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Report Designer

About Report

Designer
Report Designer works with the data in your
Sage software to analyse your business
information. It includes a comprehensive
set of tools that can be used to produce
your own customised reports.

Types of report

You can produce a whole range of business
documents.

n Operational reports.

Reports that help you take action,
such as picking lists, or sales order
shortfall lists.

Where to next?

Getting started

n What's new in Report Designer on
page 12.

n Using the workspace on page 19.

n Reports on page 28.

n Create a new report on page 37.

Next steps

n The structure of a report on page 54.

n Building your report on page 108.

n Generate and distribute reports on
page 70.

n Arrange information on page 150.

n Making reports look good on page
176.
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n Management reports.

Reports that help you take business
decisions, such fast-moving product
and service reports.

n Exception reports.

Reports that highlight any question
marks over data.

n Layouts.

Layouts are ideal when all you want
to do is print onto pre-printed
stationery such as invoices,
statements, cheques and payslips.

n Labels.

Labels for business use, such
customer address labels for
envelopes, the labelling of stock
items or fixed assets.

n Letters.

Personalised letters that thank your
customers for their orders, or a list to
remind you of outstanding
payments.

Our report design service

Our Report Design Service team are
specialists that are dedicated to designing
and producing reports. The team can
produce reports and layouts for anyone who
has Sage 50 Accounts, or Sage 50 Payroll
software.

To contact the team, chooseHelp >
Report Design Request.

Examples

n Sage 50 Accounts on page 230.

n Sage 50 HR on page 252.

n Sage 50 Payroll on page 258.
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What's new in Report Designer
What's new Description

Easier setup for
Internet email
accounts.

New setup wizard to configure Internet Mail (SMTP) accounts.

New report email
settings.

New report email settings to include BCC email addresses, and request
delivery receipts.

Sage 50 Payroll
examples in help.

New help topics for Sage 50 Payroll examples; including examples of
expressions, conditional formatting, and filters.

12
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New layout in Report Designer
The new layout of Report Designer may look slightly different to what you have used before.

Viewing the

panes
The panes on the side of the
window are now initially hidden,
to give youmore room to work on
the report.

To show a pane, hover over its
tab at the side of the window.

To keep a pane displayed, click
theAuto Hide icon.

For more information about using
panes, see Panes on page 20.

If you can't see a pane, you can
display it by selecting it from
theViewmenu.

New toolbars
The layout of the toolbars have been redesigned. If you can't see the toolbar you want, you can
display more toolbars by right-clicking the toolbar area.

Also, you can now add boxes, lines, images and data from the toolbar.

13
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For more information about using toolbars, see Toolbars on page 26.
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Getting started
n To find your way around Report Designer, see Finding features on page 17 and Using the

workspace on page 19.

n To learn about using and creating reports, seeWorking with reports on page 29 and Create a
new report on page 37.

n To set Report Designer preferences, seeOptions on page 46.

n To use the Report Browser in Sage applications, see Report Browser on page 49.

n For information on software updates, see Updates on page 51.

16
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Finding features
Tip: To reset the work area and panes to their original display, choose Tools > Options, then
select theOptions tab and enableReset Settings. The changes will bemade when you close
and then start Report Designer again.

Feature name Steps

Add a box Select Add Box from the toolbar, then click and drag in the report
to draw a box.

Add a filter ChooseReport > Filters.

Add a group ChooseSections > Add Section > Group Header And Footer.

Add a line Select Draw Line from the toolbar, then click and drag in the
report to draw a line.

Add a section filter Select the section in the report, then select Filter in the Properties
pane and click the finder button .

Add a sort ChooseReport > Sorts.

Add a text box Select Add Text from the toolbar, then click and drag in the
report to draw a box. Click inside the box to enter text.

Add a data field
(variable)

Select Add Data Field from the toolbar, or choose Toolbox >
Add Data Field.

Select a variable from the Variables pane, then click and drag in the
report to draw a box.

Add an expression Select Add Expression from the toolbar (or choose Toolbox >
Add Expression), then click and drag in the report to draw a box.
The Expression Editor will be displayed.

Add an image Select Add Image / Logo from the toolbar. Click and drag in the
report to draw a box, then select your image.

Add criteria
This feature is
only available for:
Sage 50
Accounts, Sage
50 HR, Sage
200.

ChooseReport > Criteria.

Advanced conditional
This feature is
only available for:
Sage 50
Accounts, Sage
50 HR, Sage
200.

Choose Tools > Options, then select the

17



2 | Getting started

Feature name Steps

formatting Options tab and enableUse Advanced Conditional Formatting.

Change a group sort Select the group header in the report, then select Group Sort
Direction in the Properties pane.

Conditional formatting Select the item in the report, then select Conditional Formatting in
the Properties pane and click the finder button .

Data sources Choose Tools > Data Sources.

Drill down Select the item in the report, then select Drill Down in the
Properties pane and click the finder button .

Email settings (report) Select Email Settings from the toolbar, or chooseReport >
Email Settings.

Export Choose File > Export.

Join Editor
This feature is
only available for:
Sage 50
Accounts, Sage
200.

ChooseReport > Joins.

Multi-printer settings Select the report name at the top of the Report Explorer pane, then
selectMulti-Printer Settings in the Properties pane and click the
finder button .

Page setup Select Page Setup from the toolbar, or choose File > Page
Setup.

Printer offsets Select Printer Offsets from the toolbar, or choose Tools >
Options, then select thePrinter Offsets tab.

Printer setup Choose File > Page Setup, then click Printer.

Rename a report Select Report Properties from the toolbar, or chooseReport >
Report Properties.

Report Wizard To create a new report, choose File > New > Report.

To edit a report, chooseView > Report Wizard.

Save report Choose File > Save / Save As / Save All.

Server side reporting Choose Tools > Data Sources, then click Remote.

18
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Using the workspace
The layout of the Report Designer workspace is displayed below. Your layout may look slightly
different, as the layout can be customised; for example, panes can be hidden or displayed, or moved
to different locations.

1. Toolbar.

2. Panes:
Dynamic
Help,
Variables,
File
Explorer,
Report
Explorer,
Properties.

3. Report
editor.

4. Status bar.

19



2 | Getting started

Panes
Report Designer includes a number of panes for quick access to tools and functionality.

When you first use Report Designer, most of the panes will either be hidden or displayed as a tab. If
a pane is hidden, you can show it by using theViewmenu.

How do I display panes as tabs?

Each pane can be set to be displayed all the time, or it can be automatically hidden and displayed as
a tab.To automatically hide a pane, click Auto-Hide in the top right of a pane; and to display a
pane, click Auto-Hide again.

If a pane is displayed as a tab, move themouse over the tab to display the pane.

Panes are displayed. Panes are hidden.

20
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I can't get the panes to appear

n If a pane is not visible, you can choose it from theViewmenu.

n If the pane still isn't visible, check that it isn't being automatically hidden and displayed as a
tab at the edge of the window.

n If the pane still does not appear, you can reset the Sage Report Designer desktop view to its
default. To do this, choose Tools > Options, then select Reset Settings and click OK. For
these settings to take effect, youmust then close and open Sage Report Designer.

Can I reset the screen layout back to its initial settings?

To reset the screen layout back to its initial settings, chooseView > Reset Default View.

21



2 | Getting started

Panes
Properties

To display this pane, chooseView > Properties.

TheProperties pane lists all the properties you can
change for items and sections in a report.

The properties that are displayed in the pane will
depend on the type of item that is currently selected in
the report; e.g. the properties available for a text box
will be different to a header section.

Properties can be listed by category or alphabetically;

click the Categorized or Alphabetical icons.

Tip:When you select a property, a short
description is displayed at the bottom of the
pane.

See Properties on page 186.
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File Explorer

To display this pane, chooseView > File Explorer.

The File Explorer pane lists all available pre-set reports. To
open a report, double-click one from the list.

Report Explorer

To display this pane, chooseView > Report
Explorer.

TheReport Explorer pane shows the structure of
your report, including all the pages, sections and
items. You can double-click sections to show the
variables within them. When you select an item in
Explorer, that item is also selected on your report
layout.

23
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Variables

To display this pane, chooseView > Variables.

TheVariables pane lists all the tables, variables and snippets
available for your report.

You can search for variables by using the Find box at the top
of the pane.

Use the + and - icons to expand and collapse items in a pane.

See Variables (data fields) on page 60.
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Dynamic Help

To display this pane, chooseView >
Dynamic Help.

TheDynamic Help pane provides
help with common tasks in Report
Designer.

Error List

To display this pane, chooseView >
Error List.

TheError List pane shows any errors
in your report. To view the Error List,
right-click the toolbar area above your
report and select Error List. The Error
List pane appears at the bottom of your
report.

To find the error, double-click on an
error to locate it in your report.

25
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Toolbars
Report Designer provides several toolbars for commonly used tasks. Additional tasks are available
from themenu.

n To hide or show toolbars, right-click the toolbar area and select the toolbar.

Toolbar Description

General Use this toolbar for commonly used tasks; such as save, print, and report
properties.

Alignment Use this toolbar to align, centre, and change the order of items.

Clipboard Use this toolbar for working with the clipboard; such as cut, copy, paste,
undo and redo.

Formatting Use this toolbar to apply text formatting, alignment, or styles. See Styles on
page 177.

Toolbox - Basic Use this toolbar to access more commonly tools from the Toolboxmenu;
such as adding text, boxes, lines, images, and data fields.

Toolbox -
Advanced

Use this toolbar to access remaining tools from the Toolboxmenu; such as
adding barcodes, expressions, and subreports.

Variable Use this toolbar to add variables to your report. Select a variable table and
variable from the toolbar lists, then click Insert.

View Use this toolbar to access view controls such as the zoom settings and
rulers.

Group and Lock Use this toolbar to group or lock items in your report.

26
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Status bar
The Status bar at the bottom of the screen displays: the coordinates of your cursor on your report

layout, Designer and Previewmode icons, the report page number, and the zoom setting.

27



2 | Getting started

Reports
Use the topics in this section to get started with opening and editing reports in Report Designer.
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Working with reports
Report Designer comes with a good selection of standard reports and layouts. Most people start
reporting by choosing a standard report, which they use immediately or open and amend slightly.

The following sections will help you get started with Report Designer:

Open reports

The following refers to reports but it is the same for letters, layouts or labels.

n Select the report in your main Sage software, then click Edit (orOpen).

This feature is only available for:
Sage 50 Accounts, Sage 50 HR.

n In Report Designer, choose File > Open and browse for the report you want to open.

Working with older reports?

From Sage Report Designer 2007, the file extension of reports changed. Any reports youmay have
with an old file extension are converted to use the new file extension. This is done for you when you
generate reports.

Tip: Youmay need to amend the appearance of your report. If you domake changes, save the
report by choosing File > Save As.

Create reports

If you can't find a standard report that is similar to what you want, you can create your own report
using the Report Wizard. The wizard is ideal for gettingmost of the information you want into your
report. Then you can tweak the report to get it just right.

n To start the Report Wizard, click New from the toolbar, or choose File > New > Report.

When editing a report, you work in Designermode, which shows all the items used to build your
report.

Save reports

The standard reports that comes with Report Designer are protected. Although you can't overwrite
them, you can save copies of them by choosing File > Save As. You can save:

n A report for future use, which is themost commonway people save reports. The next time
the report is opened it will use the latest data from your Sage software. The report is stored as
a *.report file.

n A snapshot of the report, which is useful if you need a record of historical information. The
next time you open the report it will show the data when the report was saved (not the current
data). The report is stored as a *.datareport file.
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Tip: To save yourself time looking for any report you will use regularly, add them to your
Favourite reports list.

Print and preview reports

Most people prefer to print their final reports from their main Sage software such as Accounts or
Payroll but you can print and preview from Report Designer.

n To preview your report, click Print Preview from the toolbar.

Tip:When previewing your report you canmake some final adjustments to improve its
look. You can resize andmove items as well as change their style, such as colour and
font. However, to make advanced changes, you will need to return to Designer mode.

To do this, click Designer from the toolbar, or chooseView > Designer.

n To print the report, click Print Preview from the toolbar. The Criteria Values window
appears. Enter the range of records you want included in your report and click OK. When the
report appears, choose File > Print.

Note: If you don't enter criteria all records are included in the report.

There aremany settings you can use to tweak your reports to get them right when printing. See Print
reports on page 71.

Distribute reports

Reports are wasted unless they are read. You can domore than just print them; you can generate
reports in a number of useful formats such as PDF or HTML. The format you choose depends on
what you want to do with the report. See Export reports on page 94.
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Change report name or description
You can set a name and a description for your report. These are displayed in your Sage software,
so usingmeaningful names and descriptions will help people find the right report.

Change the report name or description
1. Select Report Properties from the toolbar, or chooseReport > Report Properties.
2. Enter a title for the report in theReport name.

Note: You cannot change the name of the standard reports supplied with your Sage
software, you can only change the name of your own reports.

3. Enter a summary of the report in theReport description.
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Favourite reports

Introduction
Use Favourite reports to quickly find reports that you use regularly.

With some Sage software, you can open the Favouritesmenu in your main Sage software and
select the report that you want.

You can also add Favourite reports from the Report Browser. To add a report to your Favourites list,

click the Favourite icon; the icon will change to show the report is now a Favourite.

Add a report to Favourites
1. In the File Explorer pane, browse theReports folder until you find the report you want to add

to the Favouritesmenu.

2. Right-click the report and chooseAdd to Favourites.

Remove a report from Favourites
1. In the File Explorer pane, browse the Favourites folder to find the report.

2. Right-click the report and chooseRemove from Favourites.
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Arrange report information
Use the table below as a quick reference tool.

Action How?

Align information Select an item and choose Format > Alignment; or click Alignment
from the toolbar.

Select the option to align the item into position.

Tip: You can use a grid to align information. Choose Tools >
Options, then from theSnap To Mode drop-down list, select either:

n SnapToGrid: Anything you drag to a new position automatically fits
to the nearest grid line.

n SnapToLines: Blue guidelines appear when the information you
move aligns with those around it.

Group (link)
information

Grouping items allows you to treat them as a single object, for example so
they can bemoved together in a report.

Select the items that you want to group together, then choose Format >
Grouping > Group.

Lock information You can lock items to stop them from beingmoved. This is useful when
you use pre-printed stationery, as it ensures that items are not moved
accidentally and remain in the right position for printing.

Select the item that you want to lock, then choose Format > Locking >
Lock.

Alternatively, from the Properties pane, set the Locked option to True.

Tip: To unlock, select the locked information then choose Format >
Locking > Unlock.

Make information the
same size

Select the items that you want to make the same size. Choose Format >
Make Same Size.

Tip: The items are resized tomatch the first item selected.

Move information Select the item that you want to move. Hover over the border of the item so

that the pointer changes to an arrow , then drag the item to a new
position. Alternatively, you can use the arrow keys on your keyboard.

Move an item
forwards or

Tomove the position of an item so that it is in front of or behind other items,
use Format > Order.
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Action How?

backwards Tip: The Report Explorer lists overlapping information in the order that
they are positioned. Click the Report Explorer pane. Select the
appropriate Page and Section to view this information.

Resize items Select the item you want to resize. Small squares appear on the border
around the item. Click and drag on these squares to resize the item.

Select information Select Pointer from the toolbar, or choose Toolbox > Pointer.

n To select a single item, click the item once.

n To select several items, click the first item then hold downShift or
Ctrl and click other items.

Alternatively, drag a box over the items you want to select.

n To select all items, chooseEdit > Select All.

n To select horizontal rows, hold downCtrl and click to the left of the
information row.

n To select vertical rows, hold downCtrl and click above the
information column.
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Learning more about reports

Building your reports
n Construct expressions to tell Report Designer what to include in your report.

n Add headings to introduce information in your report.

n Add totals to a group of information in a report or a grand total to the whole report.

n Add page numbers to a single report or a whole print run.

n Insert images to include your company logo or branding, or perhaps pictures of your business
contacts.

n Add text, boxes and lines to add impact and clarity to a report.

n Password protect PDF reports when working with confidential or sensitive information, such
as employee payslips, customer statements, and company financial reports.

n Use a drill down link, which the reader can click to display additional information.

Arrange information
n Group information that share something in common, rather than displaying everything in a

simple list.

n Sort information into a logical order, such as post code or name.

n Filter information so that unwanted information is always excluded from a report.

n Use criteria to allow the reader to choose what information is included in the report when it is
generated; such as selecting a date range.

Making your reports look good
n Use styles to quickly change a report's appearance and give all your reports a consistent

look.

n Exclude information or only showing information of interest when a condition is met using
conditional formatting.

n Add emphasis to highlight important information or include a warningmessage when a
condition is met, using conditional formatting.

n Change the data format or lock information in a report so it can't bemoved accidentally. See
Properties on page 186.
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Distributing reports
n Email reports to individuals or groups.
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Create a new report
The Report Wizard guides you through the steps of creating a new report, layout, letter or label
document.

The wizard is ideal for gettingmost of the information you want into your report. Then you can tweak
the report to get it just right.

n To start the Report Wizard, click New from the toolbar, or choose File > New > Report.
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Document type (Report wizard)
To help get you started, there are a number of preset document types, each containing an
appropriate selection of fields and criteria. Select the document type that is the nearest match for
your requirements; you canmodify the report later if you need to change anything that you choose in
the wizard.

1. Select an appropriate document type.

The document types are grouped into folders; Report, Layout, Letter and Label.

2. To continue, click Next.
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Select fields (Report wizard)

Introduction
Each item of information is known as a variable; these contain information such as dates, addresses
and values that are stored in your data.

Variables are grouped into named tables, and the variables in each table are all related; for example,
the customer table will contain variables about the customer, such as their name or the date they
were last contacted.

Add variables to your report
To select the information that you want to appear in the report:

1. Select + to open a table .

2. Select the variable that you want to use in the report.

Tip: Hovering over the variable namewill display a short description.

l You can set theWidth orOutput length of the variable, or use the default values.

3. To add the variable to the report, click >.

The variable is added to the Fields on the report list.

l To remove a variable from this list, select it and click <.

Tip: To add all the variables in a table, select the table and click >.

4. To rearrange the order that variables will appear in the report, select a variable from the
Fields on the report list, then click the up and down arrows.

5. When you have added all the variables that you need, click Next.

Note: You can add or remove variables in your report after finishing the report wizard. See
Variables (data fields) on page 60.
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Grouping (Report wizard)

Introduction
You can divide the information in your report by using group sections; for example, youmay prefer to
see a list of contacts grouped by town or city.

Each group section in your report has a header at the start of the information set, and a footer at the
end. For example, the group header might show a title for that group, and the footer might show a
subtotal for the group.

The group header and footer are placed either side of the details section, which is themain body of
the report.

Multiple levels of grouping can be used; for example, a list of contacts could be grouped by type
(private, corporate, government), and then by city or town.

As the group section will sort information into sets, the group sort will take priority over any sorts that
are applied to information within the group. You can set up sorts in the next stage of the wizard.

Add groups to your report
To add group sections to your report:

1. From the Fields on the report list, select the variable that you want to group the section by.

2. To add the variable to the Fields to group by list, click >.

l To remove it from the list, select it and click <.

3. When you have finished adding groups, click Next.

Note: You can add or edit group sections in your report after finishing the report wizard. See
Group information on page 151.
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Sorts (Report wizard)

Introduction
Use sorting to set the order that information is displayed in the report; for example, youmay want to
have a contact list sorted alphabetically by name.

A sort is applied to the information inside all sections of a report. In group sections, the sort will
affect the order of information inside the groups, but not the order of the group sections themselves.

Add sorting to your report
To add sorts to your report:

1. From the Fields on the report list, select the variable that you want to sort by.

2. To add the variable to the Fields to sort by list, click >.

l To remove it from the list, select it and click <.

3. When you have finished adding sorts, click Next.

Note: You can add or edit sorts in your report after finishing the report wizard. See Sort
information on page 155.
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Totals (Report wizard)

Introduction
You can use totals to sum numeric variables in your report. Totals that you add with the Report
Wizard are placed in the report footer section.

Add totals to your report
To add totals to your report:

1. From the Fields on the report list , select the variable that you want to total in your report.
Only numeric variables can be selected.

2. To add the variable to the Fields to total list, click >.

l To remove it from the list, select it and click <.

3. When you have finished adding totals, click Next.

Note: You can add or edit totals in your report after finishing the report wizard. See Totals on
page 111.
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Criteria (Report wizard)

Introduction
Criteria control the information that your report displays. Without criteria, your reports would contain
information from every record in your data.

You can use criteria to select the range of information that you want in your report; for example, you
may find you want to query your report to view a particular range of information, say between certain
dates.

You can select which criteria can be set by people viewing your report.

Set criteria for your report
To set the criteria for your report:

1. To add or remove criteria from theSelected criteria list, click > (add) or < (remove).

All the available criteria are automatically added to theSelected criteria list for your report,
but theirStatewill initially be set toDisabled so they will not be available.

2. To set the state for each criteria, double-click its State column.

l Disabled: The criteria will not be used or displayed when viewing the report.

l Enabled: Enable criteria so that every time you generate the report you will be asked
to select the range of information for that criteria.

l Preset: Use preset criteria so that every time you generate the report it uses the same
criteria. The criteria is always applied to the report, and you are not prompted to
confirm or amend the criteria.

Note: Youwill be prompted to set the preset value when you click Next.

3. When you have finished setting the report criteria, click Next.

Note: You can add or edit criteria in your report after finishing the report wizard. See Using
criteria to query reports on page 161.
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Report options (Report wizard)
Before finishing the wizard, set some options for the report.

n Enter theReport Name.

n If you want to use a template with the report, click Select Template.

Using a template applies an image of the stationery to the report, to help you design the
layout.

If you want the template to be printed with the report, select Enable printing of template.

See Templates for Sage stationery on page 74.
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Data source (Report wizard)
If you are creating a new subreport, select the data source for your report.

1. Select the data source from the list.

l To edit the data sources, click Data Sources.

SeeManage data sources on page 103.

2. To continue, click Next.
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Options

Getting to this window
Choose Tools > Options.

Note: ForEmail tab options, see Email Setup Options (details) on page 88.

Options tab

Setting Description

Measurement Controls themeasurement unit used in Report Designer.

You can select the units as inches, millimetres, points, orDocument (a
unit measurement used in other software, such as Word).

Snap ToMode You can align information on your report using grid line, which is invisible in
the final report.

Choose from:

n SnapToGrid: Information you drag to a new position automatically
fits to the nearest grid line.

n SnapToLines: Blue guidelines appear when the information you
aremoving is aligned to the information next to it.

Grid Size Only used forSnapToGridmode. You can increase or reduce the
horizontal or vertical distance between the grid lines.

Show Grid Only used forSnapToGridmode. This controls whether the grid is visible

when working with your report in Designermode.

Use Element Tooltips Enable this option to display tooltips; these are small pieces of information
that pop up to describe items on your report when you hover your cursor
over them.

Keep selected
Toolbox Item active

This option is useful if you are going to add a number of the same type of
item to report, as it keeps the last Toolboxmenu item selected until you
choose a different item.

Use Advanced
Conditional
Formatting

This feature is only
available for:
Sage 50 Accounts,
Sage 50 HR, Sage
200.

Conditional formatting is used to draw attention
to, or ignore, information when a condition is met.
Advanced conditional formatting is used when
several conditions are needed. See Conditional
formatting on page 223.
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Setting Description

Use Active Complete EnableUse Active Complete to automatically suggest titles and totals
when you add variables and expressions to your report.

See Active Complete on page 227.

Sort Column List Enable this option to list variables alphabetically in the Variables pane.

Prompt to Change
Styles

When this option is enabled, if you change the font properties of an
element that uses a style, a prompt will be displayed to ask you if you also
want to update the style.

Use Tabbed Drill
Down

Enable this option to display drill down reports in a new tab, when you
preview a report in your main Sage software. Disable this option if you
want the drill down report to be displayed in a separate preview window.

Spell Check
Language

Report Designer can use a UK or US English dictionary, which will be set
at installation according to your PC's locale settings.

Printer Offsets tab

Setting Description

Printer Select the printer that the offsets (margins) will be used for, if you are going
to set Printer-specific offsets.

Printer-specific
offsets

Set the left and top offsets to be used for all reports printed using the
selected printer.

These offset settings will only be used for the selected printer. You can
select different printers and set the offsets for each individual printer. The
offsets will be used when printing all reports from this printer.

Note: The total offset will be a combination of both the report and
printer offsets.

Report-specific
offsets

Set the left and top offsets to be used for the current report.

These offsets will only be used for the current report, and will be used when
the report is printer from all printers.

Note: The total offset will be a combination of both the report and
printer offsets.

Scheme tab

Setting Description

Current Scheme Controls the colour scheme displayed while working in Report Designer.
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This feature is only
available for:
Sage 50 Accounts, Sage
50 Payroll.
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Report Browser

Introduction
The Report Browser is used tomanage your reports from your main Sage software.

The Report Browser is displayed when you choose the report option from your Sage software. The
reports displayed are related to the area or module that you were working in, and are grouped into
folders by category.

You can
n Preview the report to check it's correct.

n Add reports to your list of Favourites.

n Open the report and edit its layout.

n Change the report name and description.

n Create a new report, which opens the Report Wizard.

n Choose how you want the report to generate - print, file or email.

Using the Report Browser
n To select a report, first select a category folder, and then select the report.

Tip: If you cannot find a report, remember that Report Browser only shows reports that
are related to the area or module that you were working with in your Sage software,
before you opened the Report Browser.

n To create a new report, click New and follow the steps in the Report Wizard.

n To edit a report, select the report and click Edit.

Note: You cannot save a pre-set report, but you can save it as a new report.

n To delete a report, select it and click Delete.

Note: You cannot delete a pre-set report, only reports that you have created.

n To edit the report name or description, right-click the report and select Change name and
description. See Change report name or description on page 31.

n Tomake a copy of the report, right-click the report and select Copy Report. Enter a name
and description for the new report.
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n To print or preview a report, select it and click Print orPreview, then enter the criteria for the
report if appropriate. See Print reports on page 71.

n To export a report and save it in a different format, select it and click File.

See Export reports on page 94.

n To send the report in an email, select it and click Email.

See Email reports on page 78.

n To add the report to your list of Favourites, click the Favourite icon; the icon will change
to show it has been added to your Favourites. To remove the report from your Favourites,

click the icon again.

Favourite reports are highlighted in the folders, and also listed in the Favourites folder.

Note:With some Sage software, you can open the Favouritesmenu in your main Sage
software and select the report that you want.

n You can filter the list of reports to show reports that contain a certain report tag. To filter the
reports by a tag, select the tag from the list on the toolbar. To show all reports again, select
All.

Note: If you change the tags in your report when the Report Browser is open, this will
not be reflected in the Report Browser until you view a different report folder.

See Report tags on page 209.
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Updates

About software updates
Sage software updates are changes to your software designed to resolve issues or improve
performance. They are safe and secure and are great for keeping your software up-to-date with the
latest improvements.

There are three stages to updating your software:

n Your Sage software checks for updates.

n Available updates are downloaded to your computer.

n You install the update on your computer.

Check for updates
To check for updates:

1. ChooseHelp > Check for updates.

2. If an update is available, you can choose to download and install the update.
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Q: Updates
Click a question in the list to see the answer:

General
How do I control when updates are checked or downloaded?

Your softwaremay allow you to control how often it checks for updates and whether updates are
downloaded.

The update options that are available will vary according to the Sage software that you are using. For
more information, see the help supplied with your Sage software.

Are updates secure?

Sage software updates are open to anyone using your Sage software, regardless of access rights.

During an update, sensitive information is not transferred from your computer to Sage. The
information that is transferred is used only to check for available updates. Wewill not use this
information for any other purposes, and wewill not share this information with any other companies
or organisations.

Why do I keep getting Windows security prompts?

This is due toWindows security settings on your computer. Unless you have certain privileges you
may:

n Need to confirm you want to proceed with the update.

n Not be able to proceed with the update.

I get a message saying the service cannot be contacted

n Ensure that you have a connection to the Internet, and that you can access the Sage servers

(try browsing towww.sage.com).

n If you use a proxy server to act as a security barrier between your network and the Internet,
check that the proxy settings are correct. The software update service uses the same proxy
settings as Internet Explorer.

n If you use a firewall to act as a security barrier between your network and the Internet, ensure

that update.sage.com anddownload.sage.com are registered as allowed sites

(you can use*.sage.com if this is easier).

How much does it cost to use software updates?

There is no charge payable to Sage. Depending on your Internet connection, phone charges and
Internet charges may apply.
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Downloading updates
I get an error when downloading a software update

If you get an error when downloading an update:

n Try downloading the update again.

The problemmay simply be due to an intermittent error andmay resolve itself when you try
again.

n Check your Internet connection.

If your program can't connect to the Internet then it can't check for and download updates.

Do I need to download all available updates?

We recommend that you download all available updates ready to be installed. If an update depends
on another, Sage software updates will let you know.

If you don't want to download a particular update, clear the relevant box. Updates that you choose
not to download will appear the next time your software checks for updates.

How long will a download take?

This depends on the size of the software update and the speed of your Internet connection.

The update's Details includes a guide to how long the update will take to download. During the
download, the progress and approximate time to complete are displayed.

Installing updates
Do I need to install all downloaded updates?

We recommend that you install all available updates. If one update depends upon another, Sage
software updates will let you know.

If you don't want to install a particular update, clear the check box for that update.

Will I need to restart my computer?

This depends on the update being installed. If a particular update requires your computer to restart,
you will be asked whether you want to restart now or later. In any case, youmust close your Sage
software before you install any updates.

My company has multiple licences; do I need to update each computer?

We recommend that each computer uses the same Sage software update/version.
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The structure of a report
n To learn how the report is built from different sections such as details, header and footer; see

Sections on page 55.

n To learn how to add information from your company data in your report, see Variables (data
fields) on page 60.

n To learn how to link the information in your company data for analysis in reports, see Join
tables on page 65.
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Sections

Introduction
Sections control the layout of your report. Calculations, text and graphics used to generate the report
are placed in sections. When the report is generated, information such as report headings, page
numbers and the body of the report are laid out in the right position.

There are a number of sections that canmake up the structure of a report.

Section Description

Details The details section is typically themain body of the report.

Report Header and Footer The report header and footer contains information that is only
needed on the first and last page of the report; such as the report
title, grand totals, or an 'end of report' banner.

Page Header and Footer The page header and footer contains information needed on each
page of a report, such as column titles and totals.

Group Header andGroup
Footer

A group header and footer is used to divide report details into
groups of information that share something in common.

No Transactions If you include records with no transactions, they are displayed in
this section.

A report can contain many header and footer sections that can be reordered. For example, a report
header can be placed either before or after the page header on the first page.
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You can
n Add headers (titles) and footers (page numbers) to a report.

n Control how the information in the section is presented, such as whether the information in
the section is visible and the space it takes up in the report.

n Use groups to divide the report information into separate sets.

n Filter unwanted information from the report.

n View the sections in a report more clearly using the Report Explorer pane, which shows
every part of the report in a tree structure.

Using sections
n To add a section, chooseSections > Add Section > Report/Page/Group Header and

Footer.

If you add a group section, you can build an expression to select the information displayed in
the group. See Expressions on page 122.
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n To change the order of the sections in the report, select a section then chooseSections >
Move Section Up / Down.

Tip: You can use Active Complete to automatically add headings to the report when you add a
variable or expression.
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Q: Sections
Click a question in the list to see the answer:

How do I move a section?

Select the section you want to move. ChooseSections > Move Section Up / Down.

How do I delete a section?

Select the section. ChooseSections > Delete Section, then click Yes. Both the section header
and footer are removed from the layout.

Note: The details section can't be deleted. If you prefer not to see the details section it can be
hidden. To do this, select the section, then from theAppearance area of the Properties pane
set theVisible option to False.

How do I add a total to a section?

Select Add Expression from the toolbar, or choose Toolbox > Add Expression. Click the
report where you want to add the total. The Expression Editor opens. Drag the variable you want to
use for the total from the Fields pane into the left-hand pane, then click OK.

Tip: Ensure the Function property for the total is set toSum; this can be found in the
Properties pane.

How do I select more than one section to work on?

Hold downShift and select each section you want. When selected the section title band appears
orange. Otherwise it appears blue.

How do I stop the information in a section from printing?

Select the section you want to work with. From the Properties pane, set theSuppress Printing
option to True.

The section is hidden from preview and print but still visible in designmode.

How do I resize a section?

Select the section. From the Properties pane, change the value in theHeight option.

Alternatively, select the section thenmove your cursor to the dividing banner between this section
and the lower section. Click the dividing banner and drag the line up or down to set the desired size.

How do I hide the information in a section?

Select the section you want to work with. From the Properties pane, set theVisible option to False.

The section is hidden from design, preview and print.
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How do I force footer information to the bottom of the page?

Select the section. From the Properties pane, set theAlign to Bottom option to True.

How do I check if there are hidden sections in the report?

View the report structure using the Report Explorer pane. Every part of the report is displayed in a
tree structure.

To open the pane, chooseView > Report Explorer.
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Variables (data fields)

Introduction
Variables can be used to get information from your data, such as dates, addresses and values into
your reports. Variables are also known as data fields.

Variables are grouped into named tables. Each table contains related information of a particular type;
for example, a company or a customer. Each variable in that table contains one piece of information;
for example, the company name, or the date a customer was last contacted.

For example, a reference toCOMPANY.NAMEmeans the table name is COMPANY and the variable

name is NAME.

In addition to the tables that contain your data, there are two tables that contain variables related to
the report:

n TheREPORT table contains variables which are specific to the report. For example, the

current page or the time at which it was created.

n TheCRITERIA table contains information about the records included in the report. For

example, the range of customers or employees.

Youmay also find variables of the same name in different tables, but these are not the same.

Remember that each table stores information about a different thing, soName in a customer table

andName in a product table are different.

You can
n Add or delete variables from a report.

n Move or resize a variable.

n Change the look of the variable in the finished report (e.g. colour, font, size).

n Create formulas by combining variables with numbers andmathematical symbols; this is
known as an expression.

n Sort variables in a report to change the order of information.

n Set criteria for a report based on its variables, if you want to bemore selective about the
information that appears in the final report.

n Filter records from a report to omit those of no interest.

n Add conditional formatting to a variable to make it stand out in a report; perhaps you want to
highlight certain information.
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Add a variable to your report
To add a variable to your report:

n Select Add Data Field from the toolbar, or choose Toolbox > Add Data Field.

n From the Variables pane, select the table and variable and drag it onto your report layout.

Tip: You can search for a variable by entering its name in the Find box at the top of the
Variables pane.

n If you can't see the table you want, use the Join Editor.

This feature is only available for:
Sage 50 Accounts, Sage 200.

Tip: If you are not sure you have chosen the right variable, view its description in the
information pane below the Variables list or hover your cursor over the variable.
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Q: Variables (data fields)
Note: Variables are also referred to as data fields.

Click a question in the list to see the answer:

How do I copy a variable in a report?

Right-click the variable and chooseCopy, then right-click then choosePaste.

How do I delete a variable?

Select the variable then press Delete.

I want to choose variables as I did in a previous version of Report Designer

1. Right-click a blank section of your toolbar.

The Toolbar menu appears.

2. Click Variable.

Drop-down lists of available tables and variables appear.

3. Choose a table and variable from the drop-down lists.

4. Click on Insert.

5. Click and drag on your report to draw where you want to place the variable.

Alternatively, click once on your report where you want to insert your variable. Then select
Pointer from the toolbar. You can now move, resize and amend your variable.

Why is a variable displayed as a number instead of a description?

Some variables use numbers that have a particular meaning, for example, 1may represent 'true' and
0 'false'. These variables are referred to as coded variables.

To display a variable using its description:

1. Select the variable.

2. From the Properties pane, click theDisplay Named Values drop-down list and select
Readable Value.

For examples of coded variables, see:

n Sage 50 Accounts example: Coded variables on page 233.

n Sage 50 Payroll example: Coded variables on page 259.

How do I add page numbers to my reports?

Add thePAGE variable from theREPORT table.
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Why am I getting duplicate information on my report?

Youmight be inadvertently joining to a table which contains detail records (for example, the items on
an order) when you only want to report on the header record (for example, the order itself). As the
detail records all relate to the same header record, the variables in the header table all have the same
value for each row in the detail table.
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Add a data field (variable)
Note: Data fields are also referred to as variables.

To add a data field to your report:

1. Select Add Data Field from the toolbar, or choose Toolbox > Add Data Field.

A list of available data fields (variables) and snippets are displayed.

2. Select the data field to insert in your report.

l Data fields are grouped in tables. Click the + and - icons to expand and collapse the
tables.

l You can search for a data field by using the Find box.

3. To insert the data field, click OK

This feature is only
available for:
Sage 50 Accounts, Sage
200.
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Join tables

Introduction
The information used in your reports is stored in a database, and the variables containing this
information are stored in tables. A single table will contain a set of related variables, such as account
details, and typically a report will need to use variables frommore than one table. Whenmore than
one table is used in a report, related tables are connected together using joins, which link the related
variable that is contained in each table.

For example, say an invoice report provides details about invoices and the related customer

accounts. Theinvoice table contains variables for information related to the invoice, including an

account reference variable. Thesales ledger table contains variables for information

about customer accounts, and also includes anaccount reference variable. The two tables

can be joined by theaccount reference variable in each table, meaning that the information

for an invoice can be linked to the information for the appropriate customer.

Report Designer's set of reports already join suitable tables. If you are editing these or creating your
own reports, youmay want to include variables from a new table, and will need to join tables using
the Join Editor.

You can
n Have greater analysis of information in your report.

n Control the information returned to the report; whether to include or exclude based on the
relationship between tables. See Join properties on page 68.

Join tables in your report
1. ChooseReport > Joins.

The Join Editor appears.

2. Find the table you want in the Toolbox pane and drag it to the Join Editor's centre pane.

Tip: You can search for a table by entering its name in the Find box at the top of the
Toolbox pane.

3. To join the table, click the variable you want to join from, and drag it to the variable you want
to join to. A join appears between the two tables.
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Tip: To get a clear picture of the overall structure of tables and their joins, you can sort the
tables. In the centre pane right-click a blank area then chooseAuto Arrange > Top to
Bottom / Left to Right.

Joining multiple variables
You can connect more than one pair of variables in a table join (called a compound key).

1. Click the join connector line.

2. In the Properties window, select the From Field and enter a comma (,) followed by the
variable name to join from.

3. Select the To Field, enter a comma (,) followed by the variable name to join to.

This feature is only
available for:
Sage 200.
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Using related tables in the Join Editor
If your Sage software supports related tables, the relationships between the tables are created
automatically. When you add a table, you can choose to link to its related tables.

Add joins for related tables
Add a new table

1. ChooseReport > Joins.

2. Find the table you want in the Toolbox pane and drag it to the Join Editor's centre pane.

3. To join a table to its related tables, click Yeswhen prompted to add the links to the listed
tables. The tables and links are added to the report.

Add a join to an existing table

1. Select the table you want to add a join to.

2. Right-click and select Add related table.

3. Select the relevant table from the list. The table and the link are added to the report.
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Join properties

Getting to these setting
ChooseReport > Joins. The Join Editor appears. Click the join between the tables you want to
work with, and view the Properties pane to the right of the Join Editor.

Setting Description

Conditional Join
Type

Conditional joins are used when the report's Include Records with No
Transactions property is set to True. See Include records without
transactions on page 107.

You can use different join types to include/exclude records.

n Inner: Returns all rows frommultiple tables where the join condition
is met.

n Outer: Returns all rows from one table and only those rows from a
secondary table where the joined files are equal.

From Field Displays the variable used in the parent table.

Join Type n Inner: When amatch is found in both tables the information is
returned to the report.

n ParentOuter: Returns all information from the parent table and any
matching information from the child table, including blanks.

n ChildOuter: Returns all information from the child table and any
matching information from the parent table, including blanks.

n FullOuter: Returns all information from both the parent and child
tables.

To Field Displays the variable used in the child table.
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Generate and distribute reports
n To learn how to print reports and use templates and stationery, see Print reports on page 71.

n To send reports by email and set upmail settings, see Email reports on page 78.

n To save reports in different formats, such as Excel, HTML, CSV or PDF; see Export reports
on page 94.

n To set up a collection of reports that are sent together as a batch, see Batch reports on page
97.

n To set security options on PDF reports, see Protect your PDF reports on page 100.

n To change or configure the data source used by your reports, see Data sources and
networking on page 102.
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Print reports

Introduction
You can print reports from Report Designer or from your main Sage software.

You can
n Fine tune page settings to fit information onto a report, such as margins, page size.

n Change the report scale to a percentage of its usual size.

n Print labels using standard Avery label sizes, or set up your own custom sizes.

n Choose whether information is printed in a report or if it is printed on the first page using
appearance properties. See Appearance properties on page 191.

n Choose whether the first and last pages of a report, or a group within a report, are sent to a
different printer or printer tray. SeeMulti-printer settings on page 73.

For example, this allows you to print themain body of invoices on normal paper and the last
page as a tear-off payment form.

n Change the print area of reports to fit your printer.

Different printers place reports in slightly different positions on the page. Rather than
changing themargin size for every report, you could change the top and left outer printing
area to suit your printer (printer offsets).

n Allow or prevent grouped information in a report from breaking across pages. SeeQ: Group
information on page 153.

n Use Sage stationery for a range of reports. See Templates for Sage stationery on page 74.

Print your report
To print your report:

1. Click Print Preview from the toolbar.

The Criteria Values window appears.

2. Enter the range of records you want included in your report and click OK.

If you don't enter criteria, all records are included in the report.

3. When the report appears, choose File > Print.

Tip: You can still make some final adjustments to your report in the preview; such as moving
items, or changing their style.
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Q: Print reports
Click a question in the list to see the answer:

How do I change the report paper size?

Select Page Setup from the toolbar, or choose File > Page Setup. Use theSize drop-down to
select the report size you want then click OK.

How do I change the margins?

Select Page Setup from the toolbar, or choose File > Page Setup. Enter the size of themargins
into the boxes and then click OK.

How do I change the report scale?

From the Report Explorer pane, select the report title. From the Properties pane, findPrint Scaling
in thePrinting. Click + to display theHeight andWidth fields, and enter the values as a percentage
(%).

How do I adjust the print offset for a particular printer?

Select Printer Offsets from the toolbar, or choose Tools > Options, then select thePrinter
Offsets tab. Select thePrinter and then set thePrinter-specific offsets to adjust themargins for
that printer.

See Printer Offsets tab on page 47.

How do I generate a report in a different version of my Sage software?

Change the connection to the software database you want to use. ChooseData > Change Report
Data Source.

How do I print the layout of the report?

In Designermode , click Print from the toolbar.

How do I change the way labels are printing?

Select Label details from the toolbar, or choose Format > Page Setup and select Labels.

See Label details on page 77.

How do I save printer settings with a report?

From the Report Explorer pane, select the report title. From the Properties pane, select Save
Printer Settings from thePrinting area and set it to True.

This will save the printer options set in Page Setup (choose File > Page Setup) with the report.
When you print the report, these save settings will be used in preference to the default printer and
settings on your system.
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Multi-printer settings

Getting to this window
From the Report Explorer pane, select the report's name (at the top of the pane). From the Properties

pane, selectMulti Printer Settings, then click the finder button .

Multi-printer settings

Field name Description

Print the first page to a different print tray
or printer

Enable this setting to send the first page of the report to
a different print tray or printer. Click Settings to
choose the print tray or printer.

Print the last page to a different tray or
printer

Enable this setting to send the last page of the report to
a different print tray or printer. Click Settings to choose
the print tray or printer.

If there is only one page If the report only has one page, you can print it using
the settings for the first page, the last page, or a
normal page (using the printer settings).

Apply themulti-printer settings to the
whole report or a particular group

You can choose to apply themulti-printer settings for
either the whole report, or a particular group in the
report.

To use themulti-printer settings for a group, theremust
be a page break before and after the group. SeeQ:
Group information on page 153.
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Templates for Sage stationery

Introduction
Sage can provide a range of stationery for your business needs, which are designed to work with
Report Designer to get you the right result.

Use a template to check that your report information is in the right position to print correctly on your
Sage stationery. An image of the stationery is projected on to your report layout.

Select a report template
To select a stationery template for your report:

1. In the Report Explorer pane , select the report name at the top.

2. From the Properties pane, select Template and click the finder button .

3. Browse to the template you want and click Open.

4. If you want the template to be printed as part of the report, set thePrint Template property.

Tip: Different printers place reports in slightly different positions on the page. This can result in
information not exactly fitting your pre-printed stationery. There are several print and page
setting you can adjust to get the right fit. See Print reports on page 71.
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Print preview

Introduction
Use thePrint Previewmode to see how your report will appear when it is printed.

To preview your report:

1. Click Print Preview from the toolbar, or select View > Preview.
2. Select the criteria for your report, if appropriate.

Working in preview mode
When you are working in preview mode, you canmakeminor adjustments to your report; such as
resizing, moving and aligning items, or changing the font style.

n To return to Designer mode, select Designer from the toolbar, or chooseView >
Designer.

n To print the report, click Print from the toolbar, or choose File > Print.

n To change the page setup or select labels, select Page Setup from the toolbar, or choose
Format > Page Setup.
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Page Setup

Getting to this window
Select Page Setup from the toolbar, or choose Format > Page Setup.

Setting Description

Size Set the paper size.

Source Set the paper source (printer tray).

Portrait

Landscape

Set the page orientation as either portrait or landscape.

Left, Top, Right,
Bottom

Set the pagemargins (in millimetres).

Printer Select Printer to select a different printer.

Labels Select Labels to choose a layout for printing labels.

See Label details on page 77.
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Label details
You can edit the preset label sizes, or set up your own custom label size. Report Designer uses
standard Avery label sizes.

To edit the layout for labels:

1. Select Label details from the toolbar, or choose Format > Page Setup and select
Labels.

2. Select the label type from thePreset label size list; useCustom if you are designing your
own layout.

3. Click Advanced to display the label settings.

4. You can change the layout for your labels by setting:

l The number of labels across and down on the sheet.

l The left and topmargins, to the top-left label.

l The width and height of a label.

l The horizontal or vertical pitch, which is the width or height of the label plus themargin
to the next label.
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Email reports

Introduction
All reports can be generated and sent by email. By reports wemean:

n Reports: Detailing information about your business. Typically you will want to email the
whole report.

n Layouts: Typically statements, invoices, sales and purchase orders. Here you email many
documents to different businesses/individuals.

n Letters: Just like amail merge that uses information from your business records, such as
contact addresses, to create professional business letters.

You can also attach other documents to the email such as spreadsheets or graphs.

Report Designer works with Microsoft Outlook and Internet email services such as GoogleMail.
Before you start to email reports, we recommend you take a look at your Email Setup Options and
select your preferred email method, then do a test to make sure it works.

How it works
Email settings for a report are set using the Email Options properties, which control how the
generated information is sent by email.

Most reports and layout have basic email settings. When you email a report an email opens with the
whole report attached and ready to send. This may be fine for some documents but not for others.

For example, imagine a standard letter layout that generates a lot of individual business letters. This
might be fine to print and then post individually, but you wouldn't want to email the entire report. This
is why there are email versions of your layouts, so you can:

n Split the generated information into individual business documents.

n Use email addresses from your records and add a title to the email.

n Choose the file format of the document, such as PDF or HTML.

n Control whether emails are sent as soon as they are generated, or saved to your mailbox for
to send later (which is the default).

We recommend setting up email settings if you answer 'no' to either question:

n Is the report a one off to one person?

n Does an existing report/layout split and email information the way you want?
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You can
n Use the reports and layouts provided with Report Designer to quickly get started.

n Create your own email settings for a report or layout, if the default settings aren't right for you.

How to
n Email a report to one person or several Choose to email the report form your main Sage

software. When prompted, click Yes to confirm
you want to proceed without email options
(email settings). Select the email Provider and
then the Format you want from the drop-downs
and click OK. When the email opens enter a title
and the email addresses of the recipients and
then click Send.

Alternatively, you can do this in Report
Designer, choose File > Email > Send as
Attachment.

n Email letters or layouts (e.g. statements)
to businesses/individuals

Choose the email version of the layout you want
to use from your main Sage software. When you
choose to email the letters or layout, email
messages are sent to your Inbox ready to be
sent.

Alternatively, you can do this in Report
Designer, choose File > Email > Send with
Current Settings.

n Break up information to email individual
businesses, but I don't have an email
version that does this.

You need to enter email settings for the report.
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Q: Email reports
Click a question in the list to see the answer:

Why do I see a Microsoft Office Outlook message appearing every time I email?

Themessage is displayed if you are using Outlook 2000 build 6627 (service pack 3). It is there to
prevent security breaches.

This link will take you to the information onMicrosoft's website:
http://support.microsoft.com/kb/884998.

Why are the documents I'm generating not emailed?

Some email options send your emails to your Inbox ready to be sent. If you can't see them there or in
Sent Items, check the email software you want to use is set correctly for your computer.

To test email is working in Report Designer, choose Tools > Options, select theEmail Setup tab.
Select the way you will send your email (MAPI, Internet Mail (SMTP), orOutlook) and click Test.

How can I override Email Options to send the information as a one off?

1. Open the report or layout in Report designer.

2. Choose File > Send as Attachment.

Only the one report/document is generated for email, regardless whether the information is normally
sent as separate documents.

The email options will generate emails for all my records, but I only want a few, what
should I do?

There are a few ways to do this.

In your main Sage software select the records you want emails generated for; then generate the
report.

You could also filter the list in your main Sage software using search, so that only those records you
are interested in are displayed.

I see the error 'The email options for this report are not fully configured'

Youwill see this message if you try to email a report, but have not yet set up the report's Email
Options properties.

For help in setting up these properties, see Email Settings (Email Options) on page 82.

I see the error 'The selected email provider is not configured'

This message is displayed if you try to email a report as an attachment, but themail provider (e.g.
MAPI, Outlook, Internet Mail (SMTP)) that you selected has not yet been configured.
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To configure amail provider, select Tools > Options, then select theEmail Setup tab; see Email
Setup Options (details) on page 88.

How do I ensure that I only email each person their details?

This depends on the groups set up in the report. Groups contain variables such as contact names
and references that can be used to split the report into separate documents.

To take advantage of groups when emailing you need to set up the report's Email Options properties.

Regardless of groups, you can always email the whole report.
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Email Settings (Email Options)

Getting to these settings

Note: These email settings are for the report. You can also set up general email settings for
Report Designer; see Email Setup Options (details) on page 88.

To open the email settings, either:

n Select Email Settings from the toolbar.

n ChooseReport > Email Settings.

n Select the report by clicking the report name at the top of the Report Explorer pane. From the

Properties pane, click Email Options, then click the finder button .

Note: Email settings are only visible when you are working in Designer View.

Email Settings tab

Field name Description

Email
message
should contain

You can choose to send either:

n TheEntire Report.

n A section of the report contained in a group, if your report uses groups.

To

CC

BCC

Choose who to send the email to:

n Use To to select the primary recipients of the email.

n UseCC to select additional recipients.

n UseBCC to select recipients whose addresses will be concealed from
other recipients. This is typically used for mailing lists where the recipients
do not know each other.

Enter the email addresses:

n You can type the email addresses. Enter an email address, then click Add
to include it in the list.
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Field name Description

n You can create an expression to use email addresses contained in your
records. This is ideal when you want to email letters or statements tomany
businesses, an typical when you are using layouts.

To create an expression, click Add and enter the expression details.

Note: The report will only be emailed for records that contain valid
email addresses.

Examples

Sage 50 Accounts

If you have entered email addresses on your customer records in Sage 50
Accounts use:

SALES_LEDGER.E_MAIL

Sage 50 HR

vw_report_personcontactdetails.ContactDetails

EmailAddress

Tip: Check an email version of the document to get idea of what is
needed.

From Note: This is only supported if you select Internet Mail (SMTP) as theMail
Provider. If you useMAPI orMicrosoft Outlook, this From address will be
ignored.

Enter theName andEmail Address that will be displayed as the sender to the
recipient of the email. Alternatively, if you want to use an expression to create
either of these details, click the ... button.

If you leave this blank, the From address will be the default sender address set in
your SMTP configuration; see Email Setup Options (details) on page 88.

Subject Enter a title that will appear on the email you send. You can

n Enter as text surrounded by speechmarks, for example"Change of

address".

n Use a variable to pick up your company name. Ideal when you want to
email letters to many business. Typical when working with layouts. For

example, COMPANY.NAME
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Field name Description

n Use an expression, that is a variable and text. To do this you need to build

the syntax correctly. For example, COMPANY.NAME + "- Change

of address".

n Use an expression to include numbers. To do this you need to build the

syntax correctly, such as using aCString function.

Examples

Sage 50 Accounts

"Sales Invoice" + CString(INVOICE.INVOICE_NUM

BER)

Sage 50 HR

"Employee Number: " + CString(vw_report_emplo

yment.EmploymentWorksNumber)

Tip: Check an email version of the document to get idea of what is
needed.

Send the
report as plain
text

Include the details of the report in plain text format in the body of the email.

Send the
report as an
attachment

Include the report as a separate document attached to the email. You can send
the report in a wide selection of formats; to set the format, click Attachment
Format.

A description of how to view the attachment will be included in the email. There is
a separatemessage for each individual format, which you can edit if required.

Attachment
Format

There are several to choose from. PDF is a good choice, your documents will look
good and be easily viewed by others.

Formats available

Format Description

XML .xml XML format can be used to import the information
in the report into other software applications. XML
files are text-based, and can be viewed in XML
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Field name Description

Format Description

editors, Internet browsers, and text editors
includingMicrosoft® Notepad.

PDF .pdf PDF is a popular format that can be viewed and
printed using the free Abode® Reader®, so it is a
good choice if you want your report to be available
to a wide audience.

PDF files can be edited, but only by using tools
such as Adobe® Acrobat®, and cannot be edited
in Adobe Reader.

If you want to prevent editing, or restrict access to
the PDF, see Protect your PDF reports on page
100.

HTML .html HTML is a popular format that can be viewed or
printed usingmost Internet browsers.

Excel 97-
2003

Excel 2007

.xls

.xlsx

Excel files can be viewed inMicrosoft Excel, and
also some other compatible spreadsheet
applications such as OpenOffice Calc.

You can choose which sections of the report to
include. See Export properties on page 211.

Note: Subreports that are contained in your
report are not exported to Excel.

Plain text
Ansi

Plain text
OEM

.txt Plain text files can be viewed inmost word
processors and text editors (such as Microsoft
Notepad).

Two types of plain text format are supported:

n ANSI format uses a character set that is
primarily for use withWindows.

n OEM format uses an 8-bit character set
that is primarily for use with DOS.

CSV

CSV - Length
Delimited

.csv CSV is a text-based format that can be viewed in
most spreadsheet applications, word processors
or text editors. CSV format can be used to import
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Field name Description

Format Description

the information in the report into other software
applications.

Two types of CSV file are supported:

n CSV format produces a file in the true CSV
(CommaSeparate Value) format. Text is
contained in double quotationmarks,
without padding; numeric fields have no
quotationmarks; and commas are placed
between fields.

n CSV Length Delimited format produces a
file which is comma separated, but is more
flexible as you can specify the characters
used in the output file, and enable padding
of fields. See CSV Options properties on
page 204.

Bitmap
image

.bmp BMP format can be viewed by most image viewer
applications (such as Microsoft Paint), and can be
included in documents and presentations.

Sage Report
Data

.datareport Sage Report Data files can be viewed in Report
Designer. It is not possible to view these files in
other software applications.

Request a
delivery
receipt

Use this option to request an email receipt from the recipient's mail server when
themessage is delivered.

Note: Delivery receipts are not supported by somemail servers and not by
any MAPI mail providers.

Request a
read receipt
for this
message

Use this option if you want to receive an email to confirm that each recipient has
read the email.

Note: This will not guarantee that you will receive a read receipt when the
message is read. The recipient can choose not to send read receipts, and
some email providers and applications do not allow receipts to be sent.

Send emails
immediately

Use this option to send the report emails as soon as they are generated.

If you are using Internet Mail (SMTP), your emails are always sent
automatically.
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Field name Description

Note: Ensure your Report Designer Email Setup Options are set correctly.

Save emails
to mailbox

If you want to check the report emails before you send it to anyone, select Save
emails to mailbox. The emails will only be sent to the Inbox of your email
application.

Mail Provider n Internet Mail (SMTP): Select this if you send email using a SMTP mail
server, either within your own network or over the Internet. Typically, you
would use SMTP for an Internet-based email service such as Gmail,
Hotmail, or Yahoo.

n Microsoft Outlook: Select this if you send your email usingMicrosoft
Outlook (version 2010, 2007 or 2003).

n MAPI: Select this if your email application uses aMAPI mail server; e.g.
Outlook/Exchange.

Email Attachments tab

Field name Description

Attached Files Do you want to send out a document with emails?

Perhaps you want to include your terms and conditions each time you
contact the businesses you deal with.
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Email Setup Options (details)

Getting to this window
Choose Tools > Options, then click theEmail Setup tab.

Note: These email options will be used as the default email settings for Report Designer. You
can also set email properties for individual reports; see Email Settings (Email Options) on page
82.

Email Setup tab

Field name Description

Default Provider Select the application or service that you usemost often to send email.
You can still choose a different provider when you send an email.

n Internet Mail (SMTP): Select this if you send email using a SMTP
mail server, either within your own network or over the Internet.
Typically, you would use SMTP for an Internet-based email
service such as Gmail, Hotmail, or Yahoo.

n Microsoft Outlook: Select this if you send your email using
Microsoft Outlook (version 2010, 2007 or 2003).

n MAPI: Select this if your email application uses aMAPI mail
server; e.g. Outlook/Exchange.

WhereMAPI is
specified in the report,
use the default
provider instead

Enable this option to use the default provider in preference toMAPI, if
MAPI is selected as the provider in the report's email properties; see
Email Settings (Email Options) on page 82.

Available Providers The list shows themail providers that can be used.

n To set up amail provider, select it and click Configure.

See Internet Mail (SMTP) configuration on page 89 or MAPI
configuration on page 89

Note: Microsoft Outlook configuration is set in that
application.

n To check amail provider's settings, select it and click Test. You
can then send a test email using that provider.
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MAPI configuration
1. To start the email configuration wizard, selectMAPI from theAvailable Providers list, then

click Configure.

2. Select the profile for your email account.

Field name Description

Use default profile Choose this option to send email using the default account (profile) in
your email application; this will usually be your own email address.

Named Profile If you have several email accounts (profiles) in your email application,
and do not want to use the default account; enter the email address of
the account that you want to use.

3. Click Finish to close the wizard.

Internet Mail (SMTP) configuration
1. To start the email configuration wizard, select Internet Mail (SMTP) from theAvailable

Providers list, then click Configure.

2. You can choose from a list of email providers, or enter your own email settings.

l If your email provider is listed, select it to automatically enter the email server settings
for that provider.

l If your email provider is not listed, select Custom to enter your email settings
manually.

3. Enter the login details for your account.

Field name Description

Display Name The name of the sender that will be displayed to the email recipient;
this is typically your name.

Email Address The email address of the sender that will be displayed to the email
recipient; this is typically your email address.

Password The password for your email account.
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4. If you selectedCustom as your provider, youmust also enter your email provider's
SMTP settings.

Tip: If you are unsure of your SMTP settings and already have an email application that
is set up to use SMTP, youmight be able to check your settings in that application.
Otherwise, contact your system administrator or ISP to ensure that you're using the
correct details.

Field name Description

SMTP Server Enter the SMTP server address. This could be the address used for
your network or Internet Service Provider (ISP); for example,

smtp.talktalk.net orsmtp.gmail.com.

Port The port number used to communicate with the SMTP server; the
default is 25.

If all the other settings are correct and you still can't send email,
contact your system administrator or ISP to ensure that you are
using the correct port number.

Use Secure Socket
Layer (SSL)
connection

Select this option if your SMTP server requires a secure (SSL)
connection.

5. After you have set up your email settings, you can check them by sending yourself a test
email.

6. Click Finish to close the wizard.
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Email a report as an attachment

Introduction
You can send a report as an attachment to an email.

Before you start to email reports, we recommend you take a look at your Email Setup Options and
select your preferred email method, then do a test to make sure it works.

Email settings for a report are set using the Email Options properties, which control how the
generated information is sent by email.

Email a report
1. You can email the report form your main Sage software, or from Report Designer by choosing

File > Email > Send as Attachment.

2. Select theProvider that is used by your email application or service.

What providers can I use?

l Internet Mail (SMTP): Select this if you send email using a SMTP mail server, either
within your own network or over the Internet. Typically, you would use SMTP for an
Internet-based email service such as Gmail, Hotmail, or Yahoo.

l Microsoft Outlook: Select this if you send your email usingMicrosoft Outlook
(version 2010, 2007 or 2003).

l MAPI: Select this if your email application uses aMAPI mail server; e.g.
Outlook/Exchange.
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3. Select the file Format for the report.

What formats can I use?

Format Description

XML .xml XML format can be used to import the information in
the report into other software applications. XML files
are text-based, and can be viewed in XML editors,
Internet browsers, and text editors including
Microsoft® Notepad.

PDF .pdf PDF is a popular format that can be viewed and
printed using the free Abode® Reader®, so it is a
good choice if you want your report to be available to
a wide audience.

PDF files can be edited, but only by using tools such
as Adobe® Acrobat®, and cannot be edited in
Adobe Reader.

If you want to prevent editing, or restrict access to
the PDF, see Protect your PDF reports on page 100.

HTML .html HTML is a popular format that can be viewed or
printed usingmost Internet browsers.

Excel 97-2003

Excel 2007

.xls

.xlsx

Excel files can be viewed inMicrosoft Excel, and
also some other compatible spreadsheet
applications such as OpenOffice Calc.

You can choose which sections of the report to
include. See Export properties on page 211.

Note: Subreports that are contained in your
report are not exported to Excel.

Plain text Ansi

Plain text OEM

.txt Plain text files can be viewed inmost word
processors and text editors (such as Microsoft
Notepad).

Two types of plain text format are supported:

l ANSI format uses a character set that is
primarily for use withWindows.

l OEM format uses an 8-bit character set that
is primarily for use with DOS.

CSV .csv CSV is a text-based format that can be viewed in
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Format Description

CSV - Length
Delimited

most spreadsheet applications, word processors or
text editors. CSV format can be used to import the
information in the report into other software
applications.

Two types of CSV file are supported:

l CSV format produces a file in the true CSV
(CommaSeparate Value) format. Text is
contained in double quotationmarks, without
padding; numeric fields have no quotation
marks; and commas are placed between
fields.

l CSV Length Delimited format produces a file
which is comma separated, but is more
flexible as you can specify the characters
used in the output file, and enable padding of
fields. See CSV Options properties on page
204.

Bitmap image .bmp BMP format can be viewed by most image viewer
applications (such as Microsoft Paint), and can be
included in documents and presentations.

Sage Report Data .datareport Sage Report Data files can be viewed in Report
Designer. It is not possible to view these files in
other software applications.

4. When the email opens enter a title and the email addresses of the recipients and then click
Send.
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Export reports

Introduction
You can generate reports in a variety of different file formats, depending on what you want to do with
them.

Report formats

Format Description

XML .xml XML format can be used to import the information in the
report into other software applications. XML files are
text-based, and can be viewed in XML editors, Internet
browsers, and text editors includingMicrosoft®
Notepad.

PDF .pdf PDF is a popular format that can be viewed and printed
using the free Abode® Reader®, so it is a good choice if
you want your report to be available to a wide audience.

PDF files can be edited, but only by using tools such as
Adobe® Acrobat®, and cannot be edited in Adobe
Reader.

If you want to prevent editing, or restrict access to the
PDF, see Protect your PDF reports on page 100.

HTML .html HTML is a popular format that can be viewed or printed
usingmost Internet browsers.

Excel 97-2003

Excel 2007

.xls

.xlsx

Excel files can be viewed inMicrosoft Excel, and also
some other compatible spreadsheet applications such as
OpenOffice Calc.

You can choose which sections of the report to include.
See Export properties on page 211.

Note: Subreports that are contained in your report
are not exported to Excel.

Plain text Ansi

Plain text OEM

.txt Plain text files can be viewed inmost word processors
and text editors (such as Microsoft Notepad).

Two types of plain text format are supported:
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Format Description

n ANSI format uses a character set that is primarily
for use withWindows.

n OEM format uses an 8-bit character set that is
primarily for use with DOS.

CSV

CSV - Length
Delimited

.csv CSV is a text-based format that can be viewed inmost
spreadsheet applications, word processors or text
editors. CSV format can be used to import the
information in the report into other software applications.

Two types of CSV file are supported:

n CSV format produces a file in the true CSV
(CommaSeparate Value) format. Text is
contained in double quotationmarks, without
padding; numeric fields have no quotationmarks;
and commas are placed between fields.

n CSV Length Delimited format produces a file
which is comma separated, but is more flexible as
you can specify the characters used in the output
file, and enable padding of fields. See CSV
Options properties on page 204.

Bitmap image .bmp BMP format can be viewed by most image viewer
applications (such as Microsoft Paint), and can be
included in documents and presentations.

Sage Report Data .datareport Sage Report Data files can be viewed in Report
Designer. It is not possible to view these files in other
software applications.

Export a report
1. Choose File > Export.

The Save As window appears.

2. Browse to the folder where you want to save the file.

Tip: It is good practice to save all reports of the same type in the same location.

3. Enter the File name, and set the format of the file inSave as type.

4. Click Save to export the report.
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This feature is only
available for:
Sage 50 Accounts.
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Batch reports

Introduction
You can use batch reporting to generate a set of reports at the same time.

A batch report is a collection of individual reports that can be viewed, printed, emailed or exported
together. If you regularly produce the same set of reports together, combining them into a batch
report can save you time.

The batch report uses any email options it finds in the first report in the batch. For example, if the
first report in the batch uses a fixed email address, then the generated batch report is sent to that
email address. This is the same for any security options (password protection). If the first report in
the batch uses a fixed password to secure the PDF, then that password is applied to the generated
batch report.

Criteria from the individual reports are combined into a single criteria selection window when a batch
report is generated.

Note: Batch reports can only be generated from your main Sage software (such as Sage 50
Accounts), but not Report Designer.

You can
n Save time generating regular reports by setting them up to run as a batch.

n Save time emailing reports; rather than attaching individual reports to an email, create a batch
report and attach the one report.

n Edit or delete a batch report.

Using batch reports
Create a new batch report

1. Choose File > New > Batch Report.

2. Enter aName andDescription for the report.

3. To add reports to the batch, select each report and click Add.

4. UseMove Up andMove Down to change the order in which the reports are run.

Tip: Check the email and security options of the first report added to the batch are
compatible for all the reports in the batch as well as the finished batch report.
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5. When you have finished setting up the batch report, click Save.

Edit a batch report

1. Choose File > Open.

2. Set the file type toBatch report Files (*.batchreport), and then browse to select the file.

Delete a batch report

You can delete a batch report in either Report Designer or your main Sage software.

n In Report Designer, select the report from the File Explorer pane then click theDelete icon.

n In your main Sage software, select the report in the Report Browser and click Delete.

This feature is only
available for:
Sage 50 Accounts.
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Q: Batch reporting
Click a question in the list to see the answer:

How do I password protect my batch report?

Set the Security Options for the first report listed in the batch report to use a fixed password.
Password protection is only applied to reports that are generated as PDF.

I've used an expression to password protect my report. How does this work?

The batch report will use the password set for the first report in the batch. But more importantly, it
will only use the password found in the first record within that report.

The Email Options in my first report break up the report by person or business. Will this
work in the batch report?

No, in this instance the setting is ignored. The finished batch report produces a single report that
combines all reports within it.

How many reports can I add to a batch report?

As many as you want. However, a large report will require larger amounts of memory and disk
space.

Can I add reports to the batch from other Sage software?

Yes you can. When creating a new batch report or editing one, the Edit Batch Report window is
displayed. Use theAvailable Reports drop-down list to switch between your Sage software in
order to select reports.

I can't find my batch report. Where is it?

Batch reports are identified as *.batchreport and are stored in the batch reports folder. This folder is
only available from your main Sage software such as Sage 50 Accounts.

If I add a report to a batch report does it affect the original report in anyway?

No. The report that is added to the batch is still available to generate as an individual report.

If I delete a batch report does it also delete the reports added to the batch?

No. The individual reports will be available to generate as usual.

Why don't watermarks appear in my batch reports?

If you generate a batch report (or report selection), the watermark settings of the first report will be
used for all the following reports in the batch.
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Protect your PDF reports

Introduction
Reports published in PDF format can use security features to protect information. This is ideal when
dealing with information that is confidential or of a sensitive nature. Perhaps when dealing with
employee payslips, customer statements, and company financial reports.

When the PDF file is generated, security settings are used to protect the published report, including
a password. When someone receives a secure PDF file they must enter the password before they
can view the information.

You can
n Set a password to prevent unauthorised people opening a PDF report.

n Restrict people from copying, printing, making changes or adding notes to the PDF report.

Set report security options
To protect the report, set up the report's security options:

1. From the Report Explorer pane, select the report's name (at the top of the pane).

2. From the Properties pane select theSecurity Options and then click the finder button .

3. Set the security options for the report.

See Security Options properties on page 220.
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Q: Protect your PDF reports
Click a question in the list to see the answer:

How do I check the restrictions that have been applied to my PDF report?

To check a PDF report's restrictions:

1. Open the report in Acrobat Reader and enter its password.

2. Choose File > Document Properties and select theSecurity tab.

The document security and restriction details are displayed.

I've forgotten the password to the PDF report. What should I do?

The password is set in the report's security settings stored on the computer used to generate the
report.

Open the report in Report Designer. From the Properties pane, select Security Options and click
the finder button .

If the report uses a fixed password, disableHide the password to view the password.

If the report uses an expression, check the value of the variable in your Sage software. For example,

if the report uses EMPLOYEE.PASSWORD, check the exact spelling of the password set on the

employee's record in your Sage software.

What is meant by encrypted?

The report's content is scrambled with an encryption code, making the document unreadable to
anyone who does not have the password. To open an encrypted report youmust enter the correct
password.
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Data sources and networking

Introduction
Report Designer must be connected to the software data that you want to analyse, whether this is
on your computer or on a network. Usually the connection is made for you when opening reports
from your main Sage software. Sometimes youmay prefer to use a different data source to generate
your report, such as historical data you have archived.

You can
n Change the data source to analyse data from other Sage software that you are using.

n Improve the speed of generating reports over the network using server side reporting.

Here reports are generated on a server and the results passed to local PCs. See Sage 50
Accounts: Running reports across a network on page 104.

This feature is only available for:
Sage 50 Accounts, Sage 200.

n Configure the data sources that can be used by reports. SeeManage data sources on page
103.

Change report data source
To change the data source used by a report:

Note: Changing a report's data sourcemay stop the report from working.

1. ChooseReport > Change Report Data Source.

The Change Data Sources window appears.

2. Select the new data source that you want to use for the report, then click OK.
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Manage data sources
Tomanage the Report Designer data source connections, choose Tools > Data Sources.

Data sources that have been configured for your Sage software are displayed. If a data source
cannot be found, it will be displayed as Missing.

Add a data source

To add a new data source:

1. Click Add.

2. Enter aName and select theData Provider type.

3. To browse for a data provider file (DLL), click the ... button.

Edit data source configuration

To edit the configuration details for a data source:

1. Select the item and click Configure.

2. You can edit theName andConnection String for the data source.

Configure a remote report server

To configure a remote report server:

1. Select a data source and click Remote.

2. Enter theServer address andPort number.

TheURL for the remote source is displayed.

Note: If you have selected to use https, make sure your server is configured for HTTPS
and has the required certificates.

3. To set how long Report Designer will wait for a response from the remote server, set the
Time out length in seconds.

4. To keep the local and remote files up to date with each other, enableSynchronise files with
server.

5. To connect to the remote server for this data source, enableConnect to the Remote
Report Server for this Data Source.

Remove a data source

n To delete a connection to a data source, select it and click Remove.

This feature is only
available for:
Sage 50 Accounts.
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Sage 50 Accounts: Running reports

across a network

Introduction
Weuse the term server side reporting to describe running reports across a network. To set this up,
you will need to have some knowledge of networks and firewalls. If you are unsure about any of the
tasks described, we recommend that you contact your network administrator or the person who set
up your network.

Before you start
Ensure you have:

n A network version of Sage 50 Accounts installed on the server PC and each client PC.

n A network that uses TCP/IP protocol.

Set up tasks

Task How to

Install server side
reporting on the server
PC

Insert the Sage 50 Accounts CD. From theWelcomewindow, choose
Optional Tools. Follow the prompts to complete the installation and then
restart the server PC.

Set up firewall access
on the server PC

Enable the server to accept incoming connections through port 5976.

Your software is set up to use port number 5976. If it is unsuitable or
becomes unusable, assign another port to server side reporting from those
listed on your client PC.

Note: The port should only be used on a local area network. Opening
ports between the network and the Internet poses significant security
risks.

Set up client PC Open Report Designer on the client PC, and choose Tools > Data
Sources.

Select the data source you want to use with server side reporting, then
click Remote.
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Task How to

Enter the name of the server. Select theConnect to the Remote Report
Server for this Data Source option, then click OK.

Tip: This icon will appear at the bottom of your screen to
confirm server side reporting is active. You can double-click this icon
to open the Configure Remote Data Source window.

Copy customised
reports to the server
PC

If you have any customised reports stored on your client, copy them to the
Reports folder on the server.

Troubleshooting
If you are having problems, there are several things you could check:

Check How to

The software is
accessing the data
through a UNC path

On the client PC, open Sage 50 and chooseHelp > About. Check that
the Data Directory begins with a UNC path in the format \\<server
name>, and is not a drive letter.

Note: Server side reporting does not work on amapped drive. For
example, F:\Accounts\Accdata.

The Sage Hosting
Service is running on
the server

On the server PC, open Computer Management (e.g. right-click My
Computer and selectManage). OpenServices and Applications, then
openServices. In the service list, check that theSage Hosting Service
is listed as Started.

If the service does not have the status Started, right-click the service
name and chooseStart.

The target server
name is correct

On the server PC, right-click My Computer and select Properties.

Check that theComputer Name is the same as you set in the client; if
the name is incorrect, set up the client again.

The network protocol
is TCP/IP

On the client PC, open the Local Area Connection properties.

Check that the protocol TCP/IP appears. If you can't see the TCP/IP,
contact your network administrator.

Note: To display the properties usingWindows Vista, openControl
Panel, Network and Internet, Network and Sharing Center.
SelectManage network connections, then right-click Local Area
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Check How to

Connection and select Properties.

The client PC can find
the server PC on the
network

On the client, chooseStart > Run. In the Run window typeCMD, then

click OK. In the displayed window typeping <server name> and

press Enter.

If you get a response the client PC can find the server. If there is no
response, contact your network administrator.

The Report Service
page is accessible

On the client, open Report Designer. Choose Tools > Data Sources.
Select the data source you want to access then click Remote. Copy the
URL and paste it into a browser such as Internet Explorer.

If theReportService page appears, the client can connect to the hosting
service. If it can't connect, check your firewall settings.
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Include records without transactions
By default, Report Designer only reports on records that have transactions associated with them.

If you want to include all records, you need to set this for the report:

1. In the Report Explorer pane, select the report name (at the top).

2. In the Properties pane, find theData Source area, then set the Include records with no
transactions option to True.
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Building your report
n To learn how to add headings to your report, see Headings on page 109.

n To add totals in your report, see Totals on page 111.

n To add page numbering in your reports, see Page numbers on page 113.

n To add images, such as a logo or picture from your data, see Images on page 115.

n To add text boxes and draw lines in your report, see Text, lines and boxes on page 119.

n To learn how to use calculations and formulas in your report, see Expressions on page 122.

n To add barcodes to your report, see Barcodes on page 144.
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Headings

Introduction
Most people prefer to use text boxes to deal with headings in their report. Expressions, which can be
a variable, can also be used. Whatever you choose, headings are typically placed in the report's
page header section.

Tip: You can use Active Complete to automatically add headings to the report when you add a
variable or expression.

You can
n Control whether the headings are printed on all pages or just the first page of your report using

either a page or header section.

n Change the appearance of headings, such as the font colour or size. See Appearance
properties on page 191.

Add a heading
To add a heading:

1. Select Add Text from the toolbar.

2. Click and drag in your report to draw the text box.

3. Click the text box and type your text.

See Text, lines and boxes on page 119.
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Q: Headings
Click a question in the list to see the answer:

The heading doesn't always fully print

The amount of space allocated to the heading is too small. This can be corrected using theAuto
Grow property, which allows the space allocated to the heading to expand or decrease so that it fits
on the report. There is also aWord Wrap property youmay also find useful. See Appearance
properties on page 191.

How can I quickly align my column headings?

Select the headings. Choose Format > Alignment. You can then choose to align the headings by
Top,Middle orBottom.

How do I fix the headings on the report so they can't be accidentally moved?

Select the headings. From the Properties pane, set the Locked option to True.

I only want headings to print on the first page of my report

Move the headings into a Report Header section.

If you need to add a section, chooseSections > Add Section > Report Header and Footer.
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Totals

Introduction
A total is an expression, which can be a variable, that is typically placed in the report's footer
section.

Tip: You can use Active Complete to automatically add totals to the report when you add a
variable or expression.

You can
n Include a grand total at the end of a report.

n Add a cumulative total to each page of a report.

n Provide a total for each set of grouped information.

n On each line of your report to show a running total.

n Draw attention to the total using colour or a warningmessage when a condition is met. See
Conditional formatting on page 223.

n Change the appearance of the total, such as the number of decimal places used. See
Appearance properties on page 191.

n Link the total to additional information. See Drill down reports on page 167.

Add a total
To add a total:

1. Select Add Expression from the toolbar, or choose Toolbox > Add Expression.

2. Click in the section you want to display a total.

The Expression Editor opens. See Expressions on page 122.

3. Drag the variable you want to use for the total from the Fields pane into the left-hand pane,
then click OK.

4. In the Properties pane, check Function is set toSum.

5. To label the total, add a text box.

Select Add Text from the toolbar, or choose Toolbox > Add Text. See Text, lines and
boxes on page 119.

Tip: Instead of using the Expression Editor, alternatively you can drag and drop the variable
you want to use for the total from the Variables pane.
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Q: Totals
Click a question in the list to see the answer:

How do I change the decimal place displayed for the total?

1. Select the total. From the Properties pane, click Formatting then click the finder button .

The Formatting window appears.

2. Click theNumeric tab and use theMaximum decimal places drop-down to select the
decimal place you want.

The total doesn't always fully print

The amount of space allocated to the total is too small. This can be corrected using theAuto Grow
property, which allows the space allocated to the total to expand or decrease so that it fits on the
report. There is also aWord Wrap property youmay also find useful. See Appearance properties on
page 191.

How do I change the currency symbol displayed for the total?

1. Select the total.

2. From the Properties pane, click Formatting then click the finder button .

The Formatting window appears.

3. Click theNumeric tab and in theCurrency box, enter the symbol you want to use.

4. To change the position of the currency symbol relative to the value, use the Format drop-
down list.

The total is not calculating correctly

Check how the total is calculating. Select the total then from the Properties pane, click the Function
drop-down.

Sum is commonly used for totals in a footer section. See Function properties on page 215.
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Page numbers

Introduction
You can include page numbers and a page count in your report.

You can
n Add a simple page number to your report. For example, Page 1, Page 2, Page 3 and so on.

n Add the page number and the number of pages expected in the report. For example, Page 1 of
100, Page 2 of 100; Page 3 of 100 and so on.

n Add page numbers to a batch of reports to get the page count for each report, not the whole
batch. It would read: Page 1 of 2, Page 2 of 2, Page 1 of 5, Page 2 of 5 and so on.

Add page numbers
To add page numbers to your report:

1. Insert a text box in your report.

Select Add Text from the toolbar, or choose Toolbox > Add Text.

2. Add the text "Page" to the text box.

3. From the Variables pane, add the page numbering variables required:

l To display the page number, addREPORT.PAGE.

l To display the total number of pages in the report, addREPORT.PAGES.

l For batch reports, useBATCH_PAGE andBATCH_PAGES instead.
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Q: Page numbers
Click a question in the list to see the answer:

I have page numbers on each line of my report

The page variable may be in the Details section of your report. Check your report layout andmove
the variable to either the Page Header section or Page Footer section.

Which variables should I use to generate page numbers?

There are four variables you can use:

n PAGE: The page number when dealing with a single report. For example, Page 1, Page 2,

Page 3.

n PAGES: Indicates the number of pages expected in the report when dealing with a single

report. When use with the page variable it would read, Page 1 of 5, Page 2 of 5, Page 3 of 5.

n BATCH_PAGE: When generating a batch of reports, this variable indicates where a page is

within the batch as a whole. For example, Page 1, Page 2, Page 3, Page 4.

n BATCH_PAGES: Indicates the number of pages expected from a print run when generating a

batch of reports. Typically used with the batch page variable. For example, Page 1 of 60,
Page 2 of 60, Page 3 of 60.
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Images

Introduction
Adding images canmake your reports more professional and consistent with your company
branding.

Insert an image

Tip: You can drag and drop an image fromWindows Explorer or other compatible applications,
or copy an image to the clipboard and paste it in your report. If you use either method, a copy of
the image will be stored in your report.

1. Select Add Image / Logo from the toolbar, or choose Toolbox > Add Image / Logo.

2. Click and drag in your report to draw a box for the image.

3. Select how you want to insert the image.

l Browse my PC or network for an image.

You can choose toStore the image in the report, to place a copy of the image in the
report. If you don't store the image in the report, the image will be linked to the original
file; so if you change the external file, the image in your report will also change.

l Select an image from my application data. If you have images in your data (such
as product pictures), you can insert a variable that contains an image. See Insert
images from your data on page 118.

l Build an expression to select an image. You can create an expression that will
select the image.

Note: The image will initially be set so that it does not distort when it is resized; to change this,
use the Lock Aspect Ratio property.

Other tasks
You can also:

n Lock an image into position on your report. See Behaviour properties on page 201.

n Control whether the image is printed or not. See Appearance properties on page 191.

n Control the space allocated to an image, using theSize Method property. This is useful if
you are calling images of different sizes to the same position on each page throughout a
report. See Appearance properties on page 191.
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n Make an image appear in the report only when a certain condition is met. See Conditional
formatting on page 223.

n Add a hyperlink to the image if you intend to generate an electronic copy of the report such as
a PDF. Perhaps you want your company logo on the report to link to your website address.
See Drill down reports on page 167.
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Q: Images
Click a question in the list to see the answer:

Which image formats can I include in my report?

n Bitmap files: *.bmp, *.gif, *.jpg, *.png, *.ico

n Metafiles: *.emf, *.wmf

I'm sure my report included an image, but I can't see it. How can I find it?

If you cannot see an image in your report layout, select the image from the Report Explorer pane.
Alternatively, you can hover over the area where the image was placed to display the image box.

The imagemay not be displayed if:

n It is a linked image (i.e. it is not stored in the report), but the original image that it was linked to
has since beenmoved or deleted. Select the image in your report, then in the Properties
pane, check that the Filename setting points to the image.

n The image is not set to be visible. Select the image in your report, then in the Properties pane,
check theVisible property andmake sure it is set to True.

Some of the images don't fully print

The amount of space allocated to the images is too small. Check that the image's Size Method
property is set toAutoGrow. This allows the space allocated to the image to expand or decrease so
that it fits on the report. From the Properties pane, chooseSize Method > AutoGrow.

How do I insert an image from my data?

You can insert an image contained as a variable in your data, e.g. a product image.

1. Select Add Image / Logo from the toolbar, or choose Toolbox > Add Image / Logo.

2. Click and drag to draw the box for your image in your report.

3. ChooseSelect an image from my application data.

4. Select the image variable that you want to add. Only variables with an image format will be
listed.

How do I insert an image from a website?

To insert an image from awebsite, first copy the image to the clipboard, and then paste it in your
report.

1. How you copy the image from awebsite will depend on your Internet browser; typically, you
can right-click on the image and select Copy.

2. To paste the image in Report Designer, chooseEdit > Paste.
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Insert images from your data

Introduction
You can insert images that are contained in your main Sage software data; for example, product
images.

Insert an image from your data
1. Select Add Image / Logo from the toolbar, or choose Toolbox > Add Image / Logo.

2. Click and drag in your report to draw a box for the image.

3. Select Select an image from my application data.

Note: The variables in your data that contain images are displayed. A message will be
displayed if there are no variables in your data that contain images.

4. Select the variable from the application data.

A sample image from the data is displayed.

5. To insert the image variable in your report, click OK.
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Text, lines and boxes

Introduction
Adding text, lines and boxes adds impact and clarity to a report.

You can
n Change the appearance of text, lines and boxes, such as colour and style. See Appearance

properties on page 191.

n Lock them into place on your report so they can't be accidentally moved. See Arrange report
information on page 33.

n Control whether they print or not in your final report. See Appearance properties on page 191.

n Make them appear in the report only when a certain condition is met. Particularly useful when
dealing with warningmessages. See Conditional formatting on page 223.

Add text, boxes and lines
Add text

1. Select Add Text from the toolbar, or choose Toolbox > Add Text.

2. Click and drag in your report to draw the text box.

3. Click in the box and type your text.

Tip: You can set Background orBorder properties for the box. See Appearance properties on
page 191.

Draw a box

1. Select Draw Box from the toolbar, or choose Toolbox > Draw Box.

2. Click and drag in your report to draw the box.

Tip: You can set Background orBorder properties for the box. See Appearance properties on
page 191.

Draw a line

1. Select Draw Line from the toolbar, or choose Toolbox > Draw Line.

2. Click and drag in your report to draw the line.
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Tip: Use the Line style property to set the style, colour or width of the line. See Line style on
page 199.
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Q: Text, lines and boxes
Click a question in the list to see the answer:

The text in a text box doesn't always print fully

The text box size isn't big enough for the information returned from the database. This can be
corrected using theAuto Grow property, which allows the space allocated to the information to
expand or decrease so that it fits on the report. There is also aWord Wrap property youmay find
useful. See Appearance properties on page 191.

Is there an easier way to add titles to my report?

You can use Active Complete to automatically add titles to the report when you add a variable or
expression.

See Active Complete on page 227.

How do I edit text?

Double-click the text box you want to change. Enter the revised text. When you next click outside
the text box, the border disappears, leaving the revised text.

Why is there are warning icon appearing on my report?

At some point a text box has been added to the report but without any text inserted.

To delete the text box, select the icon and then press Delete.

To use the text box, double-click it and then enter text.
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Expressions

Introduction
An expression tells Report Designer what information to include in a report. When the report is
generated, each expression is calculated to produce a value. This valuemay come directly from the
database, or be the result of further calculations on the information in the database.

An expression is a formula that can include:

n Numbers.

n Text.

n Variables, which are your data names and the table it belongs, such as REPORT.PAGE.

n Functions, used for complex mathematical processing such as string functions.

n Operators that can be words such as NOT orLIKE and symbols such as less than<,

greater than>, or equal to=. They include wildcards such as %, which replace single or

multiple characters and are used to search for values where there is more than one possible
result.

There are some rules to follow when constructing an expression (seeQ: Expressions and snippets
on page 126). To help construct expressions, an Expression Editor is displayed when you work with
expressions.

You can use expressions to:
n Show information on the report.

n Filter the information that appears on the report.

n Highlight information in a report using conditional formatting.

n Divide information on the report into groups.

n Sort report information.

n Create criteria for a report to manage the data you want included each time the report is
generated.

n Create a drill down target.

n Generate the email addresses a report should be sent to.

n Password protect a PDF document.

n Control the way the information appears and behaves on the report using properties.

122



Report Designer

Add an expression
To add an expression:

1. Select Add Expression from the toolbar, or choose Toolbox > Add Expression.

2. Click the report where you want to add the expression.

The Expression Editor appears.

3. To construct the expression drag and drop variables and functions from the right-hand panes
into the left-hand pane.

Tip: You can view the values/information associated with a variable (as stored in your data)
using the Expression Editor. Select the variable from the Fields pane, then click Show Field
Values.
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Tip:
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Q: Expressions and snippets
Click a question in the list to see the answer:

Expressions
Are there any rules to follow when constructing an expression?

Yes, the expressionmust follow these rules:

n Text must be in double quotationmarks. For example, "name".

n The word 'null' represents a blank date. For example,

SALES.LEDGER.DATE.ACCOUNT_OPENED=NULL.

n Dates must be entered between# characters. For example, #01/12/2001#.

n Spaces between functions, variables and numbers/text are ignored.

n Text functions can be entered in either upper of lower case.

Tip: For ease of reading, you can indent parts of an expression or start parts on a new line.

What wildcards can I use in an expression?

There are two types:

n _ for single characters.

n % for multiple characters.

To use% as a wildcard, enter it as part of a word between double quotationmarks. If you use

% outside of quotationmarks, it will be interpreted as a function.

How does the Expression Editor help?

The editor can help you because:

n It shows the variables and functions you can use in an expression so you don't have to
remember them.

n It checks that the expression is valid.

n It shows tooltips for function parameters.

n It provides 'syntax colouring' to make it easier to read the expression.

n It has a predictive text feature.

How do I copy an expression?

Right-click the expression and chooseCopy. Right-click the report area where you want to paste
the expression, and choosePaste.
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How do I delete an expression?

Select the expression, then press Delete.

How do I edit an expression?

Double-click the expression to open the Expression Editor.

What is a syntax error?

The expression is not correct and should be amended. The error will be highlighted in red in the
Expression Editor.

What are recursive expressions?

Recursive expressions occur when two expressions reference each other and the calculation
cannot be completed.

For example, expression A is expression B divided by two; but expression B is expression A
multiplied by two.

Snippets
How do I insert an expression snippet?

Open the Expression Editor (double-click the expression on your report). From the Functions pane
on the right, scroll down to theSnippets folder. Double-click the snippet you require to insert it in the
expression.

How do I edit a snippet?

Choose Tools > Expression Snippets Manager. Select the snippet and click Modify. Click Build
to edit the snippet using the Expression Editor.

How do I save a snippet?

Double-click the expression. The Expression Editor appears. Click Save As Snippet. The
Expression Snippets window appears. Enter details for the snippet then click OK.

How do I delete a snippet?

Choose Tools > Expression Snippets Manager. Select the snippet and click Remove.

This feature is only
available for:
Sage 50 Accounts, Sage
50 HR, Sage 200.
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Expression Snippets

Getting to this window
The options in this window will be different depending on whether you are:

n Saving a snippet from the Expression Editor, by clickingSave As Snippet.

n Managing your snippets, by choosing Tools > Expression Snippets Manager.

Save As Snippet (from the Expression Editor)

Name Description

Choose theGroup to
save into

Displays the snippets that have been created ready for future use.

You can store snippets into a standard folder calledMySnippets, or you
may prefer to set up folders that aremoremeaningful to you andmake
them easier to find. You do this by clickingAdd.

Name Enter the snippet's name; this appears in the Functions pane of the
Expression Editor.

Description The description is optional, and can be used to give a bit more information
about your snippet and its intended use.

Author The author name is optional.

Expression The expression for the snippet is displayed. The expression cannot be
changed here, you would need to close this window and return to the
Expression Editor.

Add Use to create folders to store your snippets.

Remove Use to delete a folder and all its snippets.

Expression Snippets Manager (from the Tools

menu)

Name Description

Groups (left-hand
pane)

Displays the snippets that have been created.

You can store snippets into a standard folder calledMySnippets or you

128



Report Designer

Name Description

may prefer to set up your own folders (groups) that aremoremeaningful to
you. To add a new folder, click Add Group.

Description The description is optional, and can be used to give a bit more information
about your snippet and its intended use; to change this, click Modify.

Author The author name of the snippet is optional; to change this, click Modify.

Expression The expression for the snippet is displayed; to change this, click Modify.

AddGroup Use this to create new group folders to store your snippets.

Add Use this to create a new snippet.

See Add an expression snippet on page 130.

Remove To delete a folder or snippet, select it and click Remove.

Modify To change a snippet, select the snippet and click Modify.

See Add an expression snippet on page 130.

This feature is only
available for:
Sage 50 Accounts, Sage
50 HR, Sage 200.
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Add an expression snippet

Getting to this window
1. Choose Tools > Expression Snippets Manager.

2. To create a snippet, click Add; or to change a snippet, select it and click Modify.

Add or modify an expression snippet

Name Description

Name Enter the snippet's name; this appears in the Functions pane of the
Expression Editor.

Description The description is optional, and can be used to give a bit more information
about your snippet and its intended use.

Author The author name is optional.

Expression The expression you constructed is displayed.

To create or edit the expression, click Build.
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Functions
You can use the following functions and operators to build expressions.

n Accounts functions on page 132.

n Aggregates functions on page 133.

n Color functions on page 134.

n Date and time functions (DateTime) on page 135.

n Math functions on page 137.

n String functions on page 139.

n Operators on page 141.
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Accounts functions
Below is a list of Accounts functions, which can be used in expressions.

Accounts function Example - before using
function

Example - after using
function

Unsigned (= to omit a sign) +25

-25

25

25

Reversed (= to reverse the
sign)

+25 -25

Debit (= to only show debit
values)

25 (credit)

25 (debit)

0

25

Credit (= to only show credit
values)

25 (credit)

25 (debit)

25

0

Note: To apply one of these functions to a variable, you can also use the Properties pane.
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Aggregates functions
Below is a list of Aggregates functions, which can be used in expressions.

Function Description

Avg (value) This function shows the average value of a variable.

If a variable average is in a footer section, it shows the average of all
the values in the section above.

If the variable is in the details section, it will show the average at each
point in the list of values.

Count This function replaces the values of your variable with a numbered
list.

For example, in preview your report shows the following values for a
variable: 32.1, 58.3 and 49.0. If you apply Count to that variable, your
report will replace those values with: 1, 2, and 3.

If the variable is in a footer section, it shows the total number of
records.

CountIf (count) Replaces value with a numbered list if it fits a condition.

Max (value) This function shows themaximum value of the variable.

If the variable is in a footer section, it shows themaximum of all the
values in the section above.

If the variable is in the details section, it shows the variable's
maximum value at each point in the list of values.

Min (value) This function shows theminimum value of the variable.

If the variable is in a footer section, it shows theminimum of all the
values in the section above.

If the variable is in the details section, it shows the variable's
minimum value at each point in the list of values.

Note: To apply one of these functions to a variable, you can also
use the Properties pane.

Sum (value) This function shows the sum of a variable.

If the variable is in a footer section, it shows the total of all the values
in the section above.

If the variable is in a details or group header section, it shows the
running total of the values on the report.
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Color functions
Below is a list of Color functions, which can be used in expressions.

Function Description

ARGBColor (alpha, red,
green, blue)

UseARGBColor to specify a colour with a transparency (alpha).

In the brackets, enter the level of alpha (transparency), and the
amount of red, green and blue. The values must be in the range
from 0 (no colour) to 255 (full colour). For alpha, 0 is transparent and
255 is opaque.

NamedColor (name) Specify a colour by name.

Tomake values of less than 0 appear red.

RGBColor (red,green,blue) UseRGBColor to specify a solid colour.

In the brackets, enter the amount of red, green and blue. The values
must be in the range from 0 (no colour) to 255 (full colour).
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Date and time functions (DateTime)
Below is a list of DateTime functions, which can be used in expressions.

Function Description

DateTimeToFormattedString
(date, format)

Converts the value of a DateTime instance to its equivalent
string representation.

DateTimeToString (date) Converts the value of a DateTime instance to its equivalent
string representation.

Days(d) Returns a TimeSpan that represents the specified number of
days, where the specification is accurate to the nearest
millisecond.

DaysInMonth (year, month) Returns the number of days in the specifiedmonth and year.

Hours(d) Returns a TimeSpan that represents the specified number of
hours, where the specification is accurate to the nearest
millisecond.

IsLeapYear (year) Indicates whether the specified year is a leap year.

Milliseconds(d) Returns a TimeSpan that represents a specified number of
milliseconds.

Minutes(d) Returns a TimeSpan that represents the specified number of
minutes, where the specification is accurate to the nearest
millisecond.

Now Gets a DateTime that is set to the current date and time on this
computer, expressed as the local time.

ParseDateTime(s) Converts the specified string representation of a date and time
to its DateTime equivalent.

Seconds(d) Returns a TimeSpan that represents the specified number of
seconds, where the specification is accurate to the nearest
millisecond.

Ticks(l) Returns a TimeSpan that represents a specified time, measured
in the unit of ticks.

Note: Ticks are 100-nanosecond units of time. A particular
date can be expressed as the number of ticks since 12:00
midnight, January 1, 0001 A.D. (C.E.) in the Gregorian
Calendar.
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Function Description

UtcNow Gets a DateTime that is set to the current data and time on this
computer, expressed as the Coordinated Universal Time (UTC).
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Math functions
Below is a list ofMath functions, which can be used in expressions.

Function Description

Abs(d) Returns the absolute value of a specified number.

Acos(d) Returns the angle whose cosine is the specified number.

Asin(d) Returns the angle whose sine is the specified number.

Atan(d) Returns the angle whose tangent is the specified number.

Atan2(y, x) Returns the angle whose tangent is the quotient of two specified
numbers.

BigMul(a, b) Produces the full product of two 32-bit numbers.

CDouble(i) Converts an integer to a floating-point number.

Ceiling(d) Returns the smallest integer greater than or equal to the specified
number.

CInt(d) Converts a floating-point number to an integer.

Cos(d) Returns the cosine of the specified angle.

Cosh(d) Returns the hyperbolic cosine of the specified angle.

e Represents the natural logarithmic base, specified by the
constant, e.

Exp(d) Returns e raised to the specified power.

Floor(d) Returns the largest integer less than or equal to the specified
number.

IEEERemainder(x, y) Returns the remainder resulting from the division of a specified
number by another specified number.

Log(d) Returns the logarithm of a specified number.

Log10(d) Returns the base 10 logarithm of a specified number.

Max(val1, val2) Returns the larger of two specified numbers.

Min(val1, val2) Returns the smaller of two numbers.

Pi Represents the ratio of the circumference of a circle to its
diameter, specified by the constant Pi.

Pow(x, y) Returns a specified number raised to the specified power.
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Function Description

Round(d) Rounds a value to the nearest integer.

RoundDP(d, decimals) Rounds a value to the specified number of decimal places.

Sign(d) Returns a value indicating the sign of a number.

Sin(d) Returns the sine of the specified angle.

Sinh(d) Returns the hyperbolic sine of the specified angle.

Sqrt(d) Returns the square root of a specified number.

StringToFloat(s) Converts the string representation of a number to its floating-point
equivalent.

StringToInteger(s) Converts the string representation of a number to its integer
equivalent.

Tan(d) Returns the tangent of the specified angle.

Tanh(d) Returns the hyperbolic tangent of the specified angle.

Truncate(d) Calculates the integral part of a number.
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String functions
A string is a sequence of characters used to represent text.

Below is a list of String functions, which can be used in expressions.

Function Description

Compare(s1, s2) Compares two specified strings.

Concat(s1, s2) Concatenates two specified instances of string.

Contains(s1, s2) Returns a value indicating whether the specified string occurs
within a string.

CString(value) Returns a string that represents the given item on the report.

EndsWith(s1, s2) Determines whether the end of an instance of stringmatches a
specified string.

FormatString(format, args) Replaces each format item in a specified string with the text
equivalent of a corresponding object's value.

IndexOf(s1, s2) Reports the index of the first occurrence of the specified string in
this instance.

Insert(s1, s2, index) Inserts a specified instance of string at a specified index position in
this instance.

LastIndexOf(s1, s2) Reports the index of the last occurrence of the specified string in
this instance.

Length(s1) Gets the number of characters in this instance.

PadLeft(s1, c, count) Right-aligns the characters in this instance, padding on the left
with a specified character for a specified total length.

PadRight(s1, c, count) Left-aligns the characters in this instance, padding on the right with
a specified character for a specified total length.

Remove(s1, start, length) Deletes a specified number of characters from this string.

Replace(s1, replace, with) Replaces all occurrences of a specified string in this instance with
another specified string.

StartsWith(s1, s2) Determines whether the beginning of an instance of stringmatches
a specified string.

Substring(s1, start, length) Retrieves a substring from a string.

ToLower(s1) Converts a string to lower case.
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Function Description

ToUpper(s1) Converts a string to upper case.

Trim(s1) Removes all occurrences of white space characters from the
beginning and end of a string.

TrimEnd(s1) Removes all occurrences of white space characters from the end
of a string.

TrimStart(s1) Removes all occurrences of white space characters from the
beginning of a string.
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Operators
Below is a list of Operators, which can be used in expressions.

Operator Action

+ Add numbers or text.

- Subtract numbers or text.

* Multiply values

/ Divide.

% The remainder of a division (modulus); for example, 5%2 = 1.

^ Raise to the power of. This raises the value on the left hand side to the
power on the right hand side; for example, 3 ^2 = 9.

= Equals (numbers).

<> Not equal to.

> Greater than.

< Less than.

>= Greater than or equal to.

<= Less than or equal to.

() Use rounded brackets to enter more than one calculation in your expression.
Report Designer will use the calculation within the brackets first.

, Separate values supplied as parameters to a function.

; Separates expressions to be executed as part of a begin/end block.

AND And/also. To include two or more different rules in your expression. Report
Designer will only choose records that meet all the conditions of your
expression.

OR Either/or. TheOR operator allows you to link expressions together. Report

Designer will select data if one or more of the clauses of your expression is
true.

NOT Not true. Use this to exclude data or to test conditions.

LIKE LIKE is the text equivalent of =. However, you can only useLIKE with

text. You can also combineLIKE with wildcards.

NOT LIKE Use this to apply an exclusion clause in your expression.
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Operator Action

: Use a colon as a separator.

-> Use this to check for a property in the value on the left, e.g. TextStyle-

>Color := NamedColor("Red").

:= Assign a value, e.g. Visible := False;.

? : Select one of two options- use this to select one of two possible options,
based on the result of a test.

TRUE True can be used as part of a comparison filter to check if a variable

contains a date. Or as an assignment within a conditional formatting
expression. For example, to prevent text from automatically wrapping to a

new line in a text box, useWordWrap:=True.

FALSE False can be used as part of a comparison filter to check if a variable does

not contain a date. Or as an assignment within a conditional formatting
expression. For example, to prevent text from automatically wrapping to a

new line in a text box, useWordWrap:=False.

NULL Use this to indicate the field has no value. For example, to indicate no

border, useBorder:=Null.

IF Use this to execute an expression only if a condition is met. The optional

ELSE section allows you to execute a different expression if the condition is

not met. Use withBEGIN andEND to executemultiple expressions.

THEN Use this to execute an expression only if a condition is met. The optional

ELSE section allows you to execute a different expression if the condition is

not met. Use withBEGIN andEND to executemultiple expressions.

ELSE Use this to execute an expression only if a condition is met. The optional

ELSE section allows you to execute a different expression if the condition is

not met. Use withBEGIN andEND to executemultiple expressions.

BEGIN BEGIN is a text equivalent of {.

END END is the text equivalent of }.

{} Grouping brackets, to groupmultiple expressions together. These brackets
allow all of the expressions in the group to be executed in sequence.

BEGIN andEND are text equivalents of { and}.

SWITCH To select which expression to execute based on the value of a field or the
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Operator Action

value returned from a function. Use withBEGIN andEND to execute

multiple expressions.

CASE To select which expression to execute based on the value of a field or the

value returned from a function. Use withBEGIN andEND to execute

multiple expressions.

DEFAULT To select which expression to execute based on the value of a field or the

value returned from a function. Use withBEGIN andEND to execute

multiple expressions.
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Barcodes

Introduction
Report Designer supports a range of barcode symbols that control the appearance of a barcode.

Typically, barcodes are one dimensional, displayed as a series of parallel bars of varying widths and
spaces. But there are two dimensional barcodes that are displayed as patterns of squares, dots and
hexagons.

For one dimensional barcodes, all of the information can be read by scanning the image in one
direction (usually horizontally, from left to right) only. For two dimensional barcodes, the imagemust
be scanned in its entirety.

Each barcode is designed for different uses, printers, displays and readers. There is a limit to the
number of symbols some barcodes display; for example, UPCE only allows eight symbols. You
need to take this length into account when creating an expression for the barcode.

You can
n Change the type of barcode type used (referred to as symbology).

n Change the appearance of the barcode, such as its colour.

n Control the size of the barcode.

n Display text with the barcode that represents the data.

n Lock the barcode into place on the report layout so it can't be accidentally moved. See
Arrange report information on page 33.

n Make a barcode appear in the report only when a certain condition is met. See Conditional
formatting on page 223.

Add a barcode
To add a barcode:

1. Select Add Barcode from the toolbar, or choose Toolbox > Add Barcode.
2. Click your report where you want to add the barcode.

The Expression Editor appears.

3. Enter an expression to select the information used to generate the barcode.

To do this, drag and drop variables and functions from the right-hand panes into the left-hand
pane.
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4. To set the barcode format, from the Properties pane select Barcode Format and click the
finder button .
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Q: Barcodes
Click a question in the list to see the answer:

Why does the barcode not fully print?

First, check the type of barcode you are using. There is a limit to the number of symbols some
barcodes display. For example, UPCE only allows eight symbols. To do this, right-click the barcode
and select Change Barcode Format, then check theSymbology setting.

Alternatively, it could be that the amount of space allocated to the barcode is too small. This can be
corrected by changing the barcode's Size Method property. To do this, select the barcode, then
from the Properties pane, select theSize Method to be used. See Appearance properties on page
191.

How do I change the look and size of the barcode?

How There are several things you can change, such as the colour of the barcode. To do this, right-
click the barcode and select Change Barcode Format. See Edit Barcode Format on page 147.

Can I change the text displayed with the barcode?

No. The text shows the same data that is represented by the barcode.

How do I change the position of the text displayed with the barcode?

Right-click the barcode and select Change Barcode Format. Use the Text Location drop-down
list to select the text position, then click OK.

How do I change the style of font used for the barcode's text?

From the Properties pane, select Text Style and click the finder button . TheModify Text Style
window appears. Select the font style you want to use then click OK.

How do I improve the quality of the barcode image?

First, open the Barcode Format settings. Right-click the barcode, then select Change Barcode
Format.

n Tomake the barcode image sharper, increase theResolution value. Typically the resolution
is set to 300 DPI, but if this is not adequate then try increasing the value to something like
600 DPI. When you increase the resolution, the size of the image will also increase, so the
file size of the generated report will also increase.

n If the report is to be viewed on screen, using theAnti-alias image setting will increase its
clarity by smoothing edges. This will have limited effect on the sharpness of a printed
barcode, where it will bemuchmore effective to increase the resolution.

n You could also check the controls on the barcode's size to see if the image is stretched or
clipped. To do this, select the barcode, then from the Properties pane, select theSize
Method to be used. See Appearance properties on page 191.
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Edit Barcode Format

Getting to this window
Select the barcode you want to work with, then from the Properties pane select Barcode Format
and click the finder button .

Field name Description

Symbology Controls which symbol is used for the barcode image.

Typically, barcodes are one dimensional, displayed as a series of parallel
bars of varying widths and spaces. But there are two dimensional barcodes
that are displayed as patterns of squares, dots and hexagons.

For one dimensional barcodes, all of the information can be read by
scanning the image in one direction (usually horizontally, from left to right)
only. For two dimensional barcodes, the imagemust be scanned in its
entirety.

Each barcode is designed for different uses, printers, displays and readers.
There is a limit to the number of symbols some barcodes display; for
example, UPCE only allows eight symbols. You need to take this length
into account when creating an expression for the barcode.

Include Checksum Also referred to as check digit. It is used to check the barcode has been
read correctly when scanned. It is a single digit added to the end of the
barcode. The digit is calculated based on the information in the barcode.
When the barcode is scanned the reader checks the barcode against the
check digit calculation.

Note: Some barcodes don't support this check.

Text Location Controls where the barcode text is displayed. Choose to display text above
or below the barcode. Or you can decide not to show the text. However, text
is important should the printed barcode become damaged or of poor quality.

Text Spacing Controls the space between the text and the barcode.

Tip: To change themeasurement unit, choose Tools > Options, then
on theOptions tab set the layoutMeasurement unit.

Bar colour Controls the colour of the bars in the barcode.

Tip: Black bars are the optimum colour for barcodes with white spaces
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Field name Description

as the background.

BarWidth Controls the width of a single bar.

The size of each barcode symbol is subject to upper and lower limits. For
example, the EAN-13 symbology has amagnification range of 80% to 200%
of its specific nominal size.

Any change to the barcode's size should be proportionate otherwise it will
affect scan rates.

Tip: To change themeasurement unit, choose Tools > Options, then
on theOptions tab set the layoutMeasurement unit.

Bar Height Controls the height of the barcode.

The size of each barcode symbol is subject to upper and lower limits. For
example, the EAN-13 symbology has amagnification range of 80% to 200%
of its specific nominal size.

Any change to the barcode's size should be proportionate otherwise it will
affect scan rates.

Tip: To change themeasurement unit, choose Tools > Options, then
on theOptions tab set the layoutMeasurement unit.

Wide: Narrow Controls the ratio between the size of wide bars to that of narrow bars.

Perhaps you have a specific a barcode format you want to achieve, you
could use this setting to get the desired result. However, the default setting
works in most cases.

Note: Some barcodes don't support this.

Anti-alias Image This wil produce a smoother barcode image. This improvement in quality
may affect the speed of generating and printing reports or labels.

Resolution Controls the fineness of an image, which is measured in DPI (dots per inch).
The higher the DPI the finer the barcode. It is worth considering the
capability of the printer and printer driver used to print the barcodes before
increasing the resolution. High-resolution barcodes may affect the speed of
generating and printing reports or labels.

Rotation Angles the barcode and its text to match how it will be fed to the reader.

Preview Gives you an image of the barcode based on your current settings.
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Field name Description

The example uses values 0-9, but you can enter any value you want to
check.
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Arrange information
n To learn how to divide information in your report into grouped sections, seeGroup information

on page 151.

n To set the order that information is sorted in your report, see Sort information on page 155.

n To remove unwanted information from a report, see Filter information on page 158.

n To learn how to set up the criteria that can be used for report queries, Using criteria to query
reports on page 161.

n To set up links in your report that display related information, see Drill down reports on page
167.

n To embed a different report inside a report, see Subreports on page 172.
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Group information

Introduction
You can divide report information into groups that share something in common. For example, you
may prefer to see a list of contacts grouped by town or city.

Each group section has a header at the start of the information set and a footer at the end of the
information set. A group header can be used to show a title that indicates what is contained in the
group. A group footer can be used to show a total or subtotal for the group.

The details section (themain body of the report) sits between the group header and footer on your
report layout. We recommend you deal with your details section before grouping the information.

Multiple levels of grouping can be used. For example, a list of contacts could be grouped by type
(private, corporate, government) and then by city or town.

A group section has an expression that controls how the information is divided into the different sets
of information, such as date, name or post code. By its very nature the group sorts information into
sets. The information in these sets can then be sorted. The group sort always takes priority over
other sorts.

You can
n Add headers/titles to introduce the information in a group.

n Add totals or subtotal to grouped information.

n Have the information sets ordered in ascending or descending order.

n Havemultiple levels of grouped information.

n Allow or prevent the grouped information from breaking across pages.

n Start the grouped information on an even or odd page.

n Add a filter to exclude unwanted information from the group.

n Sort the information within each grouped set.

Group information in your report
To group information on your report:

1. ChooseSections > Add Section > Group Header and Footer.

The Expression Editor appears.
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2. Enter the expression or variable on which the report will be grouped.

Tip: The group can be controlled by a variable that doesn't even appear on your report.
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Q: Group information
Click a question in the list to see the answer:

How do I change the ascending/descending order of grouped information sets?

Select the group header section. From the Properties pane, select theGroup Sort Direction option,
then chooseAscending (A-Z) orDescending (Z-A).

How do I add a page break to grouped information?

n Break before the start of the group.

Select the group header section. From the Properties pane, set thePage Break Before
option to True.

n Break after the group.

Select the group footer section. From the Properties pane, set thePage Break After option
to True.

How do I stop the grouped information breaking over pages?

Select the group header section. From the Properties pane, set theKeep Together option to True.

How do I start grouped information on an even or odd page?

Select the group header section. From the Properties pane, set theStart on Page option toEven or
Odd.

How do I move a group section?

Select the group section. ChooseSections > Move Section Up / Down.

The corresponding group header or footer alsomoves.

How do I delete a group section?

Select the group section. ChooseSections > Delete Section, then click Yes.

Both the group header and footer are removed from the layout.

How do I add a total to the grouped information?

Select Add Expression from the toolbar, or choose Toolbox > Add Expression. Click the
group footer section. The Expression Editor opens. Drag the variable you want to use for the total
from the Fields pane into the left-hand pane, then click OK.

How do I change the expression set for the group?

Select the group header section. From the Properties pane, select theGroup Expression option
then click the finder button . The Expression Editor opens. Change the expression and click OK.
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How do I reduce the number of grouped information sets?

Oneway to reduce the number of information sets is to use theCharacter Count property. Select
the group header section, then from the Properties pane, select theCharacter Count option.

Use this property to keep together records that contain similar initial characters. TheCharacter
Count value sets the number of characters to compare in each record. Records that havematching
characters will be kept together on the same page, rather than split up.

For example, suppose the records contain the following:

Thompsons Cafe
Thompsons Restaurant
Thornaby Bakery

If theCharacter Count is set to 4, then Thompsons Cafe and Thompsons Restaurant would be
kept together, as the first 4 characters are the same; but Thornaby bakery would split to the next
group.

Why is the footer taking up so much space in my report?

This can occur if you only want one footer to appear on a page but have several footers in a report.
Report Designer adds the size of all footers together to work out the space needed. Since you only
want one footer to display, you need to discount the space allocated to the other footers.

Select the group footer section. From the Properties pane, set theAllow Overlap property to True.
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Sort information

Introduction
Sorting is placing information in some kind of order to help you find and evaluate it.

Without a sort, data (information) appears on the report in the order in which it was originally entered
into the database. Finding information in this kind of report is difficult. It is much easier to find
information when you can see it sorted in a logical order. For example, youmay want to have a
contact list sorted alphabetically by name.

A sort is applied to all sections within a report. When ordering information for a group section, it will
sort the information within each information set accordingly. It does not affect the group sort
direction, which controls the order in which the information sets are displayed. For example, you
may want a list of contacts split into groups by town; say from York to Aberdeen - this is the group
sort direction. Then within the information sets the contacts are sorted alphabetically by name - this
is the data sort.

You can
n Sort information in either ascending or descending order.

n Reorder the sorts on a report.

n Apply several sorts to a report.

You could sort a contact list first by name and then by post code. Each sort is listed
separately in your report and is applied in the order in which it is appears in the list.

Using sorts
n ChooseReport > Sorts.

The Sorts window appears.

The list displays the sorts that will be applied to the report; these are listed in order.

Add or edit a sort

1. ChooseReport > Sorts.

The Sorts window appears.
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2. To add a sort, click Add; or to edit a sort, select it and click Configure.

You can sort the data according to the value of a variable or the value of an expression.

l To sort data according to a variable, select the Table andVariable.

l To sort data according to an expression, click Edit Expression to create the
expression. See Expressions on page 122.

3. Choose to sort the data in ascending or descending order.

Change the order that sorts are applied to the report

1. Select a sort from the list.

2. Click the up and down arrow icons to change the order of the sort.

Delete a sort

n Select a sort from the list and click Remove.
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Q: Sort information
Click a question in the list to see the answer:

How do I reorder the sort on the report?

ChooseReport > Sorts. The Sorts window opens. Select a sort from the list and use the arrows to
the right of the window tomove the sort into the correct position.

How do I delete a sort?

ChooseReport > Sorts. The Sorts window opens. Select the sort you want to delete from the list
and click Remove.

How do I change a sort?

ChooseReport > Sorts. The Sorts window opens. Select the sort you want to change from the list,
then click Configure. The Sort window opens. Select the table and variable, or enter an expression
to control the sort. Choose to sort the data in ascending or descending order.
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Filter information

Introduction
Filters remove unwanted information from a report. For example, you could exclude records before a
certain date.

A filter is an expression combining a variable and an operator, such as less than or greater than.

Filters are fixed and are always applied to the report. If you want to choose the information to include
in the report when it is generated, then use criteria instead of a filter.

You can
n Set a report filter to work on the whole report.

n Set a section filter to work on part of a report. Each section can have its own filter.

n Change the appearance of the filtered information, such as font style or size.

Set a filter
1. You can set a filter on a report, or a section in a report.

l To set a report filter, chooseReport > Filters.

l To set a section filter, select the section, then from the Properties pane, select Filter
and click the finder button .

2. In theModify Filter window, enter the filter conditions. You can enter one or two conditions
that compare a variable from your data with a value. This value could be an actual figure, or
1/0 to represent true/false.

For example, to include customer accounts that are on hold, youmight useSALES_
LEDGER.ACCOUNT_ON_HOLD Equals 1.

a. Select the table and variable.

b. Select how it will be compared to the value; for example, equals, greater than, or less
than.

c. Enter a value.

Note: If you want to create your own expression as a filter, click Use Advanced Filter.

3. If you add a second condition; select And if it will be used in conjunction with the previous
filter, or select Or if it will be used as an alternative.

4. To save the filter, click OK.
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Q: Filter information
Click a question in the list to see the answer:

What's the difference between a report filter and a section filter?

n If you use a report filter, unwanted information is not retrieved from the database, which
improves report generation time. If the information is not used at all in a report use a report
filter.

n If you use a section filter, information is retrieved from the database, but is then excluded or
included in the report if the condition for the section is met. This can remove unwanted lines
of information as well as blank lines. Depending on the design of your report youmay need to
retrieve information from the database and deal with it on a section-by-section basis.

For example, youmight generate a list of people to contact by phone or by letter. This is
would be set as a report filter. The letter contacts may include information such as date,
name, address and reason for contact. Phone contacts may include date, name, number,
reason for contact and outcome. By dealing with them separately, information could appear in
one section or another, allowing sections to be formatted in different ways.

Should I set the report filter first or a section filter?

We recommend you set up your report filter before adding any section filters.

How do I pinpoint key information in a filtered section?

Take a look at the information on conditional formatting.

How do I delete a filter?

n To delete a report filter, first chooseReport > Filters. TheModify Filter window opens. Click
Clear Filter, then click OK.

n To delete a section filter, first select the section. From the Properties pane, select Filter then
click the finder button . TheModify Filter window opens. Click Clear Filter, then click OK.

n If the filter is displayed in the expression editor, you can remove the filter by clickingClear.

What's the difference between a filter and criteria?

Filters are used to remove unwanted information from a report. They determine what is retrieved
from the database. They are fixed in that they are always applied to the report.

Criteria do filter information but at the point the report is generated when you get the opportunity to
change the range of information you want to include in your report.
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Modify filter
Filters remove unwanted information from a report. For example, you could exclude records before a
certain date.

Set a filter
1. You can set a filter on a report, or a section in a report.

l To set a report filter, chooseReport > Filters.

l To set a section filter, select the section, then from the Properties pane, select Filter
and click the finder button .

2. In theModify Filter window, you can create your filter conditions. These are entered as
separate lines that compare a variable from your data with a value. This value could be an
actual figure, or 1/0 to represent true/false.

For example, to include customer accounts that are on hold, youmight have something like
SALES_LEDGER.ACCOUNT_ON_HOLD Equals 1.

a. Select the table and variable.

b. Select how it will be compared to the value; for example, equals, greater than, or less
than.

c. Enter a value.

Note: If you are editing an advanced filter, the filter will be displayed in the expression
editor.

3. If you add another line, select And if it will be used in conjunction with the previous filter, or
select Or if it will be used as an alternative.

4. To save the filter, click OK.
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Using criteria to query reports

Introduction
Criteria control the information your report displays. Without them your report would display every
piece of information that exists in the data it reads.

Unlike filters that always exclude information, with criteria you can select the range of information
you want in your report; usually at the point when it is generated. For example, youmay find you
want to query your report to view a particular range of information between certain dates.

You can
n Enable criteria so that every time you generate the report you are asked to select the range of

information you want included in the results. Enable is a status set for the criteria.

n Use preset criteria so that every time you generate the report it uses the same criteria. Preset
is a status set for the criteria. Here the criteria is always applied to the report. You are not
asked to confirm or amend the range when you run the report.

n Switch off unwanted criteria by setting its status toDisabled.

n Use any variable to query your report, such as dates and transaction types.

Using criteria in reports
Add new criteria to a report

To add new criteria to a report:

1. ChooseReport > Criteria.

2. Click New Criteria.

3. Select the table and variable from your data that you want to set up the criteria for, then click
OK.The Criterion Details window appears.

4. Click OK to add the criteria to the report's criteria list.

5. You can set the internal Criterion name, the criteria description (displayed when you
preview the report), and set its Status to be enabled or disabled. See Criterion details on page
164.

Modify report criteria

To edit the report criteria:
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1. ChooseReport > Criteria.

Note: The list initially shows the active criteria for the report, that have a status of
enabled or preset. To also see criteria that have a disabled status, select Show
Disabled.

2. Select the criteria you want to change then click Modify.

3. You can set the internal Criterion name, the criteria description (displayed when you
preview the report), and set its Status to be enabled or disabled. See Criterion details on page
164.

Change the order that criteria are displayed

To change the order in which criteria are displayed when the report is previewed:

1. ChooseReport > Criteria.

2. Select a criteria and change its position by clickingMove Up orMove Down.
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Q: Using criteria to query reports
Click a question in the list to see the answer:

How do I get the criteria range to print on my report?

For every criteria on your report a range of variables are created for use as headings, such as to,
from, display and type. These variables are stored in theCriteria table.

From the Variables pane, double-click theCriteria table, then drag and drop the variable you want as
a heading into position in the report header section.

How do I switch off criteria that has been set up on my report?

Select the criteria and then click Modify. From theStatus list, chooseDisabled.
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Criterion details

Getting to this window
ChooseReport > Criteria, then select the criteria to edit and click Modify.

Criterion Details

This feature is only available for:
Sage 50 Accounts, Sage 50Manufacturing, Sage 50 HR.

Field name Description

Criterion Name Controls how the name of the variable displays
on theManage Criteria window.

Message to use when prompting for value Controls how the criteria appears on the report
(on the Criteria Values window).

Status Controls whether the criteria is included for this
report.

Change the status toEnabled orDisabled to
include or exclude the criteria. UsePreset to
always apply the criteria to the report.

Additional Criterion Details

This feature is only available for:
Sage 200.

Field name Description

Criterion Name Controls how the name of the variable displays
on theManage Criteria window.

Description Controls how the description of the variable
displays on theManage Criteria window.

Message to use when prompting for value Controls how the criteria appears on the report
(on the Criteria Values window).
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Field name Description

Status Controls whether the criteria is included for this
report.

Change the status toEnabled orDisabled to
include or exclude the criteria. UsePreset to
always apply the criteria to the report.

Is transient Includes all the range selectors such as All, Is,
Between etc for the report.

Fix the range selector (e.g. Between, From, To) Sets theDefault Value as the range selector for
the report.

Dropdown selection list Controls the values you can select for the report

criteria. For example, for theACCOUNT_

NUMBER criteria, the drop down lists will

contain all the account reference numbers.

n Do not show dropdown list of values:
Adds a box on the Criteria Values
window. You have to enter the values for
the criteria when generating the report.

n Show a dropdown list of values from
the database: Adds all the values for the
criteria in dropdown lists on the Criteria
Values window.

To change the values in the dropdown
lists, click Edit Query and enter the
appropriate database query.

n Show a fixed dropdown list: Adds a
fixed selection of values in a dropdown
list on the Criteria Values window.

To add the values you want to appear in
the dropdown list, click Edit fixed list.

Default Value Controls which range selector is set as the
default.
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Enter criteria values

Introduction
If a report has been set up to use criteria, you will be prompted to enter the criteria when you preview
the report.

Use the criteria to select the range of information that you want in your report; for example, you
might want to view a particular range of dates or account numbers.

The criteria available will be different for each report.

n To edit the report criteria, chooseReport > Criteria.

See Using criteria to query reports on page 161.
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Drill down reports

Introduction
A drill down report is a report that is linked to other information. They are a great way to give access
to additional information so that you and others have all the information to hand.

When you click a drill down area in a report, the linked information is displayed in a separate window.

Tip: Drill down areas are highlighted in the report as links (blue and underlined) in Preview
mode only. When you hover over the link, the pointer icon will change to a hand. The link
formatting is not displayed when the report is printed.

Many of the standard reports delivered with Sage software can be easily linked together using the
drill down feature. This means you don't have to write these reports from scratch.

You can
n Get a report to open another report in order to view a breakdown of the figures for a given

value.

Report Designer passes information from one report to another using criteria. To control the
information that is displayed you will need to set criteria for the information that will be passed
from the destination report. This is quite different to setting criteria for the source report.

n Open others documents such as a web page or PDF document.

Add a drill down
To add a drill down area to a report:

1. Select the item on the report that you want to be a drill down.

2. From Properties pane, select Drill Down then click the finder button .

3. The Drill down action window appears.

See Drill down action (details) on page 169
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Q: Drill down reports
Click a question in the list to see the answer:

Can I link a report to more than one report or website?

You can link a report to as many reports or documents needed.

What elements can I use a drill down with on a report?

Any element on a report can be a drill down.

What can I link to a report?

You can link any type of format to a report, such as spreadsheets, text documents and images.

How will I know if an element in a report is a drill down?

Drill down areas are highlighted in the report as links (blue and underlined) in Previewmode only.
When you hover over the link, the pointer icon will change to a hand.

Can I email a drill down report using Report Designer?

Although the report itself can be emailed, the report will not support drill down areas.

To use the report on another computer, copy the report layout together with the linked information to
the target computer. Ensure the path to the linked information is relative.
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Drill down action (details)
To display the drill down action for an item in the report, select Drill Down from the Properties pane,

then click the finder button .

Settings tab
SetWhen this element is clicked to specify the action that will take place when the drill down
element is clicked in Previewmode. TheSettings tab displays different options depending on
document type you select.

Open a report

Field name Description

Open a fixed report file Use this option to open a specific report.

Click Browse to select the report you want to open.

You can control the records that appear in the newly opened report by
passing criteria, which are entered on theAdvanced tab.

Open the report file
defined by the
expression

Use this option if there is a choice of report to display that depends on
certain conditions.

Click Edit to enter an expression that defines the report file name
based on any condition. For example:

TABLE.FIELD = "value" ?

"path_to_report_if_true" :

"path_to_report_if_false"

You can control the records that appear in the newly opened report by
passing criteria, which are entered on theAdvanced tab.

Open a web page

Field name Description

Go to a fixed web
address

Use this option to link your report to a website or document.

Enter the website's address (URL). For example, www.sage.com. To

link a document, enter the location and file name of the document. For

example, C:\Documents\Another document.pdf.

Tip: As you enter the information, a list of addresses will be displayed
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Field name Description

based on your browser history.

You can control the records that appear in the newly opened report by
passing criteria, which are entered on theAdvanced tab.

Go to a web address
taken from the report
data

Use this option if there is a choice of document or website to display and
this depends on certain conditions.

Click Edit to enter an expression that defines the report file name based on
any condition. For example:

TABLE.FIELD = "value" ?

"http://www.address_if_true.com" :

"http://www.address_if_false.com"

You can control the records that appear in the newly opened report by
passing criteria, which are entered on theAdvanced tab.

Advanced tab

Field name Description

Advanced Use this tab to enter criteria for the drill down report.

You can control which records are displayed in the report; for example, display
a single record which relates to the customer or employee you have clicked.

To add criteria enter the name of the value you want to specify (which should
match the name of a criterion in the target report) and click Add. Enter an
expression which gives the criterion value.

Examples

Sage 50 Accounts

To display a related customer report showing only a single customer you would
enter two criteria:

Name 1: CRITERIA.CUSTOMER_REF_FROM

Value 1: SALES_LEDGER.ACCOUNT_REF

Name 2: CRITERIA.CUSTOMER_REF_TO

Value 2: SALES_LEDGER.ACCOUNT_REF
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Field name Description

Sage 50 HR

vw.report.employment.EmploymentWorksNumber

This feature is only
available for:
Sage 50 Accounts, Sage
50Manufacturing, Sage
200.
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Subreports

Introduction
Subreports are separate self-contained reports which are embedded within a parent report (called the
primary report). When the primary report is generated, each time a subreport is encountered, the
subreport is generated and then placed onto the page at the relevant location within the primary
report.

They come in useful when you want to present information from different data sources in a single
report. You could also present different views of information in a single report, say a summary at the
beginning of the report followed by details.

You can
n Limit what is passed to the subreport to exclude irrelevant information using criteria.

Note: Subreport criteria are not displayed for selection at the point the report is
generated.

n Join up rows of information in the subreport to relevant rows of information in the primary
report using criteria.

n Resize the subreport to fit neatly into the allocated space on the primary report.

n Set the subreport to display horizontally in the primary report.

Note: Subreports that are contained in your report are not exported to Excel.

Add a subreport
To add a subreport:

1. Open the primary report and select Add subreport from the toolbar, or choose Toolbox >
Add Subreport.

2. Click and drag to draw where you want to add the subreport.

The Report Wizard opens. Follow the instructions in the wizard to create your subreport.

3. The subreport is displayed separately to the primary report. You can switch between the
reports using the tabs at the top of the window.

4. The subreport is created with items such as a title, description and end of report banner. It is
likely you will want to tidy up the subreport by removing unwanted headings.
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Edit a subreport
To edit a subreport:

1. Open the primary report that contains the subreport.

2. Find the subreport you want to edit.

Tip: If you are having difficulty finding the subreport, open the Report Explorer pane and
look for a subreport icon and report name.

3. To open the subreport, either:

a. Double-click the subreport in your report.

b. Select Report in the Properties pane, then click the finder button .

4. The subreport is displayed separately to the primary report. You can switch between the
reports using the tabs at the top of the window.

This feature is only
available for:
Sage 50 Accounts, Sage
50Manufacturing, Sage
200.
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Q: Subreports
Click a question in the list to see the answer:

How do I limit the information that is displayed in a subreport?

To limit the information displayed in a subreport:

1. Set up criteria in the subreport which will filter the information in the subreport to show only
the required records. For example, records for a particular customer.

2. Pass a value from the primary report to the subreport criterion; for example, the customer
reference.

See Subreport criteria on page 175.

How do I set up criteria within the subreport?

Select the subreport , then chooseReport > Criteria. TheManage Criteria window appears. Check
the listed criteria for one that is suitable.

Otherwise, you can add new criteria by clickingNew Criteria.

How do I pass a value from the primary report to the subreport criteria?

To pass a value from the primary report to the subreport criterion, see Subreport criteria on page 175.

Why are criteria rather than a filter used to limit the information passed to the subreport?

You can set a static filter in the subreport, but criteria aremore useful when dealing with subreports
as you canmatch the information in the subreport to the information in the primary report.

What can I do to reduce the report's generation time?

Try to ensure that each report (including subreports) results in a single database query. If you have a
subreport on each row of the primary report, this will result in one database query for the primary
report, plus one query per row for the subreport; which will be slower than not using subreports.

Can I add a subreport to a subreport?

No. A subreport can't contain another subreport.

What is the different between a primary and subreport?

A subreport is embedded in a primary report. Also, a subreport can't contain another subreport.

How do I change the size of the subreport?

On the primary report click the embedded subreport. Small squares appear as a border around the
subreport. Move your cursor over these squares and drag the borders to the size you want.

Can I export subreports to Excel?

No. Subreports that are contained in your report are not exported to Excel.
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Subreport criteria
You can use criteria from your primary report in a subreport.

To do this:

1. On the primary report, select the subreport.

2. From the Properties pane, select Criteria and click the finder button .

The Build a List of Criteria window appears, displaying the criteria available from the primary
report.

3. To build an expression for a criteria, select the criteria and click Edit.

Enter the expression for the criteria in the Expression Editor, then click OK to close the
editor.

4. When you have finished editing the subreport criteria, click OK.
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n To learn how to format information in your report, see Styles on page 177.

n To set the properties for information in your report, see Properties on page 186.

n To learn how to format information based on a condition, see Conditional formatting on page
223.

n To add watermarks to the background of your report, seeWatermarks on page 226.

n To use suggestions for titles and totals for variables and expressions, see Active Complete
on page 227.

n To check the spelling in your report, see Spell check your reports on page 229.
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Styles

Introduction
A style is a set of formatting characteristics that you can apply to information on your report to
quickly change its appearance and give your reports a consistent look. When you apply a style, you
apply a set of formatting in one step. For example, instead of separately formatting the size, font and
colour of text; you can apply all the formatting using a style.

Styles are specific to a report. If youmodify a style in one report, it does not affect other reports.

You can
n Apply styles to anything on a report, text, lines, boxes.

n Use the set of styles that comes with Report Designer straightaway, or modify them if
needed.

n Create your own styles.

Using styles
n To apply a style, select the item in the report, then select a style from theStyle list on the

formatting toolbar.

n To add, remove or edit a style; either click Modify Styles on the formatting toolbar, or select
Style from the Properties pane.

See Using styles on page 180.
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Q: Styles
Click a question in the list to see the answer:

How do I create a new style?

Select the information you want to work with. From the Properties pane, click Style then click the
finder button .

The Select Style window appears. Click New Style and theModify Style window appears. Give the
style a name in theStyle name box, then set the formatting for the style.

How do I change a style?

Select the information with the style you want to change. From the Properties pane, click Style then
click the finder button .

The Select Style window appears. Click Modify. In theModify Style window, check you are working
with the right style; its name is displayed in theStyle name box. Change the formatting properties of
the style.

How do I rename a style?

Select the information with the style you want to change. From the Properties pane, click Style then
click click the finder button .

The Select Style window appears. Click Modify. In theModify Style window, check you are working
with the right style; its name is displayed in theStyle name box. Enter the new style name.

How do I delete a style?

Select the information with the style you want to delete. From the Properties pane, click Style then
click the finder button .

The Select Style window appears. Check the correct style is highlighted, then click Remove. Then
select a different style to apply to the information.

How do I make a one-off change to something without creating a new style?

Select the information you want to work with. From the Properties pane, click Text Style then click
the finder button .

TheModify Text Style window appears. Select the setting(s) you want to apply.

If the Apply to Style window appears, click No.

Where do the default styles come from?

When you create a new report, Report Designer uses a template to control the report's layout and
styles. This read-only template is called theDEFAULT.report.
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Some Sage software is supplied with other templates designed to deal with different document
types. There are theDEFAULT.letter andDEFAULT.layout.

Can I import styles from one report to another?

No. Styles are specific to a report. If youmodify a style in one report, it does not affect other reports.

179



7 | Making reports look good

Using styles

Getting to this window
1. Select an item in the report, then either:

2. Click Modify Styles on the formatting toolbar.

3. From the Properties pane, select Style from theAppearance area, then click the finder
button .

Using styles
n To apply a style, select the style and click OK.

n To add a style, click New Style.

n To edit a style, select the style and click Modify.

n To delete a style, select the style and click Remove.

Note: For help with creating or editing styles, see Style properties on page 181.
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Style properties

Setting style properties
1. Select an item in the report, then either:

l Click Modify Styles on the formatting toolbar.

l From the Properties pane, select Style from theAppearance area, then click the
finder button .

2. Select a style and click Modify.

3. Enter theStyle name.

4. Set the style properties on the tabs; see below.

Text

Field Description

Font Sets the font typeface.

Size Sets the size of the font in points.

Effects Sets font effects; such as bold, italic, underline, overline, and
strikethrough.

colour Select a font colour from the list, or select Custom colour to define
your own colour.

Align Sets the alignment of the text.

Background

Style Description

Solid colour Use a solid colour for the background.

Select a colour from the list, or select Custom colour to define your
own colour.

Gradient colour Use amultiple colour gradient for the background.

Select one of the icons in the corners or middle of the box, then set
the colour for that position.

Linear gradient Use a two-colour linear gradient for the background.

To set the gradient colours, select the From and To icons, then
select the colour for the that position. To set the angle of the
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Style Description

gradient, either click in the circle or enter an angle in degrees.

Tiled pattern Use a tiled pattern as the background.

Select thePattern style, the Foreground colour andBackground
colour.

Tiled embedded image Use your own image as a tiled background.

Click Browse to select your image.

The image will be stored in the report.

Tiled linked image Use your own image as a tiled background.

Click Browse to select your image.

The image will be linked to the original file, so if you change the
external file, the image in your report will also change.

Border

Field Description

Style Set the style of the border line, such as solid or dotted.

colour Select the border colour from the list, or select Custom colour to
define your own colour.

Width Set the width of the border in points.

Padding UsePadding to add space between the border and the contents of
the element; for example, in a text box, padding will add space on the
inside of the box so the text does not run into the border.

Rounded corner radius To have a rounded corner on the border, set the value for the
Rounded corner radius in points. Use a value of 0 (zero) for a
square corner.

Drop shadow depth To display a drop shadow, set a value for theDrop shadow depth in
points.

Preview Use the icons in thePreview section to set which sides of the box
will have a border.
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Date and time

Field name Description

Date formatting Select the formatting to use for date values.

Time formatting Select the formatting to use for time values.

Display calculated
times as number of
days

Shows the time, in days, between a set of dates. To use this option, enter
the dates as a expression on the report, subtracting one from the other.

Numeric

TheNumeric tab contains settings that deal with number formatting; such as the number of decimal
places, symbols used such as currency, as well as suppressing zeros.

Field name Description

Style TheStyle drop-down has the following options:
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Field name Description
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Fill format

Field name Description

Fill format n None: Do not use any fill formatting with this variable value.

n Pre-fill: Fill a specified number of spaces before your variable value
with the specified character.

n Post fill: Fill a specified number of spaces after your variable value
with the specified character.

n Surround: Fill a specified number of spaces before and after your
variable value with the specified character.

n Secure cheque: Fill a specified number of spaces before your
variable value, and all available spaces after.

Note: This format is an APACS standard. The fill format places
** before the value, and fills the remaining space with asterisks
(*). Text is displayed in upper case without spaces.

Fill length You can either set a fixed number of characters to use in the fill, or choose
to Fill all available space.

Fill character Enter the character to be used for the fill.
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Properties

Introduction
Every piece of information has properties that control how it appears and behaves on your reports.

The properties of an expression, variable or text box will differ to the properties of a box or line, but
there will be some things in common such as whether it should be allowed to print or not.

You can
n Control numeric properties such as the decimal place used, for example, 3.1222 or 3.1.

n Change date and time properties, for example, 21/12/10 or 21-12-2010 and 2.30 PM or 14:30.

n Resize and position information.

n Control print settings such as printing information only on the first page of your report.

n Lock information on a report layout to prevent it from beingmoved.

n Change the appearance of information, such as its colour, font size or background colour.

Using properties
1. In Designermode, select the item in the report that you want to work with.

2. The item's properties are displayed in the Properties pane; for example, Background or Text
Style.

Properties can be listed by category or alphabetically; click the Categorized or
Alphabetical icons.

3. You can change some properties directly in the pane, whilst others are set by clicking the

finder button .
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Properties list
Properties in the Properties pane can be listed by category or alphabetically; click the
Categorized or Alphabetical icons.

Depending on the item in the report you have selected, some properties are not relevant and are
therefore unavailable.

Tip: Click on a column heading to sort the column.

Property

Name Category

Aggregation Data Source

Align To Bottom Behaviour

Allow Overlap Behaviour

Apply Sign After Group Behaviour

Auto Arrange Z-Order CSV Options

Auto Grow Appearance

Background Appearance

Barcode Format Appearance

Border Appearance

Character Count Appearance

Conditional Formatting Appearance

Criteria Data Source

Delimiter CSV Options

Description Design

Dimension Layout

Height (Dimension) Layout

Width (Dimension) Layout

Display Named Values Behaviour

Drill Down Behaviour

Email Options Email Options
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Property

Name Category

End Layout

X (End) Layout

Y (End) Layout

Evaluate Section Behaviour

Excel Export Options Export Options

Expression Appearance

Filename Appearance

Filter Appearance

Filter Expression Data Source

Fixed Length CSV Options

Formatting Appearance

Function Appearance

Group Expression Appearance

Group Sort Direction Appearance

Height Layout

Image Appearance

Include Records with no
Transactions

Data Source

Include Sections CSV Options

Is Cumulative Behaviour

Keep Together Appearance

Line Style Appearance

Linked Dimension Layout

Linked Dimension Anchor Layout

Linked Position Layout

Linked Position Anchor Layout

Location Layout
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Property

Name Category

X (Location) Layout

Y (Location) Layout

Lock Aspect Ratio Appearance

Locked Behaviour

Multi-Printer settings Printing

Name Design

Numeric Qualifier CSV Options

Output Length CSV Options

Page Break After Behaviour

Page Break Before Behaviour

Page Break Only When Filter Met Behaviour

Print On First Copy Only Appearance

Print Scaling Printing

Print template Appearance

Height (Print Scaling) Printing

Width (Print Scaling) Printing

Repeat on Each Page Behaviour

Report Appearance

Report Tag Design

Reset Section Behaviour

Save Printer Settings Printing

Security Options Security Options

Sign Appearance

SizeMethod Appearance

Sorts Data Source

Start Layout
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Property

Name Category

X (Start) Layout

Y (Start) Layout

Start on Page Behaviour

Style Appearance

Suppress Duplicates Section Behaviour

Suppress Printing Appearance

Template Appearance

Text Qualifier CSV Options

Text Style Appearance

Alignment (Text Style) Appearance

Bold (Text Style) Appearance

colour (Text Style) Appearance

Font (Text Style) Appearance

Italic (Text Style) Appearance

Overline (Text Style) Appearance

Size (Text Style) Appearance

Strikeout (Text Style) Appearance

Underline (Text Style) Appearance

Vertical Alignment (Text Style) Appearance

Visible Behaviour

Watermark Appearance

WordWrap Appearance

Xml Style Sheet XMLOptions
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Appearance properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane, view the

Appearance area. If you can't see theAppearance title, click theCategorized button at the top
of the pane.

Depending on the information you are working with, some properties are not relevant and are
therefore unavailable.

Property Description

Auto Grow Allows the space allocated to the information to expand or decrease so that
it fits on the report.

n True: The width increases and decreases accordingly.

n False: The space is fixed, some informationmay be concealed. The
allocated space is set by theDimension option of the Properties
pane. See Layout properties on page 217.

Note: If you use this property withWord Wrap, the height
automatically increases or decreases.

Background Controls the style and colour of the background behind the information.

Typically this is set to Transparent. If you have changed the font colour
youmay find changing the background colour makes the information easier
to read. Or youmay want to change the background colour of a box on your
report.

See Background style on page 196.

Barcode Format Controls the format of the selected barcode.

Select Barcode Format, click the finder button , then select the barcode
format.

See Edit Barcode Format on page 147.

Border Controls the style of the border used for boxes, text boxes, barcodes and
images.

Select Border, click the finder button , then select the border properties.

See Border style on page 198.

Character Count Available on aGroup Header section.
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Property Description

Use this property to keep together records that contain similar initial
characters. TheCharacter Count value sets the number of characters to
compare in each record. Records that havematching characters will be
kept together on the same page, rather than split up.

For example, suppose the records contain the following:

Thompsons Cafe
Thompsons Restaurant
Thornaby Bakery

If theCharacter Count is set to 4, then Thompsons Cafe and Thompsons
Restaurant would be kept together, as the first 4 characters are the same;
but Thornaby bakery would split to the next group.

Conditional
Formatting

Conditional formatting is used to draw attention to, or ignore, information
when a condition is met. For example, you could use conditional formatting
to highlight balances that exceed certain amount, indicate inactive records,
or display negative numbers in bold and red.

See Conditional formatting on page 223.

Expression An expression tells Report Designer what information to include in a report.
When the report is generated, each expression is calculated to produce a
value; this valuemay come directly from the database or be the result of
further calculations on the information in the database.

See Expressions on page 122.

Filename This displays the path to a linked image, and details such as the image
format and size.

Tip: You can change the image by clicking the finder button and
browsing for a new file.

Filter A filter removes unwanted information; for example, you could exclude
records before a certain date.

See Filter information on page 158.

Formatting Use Formatting to set date and time formats, numeric properties and fill
space formats that are useful when dealing with cheques.

See Formatting properties on page 212.

Function Use this to apply numeric functions such as average, count and sum.

See Function properties on page 215.
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Property Description

Group Expression Available on aGroup Header section.

The expression controls how the information is divided into the different
sets of information, such as date, name or post code.

Group Sort Direction Available on aGroup Header section.

Use this property to change the ascending or descending order of grouped
information sets.

Image This displays details about an image stored in your report, such as its image
format and size.

Tip: You can change the image by clicking the finder button and
browsing for a new file.

Keep Together Available on aGroup Header section.

If Keep Together is set to True, the report will try to keep theGroup
information together and avoid page breaks where possible. A page break
will be inserted above the group header if the group starts part of the way
down a page, or would be split onto a second page.

Line Style Sets a line's style (e.g. solid, dotted), colour and width.

See Line style on page 199.

Lock Aspect Ratio To prevent images from being distorted when they are resized, set Lock
Aspect Ratio to True. The proportions of the image will be kept intact when
adjusting the width or height.

Print On First Copy
Only

When printingmore than one copy of the document, this option controls
whether the information is printed on the first copy only or on all copies.
There are two options:

n True: The information only appears on the first copy printed.

n False: The information is printed on every copy.

Print Template If you use a Templatewith the report, usePrint Template to choose
whether to display the template when the report is printed.

Report This displays the name of a subreport.

To view the subreport, select Report, then click the finder button .

Sign Use this to control the sign of positive and negative numbers, or how credit
and debit values are displayed.

n Signed: Shows a sign such as -, +.
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Property Description

n Unsigned: Omits signs such as -, +.

n Reversed: Shows the opposite sign for the information returned
through the variable or expression.

n Debit: Only shows debit values.

n Credit: Only show credit values.

SizeMethod TheSize Method property controls the space allocated to an image.

n Autogrow: Allows the space allocated to the image to expand or
decrease so that it fits on the report.

n Stretch: The space allocated to the image is fixed, but the image will
shrink or grow to fit the available space.

n Clip: The space allocated to the image is fixed and the image size
will be fixed. If the image is too large to fit in the available space, the
image will be clipped (so not all the image will be visible).

The following apply to barcodes only:

n AutogrowWidth: the height of the space allocated to the image is
fixed, but the width can expand or shrink to accommodate the
barcode image.

n AutogrowHeight: the width of the space allocated to the image is
fixed, but the height can expand or shrink to accommodate the
barcode image.

Style Apply a defined style to information in your report. Use styles to give your
reports a consistent appearance.

See Using styles on page 180.

Suppress Printing Controls whether the information is printed or not:

n True: The information appears in designer mode but not when
previewed or printed.

n False: The information appears in designer, preview and print mode.

Template You can use a template to project an image of the stationery you're using on
your report layout. To select a template, select Template and click the
finder button , then select a template file.

Tip: If you want the template to be printed with the report, use the
Print Template property.

See Templates for Sage stationery on page 74.
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Property Description

Text Style Set the appearance for text; such as font, size, colour, bold, underline, and
alignment. These properties will override any style properties for the
information.

See Text style on page 200.

Watermark Use a watermark to place text or an image on the background of your report;
such as "Draft" or "Confidential", or a company logo.

SeeWatermarks on page 226.

WordWrap UseWord Wrap to set whether information will wrap onto the next line
when it reaches the edge.

If you setWord Wrap to True, you need to ensure there is sufficient height
for the information to be displayed, otherwise somemay be concealed. To
ensure sufficient height is allocated when the report is generated, you could
set Auto Grow to True.
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Background style

Getting to this property
Select the information on your report you want to work with, then from the Properties pane, select

Background from theAppearance area, then click the finder button .

Tip: If you do not want any background colour, set theStyle toSolid colour, then select
Transparent as the colour.

Background styles

Note: If you are using a style that sets these properties, you have the opportunity to update the
set style or just the properties for this particular item.

Style Description

Solid colour Use a solid colour for the background.

Select a colour from the list, or select Custom colour to define your
own colour.

Gradient colour Use amultiple colour gradient for the background.

Select one of the icons in the corners or middle of the box, then set
the colour for that position.

Linear gradient Use a two-colour linear gradient for the background.

To set the gradient colours, select the From and To icons, then
select the colour for the that position. To set the angle of the
gradient, either click in the circle or enter an angle in degrees.

Tiled pattern Use a tiled pattern as the background.

Select thePattern style, the Foreground colour andBackground
colour.

Tiled embedded image Use your own image as a tiled background.

Click Browse to select your image.

The image will be stored in the report.

Tiled linked image Use your own image as a tiled background.

Click Browse to select your image.
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Style Description

The image will be linked to the original file, so if you change the
external file, the image in your report will also change.

197



7 | Making reports look good

Border style

Getting to this property
Select the information on your report you want to work with, then from the Properties pane, select

Border from theAppearance area, then click the finder button .

Border styles
To set the border style:

1. Choose the properties for the border.

2. To apply the selected properties, click the icons in thePreview section to set which sides of
the box will have a border.

Note: If you are using a style that sets these properties, you can update the style or just the
properties for this particular item.

Field Description

Style Set the style of the border line, such as solid or dotted.

colour Select the border colour from the list, or select Custom colour to
define your own colour.

Width Set the width of the border in points.

Padding UsePadding to add space between the border and the contents of
the element; for example, in a text box, padding will add space on the
inside of the box so the text does not run into the border.

Rounded corner radius To have a rounded corner on the border, set the value for the
Rounded corner radius in points. Use a value of 0 (zero) for a
square corner.

Drop shadow depth To display a drop shadow, set a value for theDrop shadow depth in
points.

Preview Use the icons in thePreview section to set which sides of the box
will have a border.
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Line style

Getting to this property
Select a line in your report, then from the Properties pane, select Line Style from theAppearance
area, then click the finder button .

Line styles

Field Description

Style Set the style of the line, such as solid or dotted.

colour Select the line colour from the list, or select Custom colour to define
your own colour.

Width Set the width of the line in points.
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Text style

Getting to this property
Select the information on your report you want to work with, then from the Properties pane, select

Text Style from theAppearance area, then click the finder button .

Text styles

Note: If you are using a style that sets these properties, you have the opportunity to update the
set style or just the properties for this particular item.

Field Description

Font Sets the font typeface.

Size Sets the size of the font in points.

Effects Sets font effects; such as bold, italic, underline, overline, and
strikethrough.

colour Select a font colour from the list, or select Custom colour to define
your own colour.

Align Sets the alignment of the text.
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Behaviour properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane, view the

Behaviour area. If you can't see theBehaviour title, click theCategorized button at the top of
the pane.

Depending on the information you are working with, some properties are not relevant and are
therefore unavailable.

Property Description

Align to Bottom Controls the placement a grouped section footer or the Report Footer.

If set to True, the footer is placed at the bottom of the page rather than
midway, which can happen if the report ends halfway through a page.

Allow Overlap Controls group footers. To save space on your report, you can allow footers
can overlap each other. This works well if the information in footers are
positioned in separate areas; e.g. one footer has information printed on the
left, whereas the next footer prints information on the right.

Apply Sign After
Group

Controls how the total for a group is displayed when it uses the credit or
debit sign.

n False: Shows separate debit and credit totals for the group.

n True: Adds all the debit and credit values in the group then displays
a final total as a debit or a credit value.

Display Named
Values

Relevant when dealing with coded variables. Coded variables use a value
(0, 1, 2) to represent a status; such as on hold, true or false. Rather than
displaying a value, you can display ameaningful description in your report.

n Readable: Value returns ameaningful description.

n Raw value: Returns the status value such as 0 or 1.

Drill Down Used to drill down to a further report or web page when previewing the
report or viewing it as a PDF file. See Drill down reports on page 167.

Evaluate Section Use this to specify what to count when calculating the value of an

expression. This is important for aggregate functions such as Sum and

Count, as they increase each time the section is generated in the report.

n When set toNone, each row is counted to give a cumulative value.
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Property Description

n To get the count to perform differently, choose a variable from the
drop-down.

Note: Use this with theReset Section property to restart the count.

Is Cumulative This property is used with functions. If set toYes, the value is displayed as
a running total; if set toNo, the value will be the total for the entire group.

Locked Fixes information on a report to stop it from beingmoved. This is useful
when you use pre-printed stationery, as it ensures the information is in the
right position when it is printed.

You can also lock and unlock information by choosing Format > Locking.

Page Break After Available on aGroup Footer section.

If you want the report to start a new page at the end of each group, set this
option to True.

Page Break Before Available on aGroup Header section.

If you want the report to start a new page at the start of each group, set this
option to True.

Page Break Only
When Filter Met

Available on aGroup Footer section.

Only apply the page break if the Filter expression is True; i.e. the group
section is displayed.

Repeat on each
page

If the Details section extends ontomultiple pages, this sets whether the
header section will be repeated at the top of each subsequent page (True),
or is only displayed on the first page (False).

Reset Section Use this to restart calculating values for a section; otherwise the
cumulative value for one section is passed to the next.

Note: Used with theEvaluate Section property.

Start on Page Available on aGroup Header section.

To set the group to start on an odd or even page, set theStart on Page
option toEven orOdd.

Tip: This is useful printing invoices on double-sided paper, as you can
set a new start page for each invoice number.

Suppress Duplicates
Section

Excludes duplicate values from your report on a section by section basis. If
your report has been split into different sections, then the information will be
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Property Description

repeated but only once in each section.

Visible Hides information from the report; it will not appear inDesigner orPreview
modes, or when printing the report.

Tip: To view hidden pieces of information in a report, use the Report
Explorer pane; as this displays every item in the report.
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CSV Options properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane view the

CSV Options area. If you can't see theCSV Options title, click theCategorized button at the
top of the pane.

Property Description

Auto Arrange Z-
Order

Specifies if the Z-Order of the elements are reordered in the exported file.

n When set to False, the variables are output in their natural order in
the report.

n When set to True, the variables are output in the following order:

a. Left to Right (X-axis).

b. Front To Back (Z-axis).

c. Top to Bottom (Y-axis).

Delimiter The delimiter is the character used to separate fields in an exported CSV

file; by default this is a comma (,).

Tip: Use\\t for a tab character.

Fixed Length This property is only used when you export the file in the format CSV -
Length Delimited Files.

When Fixed Length is set to True, values will be padded with extra
characters to their default length; when set to False, the values will not be
padded.

Include Sections Use this property to select which sections start a new row in the exported
CSV file.

See Include sections on page 205.

Numeric Qualifier Sets the character(s) to use on either side of a number in the exported CSV
file.

Output Length Themaximum length of the field when it is exported to CSV format. This is
useful if you intend to import the CSV file in another application, and the
field must be constrained to a certain length.

Text Qualifier Sets the character(s) to use on either side of a text field in the exported CSV
file.
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Include sections
Use the Include sections property to control how sections in your report are displayed in the
exported CSV file. By default, only the Details section will be included.

1. View the report properties in the Properties pane. To display properties for the report, select
the report name at the top of the Report Explorer pane, or click anywhere outside of the report
page.

2. Find the Include sectionin theCSV Options area of the Properties pane, and click the finder
button .

3. To control how each section is displayed in the CSV report:

l Select Include Variables to include the information from a section in the CSV file.

l If your Sage application supports this feature, you can select Triggers a Row to start
a new line in the CSV file for each item in this section.

For example, if you want to keep the information from the header section and details
on the same line, select Include Variables for both sections, but only Triggers a
Row for the details section.
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Data Source properties

Find these properties
Select the report or subreport. Then from the Properties pane, view theData Source area. If you

can't see theData Source title, click theCategorized button at the top of the pane.

Property Description

Aggregation Data aggregation allows you to combinemultiple data records before
running the report (so you can combine data without using groups).

See Aggregation on page 207.

Criteria Set the criteria to apply to the report.

Criteria controls the information your report displays. Without them your
report would display every piece of information that exists in the data it
reads.

With criteria you can select the range of information you want in your
report; usually at the point when it is generated. For example, youmay find
you want to query your report to view a particular range of information, say
between certain dates. See Using criteria to query reports on page 161.

Filter Expression Use this to set the filter to apply to the report.

A filter removes unwanted information from a report. For example, you
could exclude records before a certain date. See Filter information on page
158.

Include Records with
no Transactions

By default, Report Designer only reports on records that have transactions
associated with them.

If you want to include records without any transactions, set the Include
records with no transactions property to True.

Sorts You can sort the data in your report by a particular variable, or by using an
expression. See Sort information on page 155.
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Aggregation
Data aggregation allows you to combinemultiple data records before running the report (so you can
combine data without using groups).

1. Select the report or subreport from the Report Explorer pane.

2. From the Properties pane, select Aggregation from theData Source area, then click the
finder button .

3. On theData Groups tab, you can enter fields for which you want to group the data. You can
type a field name or click ... to display the Expression Editor, then click Add.

4. By default, themethod of aggregating the fields will be to calculate their sum. Alternatively,
you can calculate their minimum, maximum, or average value. To do this, select the
Aggregated Data tab, and add each field (that you do not want to sum) and select its
Aggregate Method.

207



7 | Making reports look good

Design properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane, view the

Design area. If you can't see theDesign title, click theCategorized button at the top of the
pane.

Tip: You can also set the report name or description in Report Properties. Select Report
Properties from the toolbar, or chooseReport > Report Properties.

Property Description

Description You can enter a description for the report, which is displayed in the Report
Browser.

Name You can set the name for the report, and individual expressions.

n To change the name of the report, select the report's name from the
Report Explorer pane, then set theName in the Properties pane.

n When you create an expression, it is good practice to set its name to
somethingmeaningful so that you remember its purpose.

This is especially useful if you need to reuse the expression
elsewhere in the report; you can drag-and-drop named expressions
onto your report from theExpression folder in the Variables pane.

Report Tag You can use report tags to help people find your reports more easily in the
Report Browser. A report tag is a text label that you can add to your report,
and use as a category to group related reports. You can add as many tags to
a report as you want. When you use the Report Browser, you can choose to
view reports by their tag, so you can quickly find the reports that you are
interested in.

See Report tags on page 209.
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Report tags

About report tags
You can use report tags to help people find your reports more easily in the Report Browser. A report
tag is a text label that you can add to your report, and use as a category to group related reports. You
can add as many tags to a report as you want. When you use the Report Browser, you can choose
to view reports by their tag, so you can quickly find the reports that you are interested in.

Getting to this property
Select the information on your report you want to work with, then from the Properties pane, select

Report Tag from theDesign area, then click the finder button .

Adding and removing report tags
n To add a tag to the report, enter the tag and click Add to include it in the list.

n To remove a tag from the report, select it from the list and click Remove.

Note: If you change the tags in your report when the Report Browser is open, this will not be
reflected in the Report Browser until you view a different report folder.
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Email Options properties

Find these properties
To open the email settings, either:

n ChooseReport > Email Settings.

n Select the report by clicking the report name at the top of the Report Explorer pane. From the

Properties pane, click Email Options, then click the finder button .

For information on these settings, see Email Settings (Email Options) on page 82.
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Export properties

Introduction
When you generate a report in an Excel format, you can specify which parts of the report should be
included on the spreadsheet.

Note: Subreports that are contained in your report are not exported to Excel.

Find these properties
Select the report by clicking the report name at the top of the Report Explorer pane. From the

Properties pane, select theExcel Export Options and then click the finder button .

Excel export options

Field name Description

Which sections should be included in the
report?

Select the sections you want to be included on
the Excel spreadsheet.

Don't repeat Page Headers Do you want to add the page header to every
page of the report?
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Formatting properties

Find these properties
Select the information on your report you want to work with. From the Properties pane, select

Formatting from theAppearance area and then click the finder button .

Date & Time

Field name Description

Date formatting Select the formatting to use for date values.

Time formatting Select the formatting to use for time values.

Display calculated
times as number of
days

Shows the time, in days, between a set of dates. To use this option, enter
the dates as a expression on the report, subtracting one from the other.

Numeric
TheNumeric tab contains settings that deal with number formatting; such as the number of decimal
places, symbols used such as currency, as well as suppressing zeros.

Field name Description

Style TheStyle drop-down has the following options:
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Field name Description
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Fill Format

Field name Description

Fill format n None: Do not use any fill formatting with this variable value.

n Pre-fill: Fill a specified number of spaces before your variable value
with the specified character.

n Post fill: Fill a specified number of spaces after your variable value
with the specified character.

n Surround: Fill a specified number of spaces before and after your
variable value with the specified character.

n Secure cheque: Fill a specified number of spaces before your
variable value, and all available spaces after.

Note: This format is an APACS standard. The fill format places
** before the value, and fills the remaining space with asterisks
(*). Text is displayed in upper case without spaces.

Fill length You can either set a fixed number of characters to use in the fill, or choose
to Fill all available space.

Fill character Enter the character to be used for the fill.
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Function properties

Find these properties
Select the information on your report you want to work with; from the Properties pane, select

Function from theAppearance area and then click the finder button . If you can't see the
Appearance area, click theCategorized button at the top of the pane.

Function options

Function Description

None This is the option applied to a variable or expression when added to a report.
The report displays the value for that variable or expression.

Sum Displays the total value of variables or expression in a report.

UseSum in a:

n Footer section to total all values in the section above. This is the
most common use for sum.

n Details section to give a running total of the values on the report.

n Group section to give a running total for each group.

Avg (average) Displays the average value of the information returned through the variables
or expressions.

UseAvg in a:

n Footer section to show the average of all the values in the section
above.

n Details section to show the average at each point in the list of
values.

Min Displays theminimum value of the information returned through the
variables or expressions.

UseMin in a:

n Footer section to show theminimum of all the values in the section
above.

n Details section to show theminimum value at each point in the list of
values.

Max Displays themaximum value of the information returned through the
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Function Description

variables or expressions.

UseMax in a:

n Footer section to show themaximum of all the values in the section
above.

n Details section to show themaximum value at each point in the list
of values.

Count This option replaces the values returned by variables or expressions with a
numbered list. For example, inPreviewmode, your report shows the

following values: 32.1, 58.3 and 49.0. If you apply Count to the

information, your report will replace those values with: 1, 2, and 3.

Count ignores any nil values. If you want your report to list records with a

contact address any record which does not include an address is missed
from the report.

UseCount in a:

n Group section to show the total number of records within a group.

Tip: To reset the numbering in each group useReset Section
in theBehaviour area of the Properties pane.

n Footer section to show the total number of records within the details
section.

CountAll CountAll works in a similar way toCount as explained above, but it

will increment the count for nil values.

CountUnique CountUnique works in a similar way toCount as explained above, but

it will only increment the count if a value is unique; i.e. it is different to all
previous values.
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Layout properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane, view the

Layout area. If you can't see the Layout title, click theCategorized button at the top of the
pane.

Property Description

Dimension Controls the size of the information on the report.

Click + to display the height and width properties, then enter the size into
the boxes.

End The co-ordinates for the end point of a line, relative to the current section.

Height The height of the selected section in a report (including Page Headers and
Footers, Report Headers and Footers, Details and No transactions
sections).

Linked Position Link the position of this element to another element in the report, so it will
move relative to the other element. You can link the position to any other
element, a section or the report margins.

Select Linked Position, click the finder button , then select the other
element that you want to link the position to.

Note: To choose which corner of the other element the position is
relative to, set the Linked Position Anchor.

Linked Position
Anchor

You can set a linked element's position to be relative to one corner of the
other element; e.g. top left or bottom right.

Select Linked Position Anchor, click the finder button , then select the
sides of the other element which will set the corner that the linked position
will be fixed to.

Linked Dimension Link the size of this element to another element in the report, so it will be
resized relative to the other element. You can link the dimension to any
other element.

Select Linked Dimension, click the finder button , then select the other
element that you want to link the dimensions to.

Note: To choose whether the width and/or height is linked, set the
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Property Description

Linked Dimension Anchor.

Linked Dimension
Anchor

If you have set a Linked Dimension, you can choose to link the width
and/or height of the elements.

Select Linked Dimension Anchor, click the finder button , then select
whether to link the widths and heights of the elements.

Location Controls the position of information on your report.

Click + to display theX andY properties, then enter the horizontal and
vertical positions into the boxes.

Note: If the element is linked using the Linked Position property,
then the location values will show the position relative to the linked
element; i.e. the distance from the linked element (from the corner set
as the Linked Position Anchor).

Start The co-ordinates for the start point of a line, relative to the current section.
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Printing properties

Find these properties
Select the information on your report you want to work with, then from the Properties pane, view the

Printing area. If you can't see thePrinting title, click theCategorized button at the top of the
pane.

Property Description

Multi-Printer
Settings

You can set upmultiple printer options for a report. SeeMulti-printer settings
on page 73.

Print Scaling You can set the print scaling to apply to the report. To do this, openPrint
Scaling, then set theHeight andWidth values as a percentage (%).

Save Printer
Settings

n To save the current printer settings with the report, set this property
to True. This will save the printer options set in Page Setup (choose
File > Page Setup).

You would typically use this when you want to use a specific printer
and settings to print a report, rather than the default printer settings
on your system. When you print the report, it will try to use the printer
and settings saved with the report (if available), in preference to the
default printer.

n Set this property to False if you don't want to save the printer
settings with the report. When the report is printed, it will
automatically use the current default printer.
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Security Options properties

Find these properties
Select the report by clicking the report name at the top of the Report Explorer pane. Then from the
Properties pane, view theSecurity Options area. If you can't see theSecurity Options title, click

theCategorized button at the top of the pane.

PDF Security Settings

Field name Description

Do not encrypt the
PDF document

If you don't want to protect your PDF report, select this option.

Reports are set to not be encrypted as standard.

Encrypt the PDF
document with a fixed
password

To protect your PDF report with a fixed password, select this option.

Tip: As you enter the password, asterisks (*) are used to hide the
text. If you prefer to see the text as you enter the password (or want
to check the password), disableHide the password.

Encrypt the PDF with
a password defined by
an expression

To protect your PDF report with a password based on variables from your
database tables, select this option. Then use the browse button to select
the table and variable.

For example, to use your business name as the password, select the

COMPANY table and theNAME variable (COMPANY.NAME).

Examples

Sage 50 Accounts

To password protect a statement you want to send to your customer use

SALES_LEDGER.PASSWORD. The report applies the password that

has been set on the customer's record.

Or to password protect a letter you want to send to your supplier use

PURCHASE_LEDGER.PASSWORD. The report applies the password

that has been set on a supplier's record.

Note: If a password has not be set on the customer's/supplier's
record the password will be blank. Anyone who receives the report
will be able to open it!
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Field name Description

Sage 50 HR

To password protect a letter or contract useEMPLOYEE.PASSWORD.

The report will apply the password that has been set on an employee's
record. This could be the employee's National Insurance number.

Note: If a password has not be set on the employee's record the
password will be blank. Anyone who receives the letter or contract
will be able to open it!

Restrict operations on
the PDF document

If you have set a password for the report, you can also restrict what the
reader can do with the PDF report when they are viewing it, such as not
being able to change or print the content.

You can restrict actions by disabling any of these options:

n Allow the document to be printed.

n Allow the document to be changed.

n Allow text and graphics to be copied (to the clipboard).

n Allow notes to be added and changed, to prevent comments
from being added.
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XML Options properties

Find these properties
Select the report by clicking the report name at the top of the Report Explorer pane. Then from the
Properties pane, view theXML Options area. If you can't see theXML Options title, click the

Categorized button at the top of the pane.

Property Description

XML style sheet You can use a XSLT style sheet to format (or transform) reports that you
export in XML format.

222



Report Designer

Conditional formatting

Introduction
Conditional formatting is used to draw attention to, or ignore, information when a condition is met.
For example, you could use conditional formatting to highlight balances that exceed certain amount,
indicate inactive records, or display negative numbers in bold and red.

Unlike filters that work on the whole report or a section of a report, you can control single pieces of
information on a report.

Conditional formatting is an expression, which can be applied tomost information on a report
whether it is a heading, calculation or text.

You can
n Exclude information from a report.

n Only show information of interest.

n Highlight information by colour.

n Add amessage or a warning to the report.

Use conditional formatting
To apply conditional formatting:

1. Select the item you want to work with.

2. From the Properties pane select Conditional Formatting then click the finder button .

The Conditional Formatting window appears.

3. To create a filter, click Edit on the Filter tab.

4. Click theProperties tab and select the properties you want to apply such as text styles and
colour.

5. Once the condition is complete, click OK.

Note: Conditional formatting works on individual items. Applying conditional formatting to an
item does not affect the line of information it is associated. If you want to hide or highlight the
whole line, you need to apply conditional formatting to all items in the line.
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Advanced conditional formatting

This feature is only
available for:
Sage 50 Accounts, Sage
50 HR, Sage 50 Payroll,
Sage 200.

You can also use expressions for conditional formatting filters.
When you are editing a filter, click Use Advanced Filter to enter an
expression. To display the expression editor by default when setting
conditional formatting, choose Tools > Options, then select the
Options tab and enableUse Advanced Conditional Formatting.

n Expressions can be used for conditional formatting.

n Operators are words such as NOT orLIKE, or symbols such as less than<, greater than>,

or equal to=. They include wildcards such as %, which replace single or multiple characters

and are used to search for values where there is more than one possible result.

n Functions are typically used for mathematical calculations andmanipulating text strings.
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Q: Conditional formatting
Click a question in the list to see the answer:

Why does the Expression Editor open instead of the Conditional Formatting window?

If the Expression Editor is displayed, this means the Advanced Conditional Formatting option is
enabled. To switch this off, choose Tools > Options, select theOptions tab and disableUse
Advanced Conditional Formatting.

Can I include a drill down on information with conditional formatting?

Yes. The drill down and conditional formatting properties are independent, so you can use both on
the same piece of information.

How do I change the appearance of information regardless of a condition?

You can change the style of the information such as colour, font or alignment.

To change the text style of an item, select Text Style from the Properties pane, then click the finder

button .
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Watermarks

Introduction
Use a watermark to place text or an image on the background of your report; such as "Draft" or
"Confidential", or a company logo. The watermark will be visible when you view or print the report.

Note: If you generate a batch report (or report selection), the watermark settings of the first
report will be used for all the following reports in the batch.

Set up a watermark
To set up a watermark:

1. Choose File > Watermark.

Note: You can also set the watermark from the Properties pane, by selecting
Watermark in the Appearance section.

2. Select whether you want either a text or image watermark.

l If you select a Text watermark, enter your text (or select a preset watermark text
such as Confidential orDraft); then select the font, size and colour.

l If you select an Image watermark, click Open to select the image file. The file will be
stored in your report.

To adjust the size of the image, useScale to set the image size as a percentage, or
enableScale image to fit page to make the image fill the page.

3. To set the angle of the watermark, select eitherDiagonal (to rotate 45 degrees) or
Horizontal.

4. If you want to make the watermark more or less visible, adjust the Transparency setting.
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Active Complete

Introduction
You can use theActive Complete feature to automatically suggest titles or totals for variables or
expressions that you add to your report. When you add a variable or expression, Active Complete
will ask you if you want to add a title or total to your report.

n To enable Active Complete, choose Tools > Options, then select theOptions tab and
enableUse Active Complete.

Use Active Complete

Field name Description

Where do you want
the title to appear?

Choose whether you want to add a title for the variable or expression, and
choose where you want it to be placed in the report.

n Do not add a title.

n Add a title in the section above where the variable was
placed.

n Add a title to the left of the variable.

What text do you
want in the title?

Enter the text to be used in the title text box.

Where do you want
the totals to appear?

Choose whether you want to add totals for the variable or expression, and
choose where you want them to be placed in the report.

n Do not add a total.

n Add a total in the next footer section only.

n Add a total for all of the following footer sections.

Output Length Themaximum length of the field when it is exported to CSV format. This is
useful if you intend to import the CSV file in another application, and the
field must be constrained to a certain length.

Width Set the width of the boxes used for the variable/expression, title and total.

Use variable width for
title

Use this option to set the width of the title box to fit the text.

Group variable with
title and total

Use this option to link the variable/expression and its title or totals in a
group.
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Field name Description

Remember settings
for this session

Use this option to keep these active complete settings until you close
Report Designer.
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Spell check your reports

Introduction
Improve the quality of your reports with this feature that highlights mistakes and suggests
alternative words to use.

All text in a report is checked, but not the variables. As you type, any words that are not recognised
are highlighted with a red underline to indicate a possible spelling problem.

Report Designer is set to use either a UK or US English dictionary when it is installed, according to
your PC's local settings.

Note: The spell checker will detect misspelt words, but not punctuation errors or grammatical
errors such as using the wrong word; for example, typing 'where' instead of 'were', or 'there'
instead of 'their'.

You can
n Check spelling automatically as you type.

n Check spelling all at once when you have finished the report.

n Addwords to the spell checker dictionary.

Using the spell checker
n To check spelling as you type, right-click the highlighted word and select an alternative word

from the list.

n To check spelling in the whole report, choose Tools > Check Spelling.

n To check which dictionary you are using (English UK or US), choose Tools > Options and
check theSpell Check Language option.
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See the topics in this section for information about using Report Designer with Sage 50 Accounts.
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Sage 50 Accounts: End of report

banner
The end of report banner indicates whether the report is complete. The banner is included in all
standard reports; but not to labels, letters or statements. The banner text is fixed, so it can't be
changed.

n To stop the banner being printed, open your Sage 50 Accounts software, then choose
Settings > Company Preferences. Select theReporting tab, and deselect Print End of
Report Banner.

n To add the banner to a report, select Add Data Field from the toolbar and draw a box in the
report footer, then chooseCompany andEND_OF_REPORT.
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Sage 50 Accounts: Address variables
Variable Description

C_ADDRESS TheC_ADDRESS variables display a compact company address that

excludes blank lines.

For example, if the company address has aStreet1 and a Town but no
Street2, there will be no blank line in the report forStreet 2.

ADDRESS TheADDRESS variables display the company address as it is entered

in Sage 50 Accounts, set inSettings > Company Preferences on the
Details tab.

If the company address has aStreet1 and a Town but noStreet 2, a
blank line will be displayed in the report forStreet2.

L_ADDRESS The L_ADDRESS variables will only display the company address if
Print Address on Stationery is enabled in Sage 50 Accounts. This is
set inSettings > Company Preferences on theReporting tab.
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Sage 50 Accounts example: Coded

variables
Coded variables use a value that has been set in your Sage software. Some coded variables
indicate a status as true or false, for example:

Variable Description

SALES_LEDGER.AC

COUNT_ON_HOLD

This variable returns 1 if the account is on hold (true) or 0 if it is not
(false).

SALES_LEDGER.TE

RMS_AGREED

This variable returns 1 if terms have been agreed on the account
(true) and 0 if they haven't (false).

Note: You can choose whether to display the coded (readable) variable or the value in your
report. To do this, select the variable, then from the Properties pane, click theDisplay Named
Values drop-down list and select Readable Value orRaw Value.

Some coded variables indicate a range of different statuses. For example, theSALES_

LEDGER.STATUS_NUMBER variable indicates the customer record status:

Number Status

0 Open

1 See Notes

2 Closed (OnHold)

3 Liquidation (OnHold)

4 Expired Credit Limit (On Hold)

5 Exceeded Credit Limit (On Hold)

6 Bad Debt (On Hold)

7 Solicitors (On Hold)

8 New

9 CashOnly

10 Prospect

11-99 Blank status, set as required
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Sage 50 Accounts example:

Conditional formatting

Conditional formatting examples
To set conditional formatting, select the item you want to work with then from the Properties pane

select Conditional Formatting and click the finder button . The Conditional Formatting window
appears.

Purpose Expression

To highlight transactions for
a particular date.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

AUDIT_SPLIT.DATE = #31/12/2011#

On theProperties tab, select the colour you want to use from the
Text Style options.

To highlight a value greater
than zero.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

SALES_LEDGER.BALANCE > 0

On theProperties tab, select the colour you want to use from the
Text Style options.

To use date/time functions
to highlight particular dates.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

AUDIT_SPLIT.DATE = Now() - Days(7)

On theProperties tab, select the colour you want to use from the
Text Style options.

To highlight transactions
details which end in the
word 'interest'.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

AUDIT_SPLIT.DETAILS LIKE "%interest"

On theProperties tab, select the colour you want to use from the
Text Style options.
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Purpose Expression

To highlight foreign
transactions that total more
than 50,000.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

Sum(AUDIT_SPLIT.FOREIGN_NET_AMOUNT) > 5

0000

On theProperties tab, select the colour you want to use from the
Text Style options.

To hide invoices with
product codes of "M".

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

INVOICE_ITEM.STOCK_CODE LIKE "M"

On theProperties tab, set Suppress Printing to True.

To hide sales orders
invoices with product codes
of "M".

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

SOP_ITEM.STOCK_CODE LIKE "M"

On theProperties tab, set Suppress Printing to True.

To hide purchase orders
with product codes of "M".

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

POP_ITEM.STOCK_CODE LIKE "M"

On theProperties tab, set Suppress Printing to True.

To hide negative values. On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:

SALES_LEDGER.BALANCE < 0

On theProperties tab, set Visible to False.

To add a warningmessage
if the balance is less than
zero.

First, add a text box to your report which includes the text
'warning'. Then select the text box and set the conditional
formatting as follows.

On the Filter tab, click Edit, then select Use Advanced Filter.
Enter the expression:
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Purpose Expression

SALES_LEDGER.BALANCE < 0

On theProperties tab, set Suppress Printing to True.

Advanced conditional formatting examples

The following examples use advanced conditional formatting. Before you try these examples,
choose Tools > Options, then select theOptions tab and enableUse Advanced Conditional
Formatting.

Purpose Expression

To highlight transactions
for a particular date in red.

If AUDIT_SPLIT.DATE = #31/12/2011# then

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")

To highlight negative
values in red, and other
values in black.

If SALES_LEDGER.BALANCE <0 then

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")

To use date/time functions
to highlight particular
dates in red.

If AUDIT_SPLIT.DATE = Now() - Days(7) the

n

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")

To highlight transactions
details which end in the
word 'balance'.

If AUDIT_SPLIT.DETAILS LIKE "%balance" th

en

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")
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Purpose Expression

To highlight foreign
transactions that total
more than 50,000.

If Sum(AUDIT_SPLIT.FOREIGN_NET_AMOUNT) >

50000 then

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")

To hide invoices with
product codes of "M".

If INVOICE_ITEM.STOCK_CODE LIKE "M" then

begin

SuppressPrinting := True;

end

To hide sales orders
invoices with product
codes of "M".

If SOP_ITEM.STOCK_CODE LIKE "M" then

begin

SuppressPrinting := True;

end

To hide purchase orders
with product codes of "M".

If POP_ITEM.STOCK_CODE LIKE "M" then

begin

SuppressPrinting := True;

end

To hide negative values.
If SALES_LEDGER.BALANCE < 0 then

begin

Visible := False;

end

To add a warning
message if the balance is
less than zero.

First, add a text box to your report which includes the text 'warning'.
Then select the text box and add the conditional formatting as
follows, which will prevent the box from appearing if the balance is
above 0.

If SALES_LEDGER.BALANCE >= 0 then

begin

SuppressPrinting :=True;

end
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Sage 50 Accounts example:

Expressions
Here are some examples of commonly used expressions.

Purpose Expression

To get a fixed payment due
date for an invoice (for
example, 30 days from date
of invoice).

INVOICE.INVOICE_DATE+30

To get a payment due date
for an invoice based on
individual customer terms.

INVOICE.INVOICE_DATE+SALES_LEDGER.PA

YMENT_DUE_DAYS

To calculate what
percentage of the Sales
Price the Unit Price is.

INVOICE_ITEM.UNIT_PRICE/STOCK.SALES_

PRICE*100

To calculate the VAT
element of the Aged
Balance Variable.

AUDIT_SPLIT.AGED_BALANCE-((AUDIT_SPL

IT.AGED_BALANCE*AUDIT_SPLIT.NET_AMOU

NT)/AUDIT_SPLIT.GROSS_AMOUNT)

To calculate the Gross Unit
Price of an invoice item.

INVOICE_ITEM.UNIT_PRICE*(INVOICE_ITE

M.TAX_RATE+100)/100

To calculate the Unit Price
After Discount on an
invoice.

INVOICE_ITEM.UNIT_PRICE-(INVOICE_ITE

M.UNIT_PRICE*INVOICE_ITEM.DISCOUNT_R

ATE)/100

As long as no unit price values equal 0, you can also use the
following expression:

INVOICE_ITEM.NET_AMOUNT/INVOICE_ITEM

.QUANTITY
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Sage 50 Accounts example:

Expressions with operators
Some of the following examples use advanced conditional formatting. Before you try these
examples, choose Tools > Options, then select theOptions tab and enableUse Advanced
Conditional Formatting.

Operator Action

+ Use a plus sign to add values.

To get a payment date that is 30 days after an invoice was sent:

INVOICE.INVOICE_DATE+30

This example can be used to display the value on the report or as part of
another expression.

- Use aminus sign to subtract values.

To calculate the difference between gross and net amounts on an invoice:

INVOICE.INVOICE_GROSS-INVOICE.INVOICE_NET

This expression can be used to display the value on the report or as part of
another expression.

* Use an asterisk to multiply values.

To calculate what percentage of the sales price the unit price is:

INVOICE_ITEM.UNIT_PRICE/STOCK.SALES_PRICE*100

This expression can be used to display the value on the report or as part of
another expression.

/ Use a forward slash to divide values. Divide. For example, 5/2 = 2.5.

^ Use^ for exponential functions; for example, 3^2means 3 to the power of 2,
which results in 9.

This expression can be used to display the value on the report or as part of
another expression.

% Use a percent symbol to calculate percentages.
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Operator Action

If you calculate5%2, you get 1.

This example can be used to display the value on the report or as part of
another expression.

NOT Use a logical NOT to test is a statement is false.

To check if invoice types do not contain "SOP":

if NOT Contains(INVOICE.INVOICE_TYPE, "SOP") th

en

TextStyle->Color:=NamedColor("Red");

This example is an advanced conditional formatting expression.

LIKE UseLIKE to test if a string contains information.

To only include information for the customer with the account reference
"Johnson":

SALES_LEDGER.ACCOUNT_REF LIKE "JOHNSON"

This example can be used as a filter expression or for conditional formatting.

NOT LIKE UseNOT LIKE to test if a string does not contain information..

To exclude information for the customer with the account reference
"Johnson":

SALES_LEDGER.ACCOUNT_REF NOT LIKE "Johnson"

This example can be used as a filter expression or for conditional formatting.

AND Use a logical AND to test if all statements are true.

Customers with both a turnover for the year to date of less than £1000, and a
prior year balance that is greater than £2500:

SALES_LEDGER.TURNOVER_YTD<1000 AND SALES_LEDGER

.PRIOR_YEAR>2500

This example can be used as a filter expression or for conditional formatting.

OR Use a logical OR to test if at least one or another statement is true.
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Operator Action

To include customers with either: a turnover for the year to date of less than
£1000; or a prior year balance that is greater than £2500:

SALES_LEDGER.TURNOVER_YTD<1000 OR SALES_LEDGER.

PRIOR_YEAR>2500

This example can be used as a filter expression or for conditional formatting.

() Use brackets (parentheses) to group parts of the expression, to define the
order in which it is evaluated.

To include customers with a turnover between £1000 - £2000, and whose prior
year balance is greater than £2500:

(SALES_LEDGER.TURNOVER_YTD>1000 AND SALES_LEDGE

R.TURNOVER_YTD<2000)

AND SALES_LEDGER.PRIOR_YEAR>2500

This example can be used as a filter expression or for conditional formatting.

{} Use curly brackets (braces) to enclosemultiple lines in an expression.

If Contains(SALES_LEDGER.NAME, "Johnson") then

{

TextStyle->Color:=NamedColor("Red");

TextStyle->Underline:=1;

}

This example is an advanced conditional formatting expression.

BEGIN Begin is a text equivalent of {.

END End is the text equivalent of }.

, Use a comma to separate items.

; Use a semi-colon to separatemultiple lines.

If Contains(SALES_LEDGER.NAME, "Johnson") then

Begin

TextStyle->Color:=NamedColor("Red");

TextStyle->Underline:=1;
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Operator Action

End

This example is an advanced conditional formatting expression.

TRUE Set a variable to be true; for example, to set the word wrap property to true:

WordWrap:=True

FALSE Set a variable to be false; for example, to set the word wrap property to false:

WordWrap:=False

IF

THEN

ELSE

To construct a conditional statement, useIF, THEN, ELSE.

If sales ledger names contain "Johnson", they appear red and with a shadow
of depth 1. Otherwise the names appear blue:

If Contains(SALES_LEDGER.NAME,"Johnson") then

Begin

TextStyle->Color:=NamedColor("Red");

Formatting->Border->DropShadowDepth:=1;

End

Else

TextStyle->Color:=NamedColor("Blue")

This example is an advanced conditional formatting expression.

SWITCH UseSWITCH to construct a conditional statement.

To set the colour of the country code according to its value; red for Germany
(DE), blue for France (FR), and green for any other country.

Switch COUNTRY_CODE.CODE

Case "DE":

TextStyle->Color:=NamedColor("Red")

Case "FR":

TextStyle->Color:=NamedColor("Blue")

Default:

Begin

TextStyle->Color:=NamedColor("Green");
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Operator Action

End

This example is an advanced conditional formatting expression.

> Compare if a value is greater than another value.

Customers with a turnover for the year to date that is greater than £1000:

SALES_LEDGER.TURNOVER_YTD>1000

< Compare if a value is less than another value.

Customers with a turnover for the year to date that is less than £1000:

SALES_LEDGER.TURNOVER_YTD<1000

This example can be used as a filter expression or for conditional formatting.

= Compare if a value is equal to another value.

Customers with a turnover for the year to date that is equal to £1000:

SALES_LEDGER.TURNOVER_YTD=1000

This example can be used as a filter expression or for conditional formatting.

>= Compare if a value is greater than or equal to another value.

Customers with a turnover for the year to date that is greater than or equal to
£1000:

SALES_LEDGER.TURNOVER_YTD>=1000

This example can be used as a filter expression or for conditional formatting.

<= Compare if a value is less than or equal to another value.

Customers with a turnover for the year to date that is less than or equal to
£1000:

SALES_LEDGER.TURNOVER_YTD<=1000

This example can be used as a filter expression or for conditional formatting.

<> Compare if a value is not equal to another value.
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Operator Action

Customers with a turnover that is not equal to £1000:

SALES_LEDGER.TURNOVER_YTD<>1000

This example can be used as a filter expression or for conditional formatting.

-> This is used to select properties.

Tomake values of less than 0 appear red:

If SALES_LEDGER.BALANCE<0 then TextStyle->Color

:=

NamedColor("Red")

The property is only set if the statement on the left is true.

This example is an advanced conditional formatting expression.

:= This is used to assign a value.

Tomake values of less than 0 appear red:

If SALES_LEDGER.BALANCE<0 then TextStyle->Color

:= NamedColor("Red")

This example can be used as an Advanced Conditional Formatting
expression.

Note: You cannot use := to assign a value to a variable (data field), as
these are read-only. For example, you cannot use Text:= with a variable,
you can only use this with a text box.

? : To show balances greater than 0 as credit, and balances less than 0 as debit:

SALES_LEDGER.BALANCE>0?"Credit":"Debit"

In this example, 'Credit' appears if a value is more than 0 because it is to the
left of ':'. 'Debit' appears for values that do not obey the expression to the left
of '?' , because it is to the right of ':'.

This example can be used to display the value on the report or as part of
another expression.
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Sage 50 Accounts example: Filters
n To set a filter on the whole report, select Report > Filters.

n To set a filter on a section in a report, select the section, then select Filter in the Properties
pane and click the finder button .

Filter examples

Action Filter

To exclude control
accounts from nominal
reports.

NOMINAL_LEDGER.ACCOUNT_TYP

E Does not equal 4

To exclude fully paid
transactions.

AUDIT_HEADER.FOREIGN_AGED_

BALANCE Does not equal 0

To exclude customers with
a zero balance.

SALES_LEDGER.BALANCE Does

not equal 0

To exclude suppliers with a
zero balance.

PURCHASE_LEDGER.BALANCE Do

es not equal 0

To exclude the suspense
account.

Note: This example
assumes you are
using the code 9998
for your suspense
account.

AUDIT_SPLIT.NOMINAL_CODE D

oes not equal 9998

To include supplier invoices
over a certain value
(exclude below the value).

The example used a
notional value of £100.

AUDIT_HEADER.FOREIGN_NET_A

MOUNT Less than "-100"

or you could use

AUDIT_SPLIT.FOREIGN_NET_AM

OUNT Less than "-100"

245



8 | Sage 50 Accounts

Advanced filter examples
To enter the following examples, select Use Advanced Filterwhen you set the filter.

Action Filter expression

To include customers that
have exceeded their credit
limit (exclude customers
within credit limit).

SALES_LEDGER.BALANCE >

SALES_LEDGER.CREDIT_LI

MIT

To include suppliers where
the credit limit has been
exceeded (exclude
suppliers where the credit
limit has not been
exceeded).

PURCHASE_LEDGER.BALANC

E > PURCHASE_LEDGER.CR

EDIT_LIMIT
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Sage 50 Accounts example: Joins
In Sage 50 Accounts theCustomers andInvoices tables are separate tables, but they are

related because they both include customer account numbers.

You can connect the tables by using a join on the account number. For more information, see Join
tables on page 65.

Customers Table (part of it)

Account Number Name Credit Limit

2706 Dodd Ltd £12000

1302 Gatens Inc £50,000

Invoices Table (part of it)

Invoice Number Amount Account Number

44621 £2000 2706

44622 £15,000 1302
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Sage 50 Accounts example:

Wildcards in an expression
The following examples usewildcard symbols in the expression that canmatch any other text.

Wildcard Description Example

% Use percent (%) as a

substitute for multiple
characters.

Match all sales ledger
accounts that start with a
letter 'A'.

SALES_LEDGER.ACCOUNT_R

EF LIKE "A%"

% Match all sales ledger
accounts that end in the
letter 'E'.

SALES_LEDGER.ACCOUNT_R

EF LIKE "%E"

_ Use underscore (_) as a

substitute for multiple
characters.

Match sales transactions
SI, SC, SR, SA and so on.

AUDIT_SPLIT.TYPE LIKE

"S_"

_ Match sales accounts 400,
410, 420, 430, 450, 460,
470 and so on.

SALES_LEDGER.ACCOUNT_R

EF LIKE "4_0"
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Sage Instant Accounts: Features
The following features are not available with Instant Accounts:

n Criteria (add and remove) used when you want to bemore selective about the data that
appears in a report.

n Join Editor.

n Advanced conditional formatting used to draw attention to, or ignore information when
conditions aremet. Unlike standard conditional formatting based on one condition, advanced
is based onmultiple conditions.

n The Snippets Manager and theSave As Snippet option in the Expression Editor.
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Sage 50 HR
See the topics in this section for information about using Report Designer with Sage 50 HR.
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Sage 50 HR example: Conditional

formatting

Conditional formatting examples
To set conditional formatting, select the item you want to work with then from the Properties pane

select Conditional Formatting and click the finder button . The Conditional Formatting window
appears.

Purpose Expression

Highlight absences when
the start date is today.

On the Filter tab, click Edit, then select Use
Advanced Filter. Enter the expression:

DateTimeToFormattedString(vw_

absence.AbsenceFromDate , "d")

= DateTimeToFormattedString(

Now() , "d")

On theProperties tab, select the colour you want
to use from the Text Style options.

Highlight absences which
have a reason description
ending with the word
'unknown'.

On the Filter tab, click Edit, then select Use
Advanced Filter. Enter the expression:

vw_absence.ReasonDescription

LIKE "%unknown"

On theProperties tab, select the colour you want
to use from the Text Style options.

Highlight absences if the
total duration of all absence
periods is greater than 10.

On the Filter tab, click Edit, then select Use
Advanced Filter. Enter the expression:

sum(vw_absence.Duration) > 10

On theProperties tab, select the colour you want
to use from the Text Style options.
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Advanced conditional formatting examples

The following examples use advanced conditional formatting. Before you try these examples,
choose Tools > Options, then select theOptions tab and enableUse Advanced Conditional
Formatting.

Purpose Expression

Highlight absences in red
when the start date is
today.

If DateTimeToFormattedString(vw_absen

ce.AbsenceFromDate , "d") = DateTimeT

oFormattedString(Now() , "d") then

TextStyle->Color:=NamedColor("Red")

else

TextStyle->Color:=NamedColor("Black")

Highlight absences in red
which have a reason
description ending with the
word 'unknown'.

If vw_absence.ReasonDescription LIKE

"%unknown" then

TextStyle->Color:=NamedColor("Red")

else

TextStyle->Color:=NamedColor("Black")

Highlight absences in red, if
the total duration of all
absence periods is greater
than 10.

If sum(vw_absence.Duration) > 10 then

TextStyle->Color:=NamedColor("Red")

else

TextStyle->Color:=NamedColor("Black")
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Sage 50 HR example: Filters
The example below is an expression which is entered as an advanced filter. To enter this example,
select Use Advanced Filter.

Action Expression

Filter report to only show
employees that are absent
today.

(vw_absence.AbsenceFromDate <= Now() AND

vw_absence.ToDate >= Now()) OR (vw_absenc

e.ToDate = null)
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Sage 50 HR example: Wildcards in an

expression
The following examples usewildcard symbols in the expression that canmatch any other text.

Variable Description

vw_company_address.Postcode LIK

E "NE%"

Find employees whose post
code start with 'NE'.

vw_person.Surname LIKE "%son"
Find employees whose
surname ends with 'son'.
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Sage 50 HR: Features
The following features are not available with Sage 50 HR:

n Join Editor.

n Batch reporting.
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Sage 50 Payroll
See the topics in this section for information about using Report Designer with Sage 50 Payroll.
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Sage 50 Payroll example: Coded

variables
Coded variables use a value that has been set in your Sage software. For example, some coded
variables indicate a status.

Variable Description

AbsenceHistory.HalfDayT

ype

This variable returns 0 if the absence is for a full
day, 1 for themorning (AM), or 2 for the
afternoon (PM).

Employees.PayStatus
This variable returns 0 if the pay status is OK, 1
if it is on hold, or 2 if there is a trade dispute.

Note: You can choose whether to display the coded (readable) variable or the value in your
report. To do this, select the variable, then from the Properties pane, click theDisplay Named
Values drop-down list and select Readable Value orRaw Value.
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Sage 50 Payroll example: Conditional

formatting

Conditional formatting examples
To set conditional formatting, select the item you want to work with then from the Properties pane

select Conditional Formatting and click the finder button . The Conditional Formatting window
appears.

Purpose Expression

Highlight employees
who have taken less
than 5 days holiday.

Employees.HolDaysTaken < 5

On theProperties tab, select the colour you want to use from the Text
Style options.

Highlight absences
since a particular date.

Highlight absences with a start date since 1 August 2013:

AbsenceHistory.AbsStartDate >= #2013-08-01T

00:00:00#

On theProperties tab, select the colour you want to use from the Text
Style options.

Highlight employees
with over 20 days
remaining holiday.

On the Filter tab, click Edit, then select Use Advanced Filter. Enter
the expression:

((Employees.HolDaysBF + Employees.HolDaysCF

+ Employees.EmployeeEntitlement) - (Employe

es.HolDaysTaken + Employees.HolDaysBookedTh

isPayPeriod)) > 20

On theProperties tab, select the colour you want to use from the Text
Style options.

Advanced conditional formatting examples

The following examples use advanced conditional formatting. Before you try these examples,
choose Tools > Options, then select theOptions tab and enableUse Advanced Conditional
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Formatting.

Purpose Expression

Highlight employees
that have left in red text.

If Employees.WorkEndDate <> NULL

then

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")

Highlight employees
with over 20 days
remaining holiday in red
text.

If ((Employees.HolDaysBF + Employees.HolDay

sCF + Employees.EmployeeEntitlement) - (Emp

loyees.HolDaysTaken + Employees.HolDaysBook

edThisPayPeriod)) > 20

then

TextStyle->Color := NamedColor("Red")

else

TextStyle->Color := NamedColor("Black")
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Sage 50 Payroll example: Expressions
Here are some examples of commonly used expressions.

Purpose Expression

To add the processing
month and year to the
subject line of an email
payslip.

CompanyDetails.Name + " payslip for " + Date

TimeToFormattedString (DateParameters.Proces

sDate, "MMMM/yy")

To calculate the total
value of all non-
statutory payment or
deduction types.

Payments:

CurrentPay.PreTaxPay + CurrentPay.PstTaxPay

Deductions:

CurrentPay.PreTaxDed + CurrentPay.PstTaxDed

To show the age of an
employee in years and
months.

Age in years andmonths:

CString((TotalMonths(Employees.DateOfBirth,

Now()) - ((DateTimeToFormattedString(NOW(),

"dd"))<(DateTimeToFormattedString(Employees.

DateOfBirth, "dd"))?2:1)) / 12) + " yrs, " +

CString((TotalMonths(Employees.DateOfBirth,

Now()) - ((DateTimeToFormattedString(NOW(),

"dd"))<(DateTimeToFormattedString(Employees.

DateOfBirth, "dd"))?2:1)) % 12) + " mths"

Age in years:

(DateParameters.ProcessDate - Employees.Date

OfBirth) / 365.25

Age inmonths:

(DateParameters.ProcessDate - Employees.Date

OfBirth) / 30.4375

Tip: To display only full years or months, set theMax decimals
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Purpose Expression

setting to 0 (zero). To do this, select the variable, then from the
Properties pane, select Formatting from theAppearance area and
then click the finder button . On the Formatting window, open the
Numeric tab, then set theMax decimals value to 0 (zero).

If you want to ensure the age rounds down to the previous year rather
than up, you can also use the following expression.

Age in years:

Floor((DateParameters.ProcessDate - Employee

s.DateOfBirth) / 365.25)

To show an
employee's length of
service in years and
months.

CString((TotalMonths(Employees.WorkStartDat

e, Now()) - ((DateTimeToFormattedString(NOW(

), "dd"))<(DateTimeToFormattedString(Employe

es.WorkStartDate, "dd"))?2:1)) / 12) + " yr

s, " + CString((TotalMonths(Employees.WorkSt

artDate, Now()) - ((DateTimeToFormattedStrin

g(NOW(), "dd"))<(DateTimeToFormattedString(E

mployees.WorkStartDate, "dd"))?2:1)) % 12) +

" mths"

To show an
employee's total
holiday entitlement,
including any holidays
brought or carried
forward from a
previous year.

Holidays calculated in days:

Employees.HolDaysBF + Employees.HolDaysCF +

Employees.EmployeeEntitlement

Holidays calculated in hours:

Employees.HolHoursBF + Employees.HolHoursCF

+ Employees.EmployeeEntitlement

To show the holidays
remaining for an
employee.

Holidays calculated in days:

(Employees.HolDaysBF + Employees.HolDaysCF +

Employees.EmployeeEntitlement) - ( Employees

.HolDaysTaken + Employees.HolDaysBookedThisP
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Purpose Expression

ayPeriod)

Holidays calculated in hours:

(Employees.HolHoursBF + Employees.HolHoursCF

+ Employees.EmployeeEntitlement) - (Employee

s.HolHoursTaken + Employees.HolHoursBookedTh

isPayPeriod)

To show the full year
values from the
Information tab of the
Enter Payments
window.

These values include both the year to date YTD value and the current un-
updated value. To show this value on a pre-update report, add the YTD
value from the Employees table to the current un-updated value from the
CurrentPay table.

To show the value for total gross pay to date:

Employees.TotalGrossTD + CurrentPay.TotalGro

ss

To show the value of student loans repaid this year:

Employees.SLRPaidTD + CurrentPay.SLRPaymentC

ur + CurrentPay.SLRPaymentHol

To show an
employee's projected
yearly salary based on
their current monthly
payment type.

First, you need to know the number assigned to the payment type in your
custom report setting. You can check this withinCompany > Custom
Reports.

You can then use the following expression, replacing the number of

Total1 with the number of the payment type:

PaymentAnalysis.Total1 * 12

To show the amount of
the employee's current
net pay payable into
their first bank
account.

CurrentPay.RndNetPay - CurrentPay.RndNetPayS

ecAcc

To show an
employee's national

Current values:
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Purpose Expression

insurance value net of
rebate.

CurrentPay.EmployeeNIC - CurrentPay.Employee

Rebate

YTD values:

Employees.EmployeeNICTD - Employees.Employee

Rebate

Historical values:

Updates.EmployeeNIC - Updates.EmployeeRebate

To include employer's
pension contributions
on a payslip layout.

Current values:

CurrentPay.EmployerPensCur + CurrentPay.Empl

oyerPensHol

YTD values including the current period:

Employees.PensnEmployerTD + CurrentPay.Emplo

yerPensCur + CurrentPay.EmployerPensHol

To show an
employee's holiday
fund values accrued
and carried forward.

To show an accrued fund:

CurrentPay.HolidayFundAccrued + CurrentPay.H

olidayFundAccruedHol

To show a fund carried forward to the next pay period:

Employees.HolidayFund + CurrentPay.HolidayFu

ndAccrued + CurrentPay.HolidayFundAccruedHol

- CurrentPay.HolidayFundPaid - CurrentPay.Ho

lidayFundPaidHol

To exclude P45 values
from gross and tax
year to date values.

Total gross pay:

Employees.TotalGrossTD - Employees.P45Gross

Taxable gross pay:
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Purpose Expression

Employees.TaxGrossTD - Employees.P45Gross

PAYE:

Employees.TotalTaxTD - Employees.P45Tax

To show an
employee's title,
forename and
surnamewithout
spaces.

Employees.Title + " " + Employees.Forename +

" " + Employees.Surname

To show an
employee's first
forename, excluding
any second forename.

Substring(Employees.Forename,0,IndexOf(Emplo

yees.Forename," ")) + " "

You can use this within a larger expression, for example:

"Dear " + Substring(Employees.Forename,0,Ind

exOf(Employees.Forename," ")) + ","

To show the
employer's national
insurance value net of
rebate.

Current:

CurrentPay.EmployerNIC - CurrentPay.Employer

Rebate

Year to date:

Employees.EmployerNICTD - Employees.Employer

Rebate

Historical:

Updates.EmployerNIC - Updates.EmployerRebate
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Sage 50 Payroll example: Expressions

with operators
Here are some examples of using operators in expressions.

Operator Action

+ Use a plus sign to add values.

This filter is active for all employees whose net pay in the full tax year to date,
plus an additional value of £500.00, is greater than £15,000.

(Employees.NetPayTD + 500.00) > 15000

- Use aminus sign to subtract values.

This filter is active for all employees whose net pay in the full tax year to date,
minus an additional value of £500.00, is greater than £15,000.

(Employees.NetPayTD - 500.00) > 15000

* Use an asterisk to multiply values.

This filter is active for all employees whose net pay in the full tax year to date,
multiplied by 1.5, is greater than £15,000.

(Employees.NetPayTD * 1.5) > 15000

/ Use a forward slash to divide values. Divide. For example, 5/2 = 2.5.

This filter is active for all employees whose net pay in the full tax year to date,
divided by 2, is greater than £15,000.

(Employees.NetPayTD / 2) > 15000

^ Use^ for exponential functions; for example, 3^2means 3 to the power of 2,
which results in 9.

This expression can be used to display the value on the report or as part of
another expression.

% Use a percent symbol to calculate percentages.

If you calculate5%2, you get 1.
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Operator Action

This example can be used to display the value on the report or as part of
another expression.

LIKE UseLIKE to test if a string contains information.

Employees.Reference LIKE "Ref1"

This filter is active for the employee with the reference Ref1.

NOT Use a logical NOT to test is a statement is false.

This filter is active for all employees apart from the employee with the
reference Ref1.

Employees.Reference NOT LIKE "Ref1"

AND Use a logical AND to test if all statements are true.

This filter is active for employees where their net pay in the full tax year to
date is greater than £5000, but their gross National Insurance contributions
are less than £500.

Employees.NetPayTD > 5000 AND Employees.NICGro

ssTD < 500

OR Use a logical OR to test if at least one or another statement is true.

This filter is active for employees where their net pay in the full tax year to
date is greater than £5000, or their gross National Insurance contributions are
more than £1500.

Employees.NetPayTD > 5000 OR Employees.NICGros

sTD > 1500

NULL You can use theNULL operator to specify that a value contains no data.

Youmust use this operator with the equal (=) operator.

Note: Not all blank areas within Sage 50 Payroll are null values. This
operator is most commonly used with a date value, where the date can
be left blank.

This filter is active for all employees with no work end date specified within
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Operator Action

their employee record .

Employees.WorkEndDate = NULL

() Use brackets (parentheses) to group parts of the expression, to define the
order in which it is evaluated.

If you need the filter to be active for monthly paid employees, but also for any
employees who are paid in cash on a weekly basis, you could enter the filter
as follows:

Employees.PaymentPeriod LIKE "Monthly" OR Empl

oyees.PaymentPeriod LIKE "Weekly" AND Employee

s.PaymentMethod LIKE "Cash"

However, when you view this filter it is not clear which of the conditions
belong together - this filter can also be interpreted as including either monthly
or weekly paid employees, but only where the payment method is set to
cash. To ensure the filter applies for the correct employees, you can insert
brackets as follows:

Employees.PaymentPeriod LIKE "Monthly" OR (Emp

loyees.PaymentPeriod LIKE "Weekly" AND Employe

es.PaymentMethod LIKE "Cash")

> Compare if a value is greater than another value.

This filter is active for all employees whose net pay in the full tax year to date
is greater than £15,000.

Employees.NetPayTD > 15000

< Compare if a value is less than another value.

This filter is active for all employees whose net pay in the full tax year to date
is less than £15,000.

Employees.NetPayTD < 15000

= Compare if a value is equal to another value.

This filter is active for all employees whose net pay in the full tax year to date
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Operator Action

is exactly £15,000.

Employees.NetPayTD = 15000

>= Compare if a value is greater than or equal to another value.

This filter is active for all employees whose net pay in the full tax year to date
is greater than or equal to £15,000.

Employees.NetPayTD >= 15000

<= Compare if a value is less than or equal to another value.

This filter is active for all employees whose net pay in the full tax year to date
is less than or equal to £15,000.

Employees.NetPayTD <= 15000

<> Compare if a value is not equal to another value.

This filter is active for all employees whose net pay in the full tax year to date
has any value other than £15,000.

Employees.NetPayTD <> 15000
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Sage 50 Payroll example: Filters
Note: Formore information about filters, see Filter information on page 158.

n To set a filter on the whole report, select Report > Filters.

n To set a filter on a section in a report, select the section, then select Filter in the Properties
pane and click the finder button .

Filter examples

Action Filter

To show only employees
who were born on or after a
set date.

This example shows employees who were born on or
after 1 January 1980:

Employees.DateOfBirth Greater tha

n or equal 01/01/1980

To show only employees
with a value for their current
net pay.

CurrentPay.RndNetPay Does not equ

al 0

Advanced filter examples
To enter the following examples, select Use Advanced Filterwhen you set the filter.

Action Filter expression

To show only current
employees.

Employees.WorkEndDate = NULL

To show only employees
who have left.

Employees.WorkEndDate <> NULL

To show all employees who
worked in a particular tax
year.

This example shows all employees who worked for the
company in the 2012/13 tax year:

(Employees.WorkEndDate >= #2012-04-0

6# OR Employees.WorkEndDate = NULL) A

ND Employees.WorkStartDate <= #2013-0

4-05#
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Action Filter expression

To show employees who
either started or left within a
particular date range.

This example shows all employees who either started or left
the company between 6 April 2012 and 5 April 2013:

(Employees.WorkStartDate >= #2012-04-

06# AND Employees.WorkStartDate <= #2

013-04-05#

OR (Employees.WorkEndDate >= #2012-0

4-06# AND Employees.WorkEndDate <= #2

013-04-05#)

To show only employees
who started work in a
specific year.

This example shows employees who started work in 2013:

DateTimeToFormattedString(Employees.W

orkStartDate, "yyyy") = "2013"

To show only one payment
type on a post-update
report.

This example shows only the Salary payment type:

PaymentHistory.PaymentDescription LIK

E "Salary"

To show several specific
payment types on a post-
update report.

This example shows the payment types Salary, Bonus and
Commission:

PaymentHistory.PaymentDescription IN

("Salary", "Bonus", "Commission")

To show all employees with
a tax code that ends with a
particular letter.

This example shows all employees whose tax code ends with
the letter L:

Employees.TaxCode LIKE "%L"

To show employees whose
national insurance number
begins with anything except
specific letters.

This example shows employees whose national insurance (NI)
number begins with any letters other than "JB":

Employees.NINumber NOT LIKE "JB%"

To show all employees with
a particular format of tax
code.

This example shows employees who have a K tax code
followed by three numbers:
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Action Filter expression

Employees.TaxCode LIKE "K___"

To show all employees who
are paid using a specific
method and frequency.

This example shows all employees who are paid by cheque on
amonthly basis:

Employees.PaymentMethod LIKE "Cheque"

AND Employees.PaymentPeriod LIKE "Mon

thly"
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Sage 50 Payroll example: Wildcards

in an expression
The following examples use a% symbol in the expression to indicate a wildcard, that canmatch any

other text.

Wildcard Description Example

% Use percent (%) as a

substitute for multiple
characters.

Employees whose tax code ends with the letter L:

Employees.TaxCode LIKE "%L"

_ Use underscore (_) as a

substitute for a single
character.

Employees who have a tax code that begins with a
K and is followed by three numbers:

Employees.TaxCode LIKE "K___"
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Sage 50 Payroll: Features
The following features are not available with Sage 50 Payroll:

n Join Editor.

n Batch reporting.
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